On 24/1/24 11:16, Philippe Mathieu-Daudé wrote:
accel/tcg/ ought to be target agnostic. This series remove
some x86 code, addressing part of "Work still remains" from
Anjo's series:

Oops, s/Anjo/Anton/

https://lore.kernel.org/qemu-devel/20240119144024.14289-1-a...@rev.ng/

Based-on: <20240124075609.14756-1-phi...@linaro.org>
           "Move perf and debuginfo support to tcg"

Philippe Mathieu-Daudé (9):
   accel/tcg: Rename tcg_ss[] -> tcg_specific_ss[] in meson
   accel/tcg: Rename tcg_cpus_destroy() -> tcg_cpu_destroy()
   accel/tcg: Rename tcg_cpus_exec() -> tcg_cpu_exec()
   accel/tcg: Un-inline icount_exit_request() for clarity
   accel/tcg: Hoist CPUClass arg to functions with external linkage
   accel/tcg: Introduce TCGCPUOps::need_replay_interrupt() handler
   target/i386: Extract x86_need_replay_interrupt() from accel/tcg/
   accel/tcg: Introduce TCGCPUOps::cpu_exec_halt() handler
   target/i386: Extract x86_cpu_exec_halt() from accel/tcg/

  accel/tcg/tcg-accel-ops.h           |   4 +-
  include/hw/core/tcg-cpu-ops.h       |   7 ++
  target/i386/tcg/helper-tcg.h        |   2 +
  accel/tcg/cpu-exec.c                | 125 ++++++++++++----------------
  accel/tcg/tcg-accel-ops-mttcg.c     |   4 +-
  accel/tcg/tcg-accel-ops-rr.c        |   4 +-
  accel/tcg/tcg-accel-ops.c           |   4 +-
  target/i386/tcg/sysemu/seg_helper.c |  23 +++++
  target/i386/tcg/tcg-cpu.c           |   2 +
  accel/tcg/meson.build               |  12 +--
  10 files changed, 103 insertions(+), 84 deletions(-)



Reply via email to