On 22/7/24 06:07, Yao Xingtao wrote:
use ranges_overlap() instead of open-coding the overlap check to improve
the readability of the code.

Signed-off-by: Yao Xingtao <yaoxt.f...@fujitsu.com>
---
  system/memory_mapping.c | 4 ++--
  1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/system/memory_mapping.c b/system/memory_mapping.c
index 6f884c5b90c9..ca2390eb8044 100644
--- a/system/memory_mapping.c
+++ b/system/memory_mapping.c
@@ -12,6 +12,7 @@
   */
#include "qemu/osdep.h"
+#include "qemu/range.h"
  #include "qapi/error.h"
#include "sysemu/memory_mapping.h"
@@ -353,8 +354,7 @@ void memory_mapping_filter(MemoryMappingList *list, int64_t 
begin,
      MemoryMapping *cur, *next;
QTAILQ_FOREACH_SAFE(cur, &list->head, next, next) {
-        if (cur->phys_addr >= begin + length ||
-            cur->phys_addr + cur->length <= begin) {
+        if (!ranges_overlap(cur->phys_addr, cur->length, begin, length)) {

Maybe this one is easier to read the other way around:

     if (!ranges_overlap(begin, length, cur->phys_addr, cur->length)) {

Anyhow,

Reviewed-by: Philippe Mathieu-Daudé <phi...@linaro.org>
Tested-by: Philippe Mathieu-Daudé <phi...@linaro.org>

Reply via email to