On 28/10/26 21:41, Pierrick Bouvier wrote:
On 10/28/2026 12:39 PM, Pierrick Bouvier wrote:
On 10/28/2026 11:25 AM, Philippe Mathieu-Daudé wrote:
The Makefile needs a toolchain we do not have and qemu-mipsel,
which no longer provides the R5900 CPU. Move the tests next to
the bare-metal harness, register them in meson.build, and remove
the Makefile and the obsolete README.

Signed-off-by: Philippe Mathieu-Daudé <[email protected]>
---
  .../system}/test_r5900_div1.c                 |  0
  .../system}/test_r5900_divu1.c                |  0
  .../system}/test_r5900_madd.c                 |  0
  .../system}/test_r5900_maddu.c                |  0
  .../system}/test_r5900_mflohi1.c              |  0
  .../system}/test_r5900_mtlohi1.c              |  0
  .../system}/test_r5900_mult.c                 |  0
  .../system}/test_r5900_multu.c                |  0
  tests/tcg/mips/user/isa/r5900/Makefile        | 32 -------------------
  tests/tcg/mips/user/isa/r5900/README          |  6 ----
  tests/tcg/mips64el/system/meson.build         | 20 ++++++++++++
  11 files changed, 20 insertions(+), 38 deletions(-)
  rename tests/tcg/{mips/user/isa/r5900 => mips64el/system}/test_r5900_div1.c 
(100%)
  rename tests/tcg/{mips/user/isa/r5900 => mips64el/system}/test_r5900_divu1.c 
(100%)
  rename tests/tcg/{mips/user/isa/r5900 => mips64el/system}/test_r5900_madd.c 
(100%)
  rename tests/tcg/{mips/user/isa/r5900 => mips64el/system}/test_r5900_maddu.c 
(100%)
  rename tests/tcg/{mips/user/isa/r5900 => 
mips64el/system}/test_r5900_mflohi1.c (100%)
  rename tests/tcg/{mips/user/isa/r5900 => 
mips64el/system}/test_r5900_mtlohi1.c (100%)
  rename tests/tcg/{mips/user/isa/r5900 => mips64el/system}/test_r5900_mult.c 
(100%)
  rename tests/tcg/{mips/user/isa/r5900 => mips64el/system}/test_r5900_multu.c 
(100%)
  delete mode 100644 tests/tcg/mips/user/isa/r5900/Makefile
  delete mode 100644 tests/tcg/mips/user/isa/r5900/README


+# o32: 32-bit pointers, 32-bit GPRs are enough
+foreach t: [
+  'div1',
+  'divu1',
+  'madd',
+  'maddu',
+  'mflohi1',
+  'mtlohi1',
+  'mult',
+  'multu',
+]
+  tests += {
+    'test_r5900_' + t + '.c': {
+      'cflags': cflags + ['-mabi=32'],
+      'qemu_args': qemu_args,
+      'gdb_test': gdb_test,
+    }
+  }

Just a small nit, please keep full file name in the original array
(s/div1/div1.c), All other meson.build for tcg/tests do this also.


(s/div1/test_5900_div1.c)

Squashed:

-- >8 --
diff --git a/tests/tcg/mips64el/system/meson.build b/tests/tcg/mips64el/system/meson.build
index fd5a759c20fa..c16a21f57aef 100644
--- a/tests/tcg/mips64el/system/meson.build
+++ b/tests/tcg/mips64el/system/meson.build
@@ -21,17 +21,17 @@ gdb_test = ['--gdb-args=-ex "set remoteaddresssize 64"',

 # o32: 32-bit pointers, 32-bit GPRs are enough
 foreach t: [
-  'div1',
-  'divu1',
-  'madd',
-  'maddu',
-  'mflohi1',
-  'mtlohi1',
-  'mult',
-  'multu',
+  'test_r5900_div1.c',
+  'test_r5900_divu1.c',
+  'test_r5900_madd.c',
+  'test_r5900_maddu.c',
+  'test_r5900_mflohi1.c',
+  'test_r5900_mtlohi1.c',
+  'test_r5900_mult.c',
+  'test_r5900_multu.c',
 ]
   tests += {
-    'test_r5900_' + t + '.c': {
+    t: {
       'cflags': cflags + ['-mabi=32'],
       'qemu_args': qemu_args,
       'gdb_test': gdb_test,
---


Reviewed-by: Pierrick Bouvier <[email protected]>

Thanks!

Reply via email to