On 30/01/2015 19:42, John Snow wrote:
> +/**
> + * Boot and fully enable the HBA device.
> + * @see ahci_boot, ahci_pci_enable and ahci_hba_enable.
> + */
> +static AHCIQState *ahci_macro_bootup(void)

Ugly name...  I would just leave out this patch.

Paolo

> +{
> +    AHCIQState *ahci;
> +    ahci = ahci_boot();
> +
> +    ahci_pci_enable(ahci);
> +    ahci_hba_enable(ahci);
> +
> +    return ahci;
> +}

Reply via email to