On 02/02/2015 05:37 AM, Paolo Bonzini wrote:


On 30/01/2015 19:42, John Snow wrote:
+/**
+ * Boot and fully enable the HBA device.
+ * @see ahci_boot, ahci_pci_enable and ahci_hba_enable.
+ */
+static AHCIQState *ahci_macro_bootup(void)

Ugly name...  I would just leave out this patch.

Paolo

+{
+    AHCIQState *ahci;
+    ahci = ahci_boot();
+
+    ahci_pci_enable(ahci);
+    ahci_hba_enable(ahci);
+
+    return ahci;
+}


It comes in handy later for testing migration so I don't have to do a lot of boilerplate for each instance, though it is just a convenience subroutine with no logic of its own.

I like to cut down on boilerplate as much as possible to expose the logic of the test as much as possible.

Have a suggestion for a better name, or are you very adamant about culling it?

--js

Reply via email to