On 06/15/2010 11:30 AM, Anthony Liguori wrote:
block_passwd ------------
I dislike abbreviations. I also think that we should make commands verbs. So I'd like to change the name to set_block_password and then we can alias block_passwd to that command if we need to.
Set the password of encrypted block devices. Arguments: - "device": device name (json-string) - "password": password (json-string)
What happens if: 1) device does not exist 2) media is not present 3) block format does not support encryption 4) password is invalid Regards, Anthony Liguori
Example: -> { "execute": "block_passwd", "arguments": { "device": "ide0-hd0", "password": "12345" } } <- { "return": {} }