On 20 April 2018 at 18:50, Philippe Mathieu-Daudé <f4...@amsat.org> wrote: > On 04/20/2018 11:52 AM, Peter Maydell wrote: >> Create a new function max_serial_hds() which returns the number of >> serial ports defined by the user. This is needed only by spapr. >> This allows us to remove the MAX_SERIAL_PORTS define. >> >> Signed-off-by: Peter Maydell <peter.mayd...@linaro.org> >> --- >> include/sysemu/sysemu.h | 6 ++++-- >> hw/ppc/spapr.c | 2 +- >> vl.c | 5 +++++ >> 3 files changed, 10 insertions(+), 3 deletions(-) >> >> diff --git a/include/sysemu/sysemu.h b/include/sysemu/sysemu.h >> index 989cbc2b7b..612659a718 100644 >> --- a/include/sysemu/sysemu.h >> +++ b/include/sysemu/sysemu.h >> @@ -159,10 +159,12 @@ void hmp_pcie_aer_inject_error(Monitor *mon, const >> QDict *qdict); >> >> /* serial ports */ >> >> -#define MAX_SERIAL_PORTS 4 >> - >> /* Return the Chardev for serial port i, or NULL if none */ >> Chardev *serial_hd(int i); >> +/* return the number of serial ports defined by the user. serial_hd(i) >> + * will always return NULL for any i which is greater than or equal to this. >> + */ >> +int max_serial_hds(void); > > What about naming it serial_hds_count() to keep this under the serial_ > namespace?
OK, makes sense. > And about using a size_t for num_serial_hds? This doesn't seem worthwhile though. Since the rename of max_serial_hds is the only change here, I propose to apply this to master (fixing up the function name in this patch in the process), to reduce the number of conflicts with other changes currently in-flight. thanks -- PMM