On Fri, Nov 01, 2019 at 01:23:31PM -0600, jathan wrote: > On 01/11/2019 13:13, Holger Levsen wrote: > > hi, > > > > so I just did an upgrade from FreeBSD 11.2 to 12.0 on our freebsd test > > host and now the job trying to build FreeBSD master fails with > > > > ERROR: Required ntpd user is missing, see /usr/src/UPDATING. > > *** [__installcheck_UGID] Error code 1 > > > > full log at > > https://jenkins.debian.net/job/reproducible_freebsd/314/console > > > > What is also strange, on the host I see this: > > > > root@freebsd-jenkins:~ # grep ntp /etc/passwd /etc/group > > /etc/passwd:ntpd:*:123:123:NTP Daemon:/var/db/ntp:/usr/sbin/nologin > > /etc/group:ntpd:*:123: > > root@freebsd-jenkins:~ # id ntpd > > id: ntpd: no such user > > root@freebsd-jenkins:~ # > > > > which to me doesnt really make sense. > > > > Any hints welcome. > > > > > > > > _______________________________________________ > > [email protected] mailing list > > > > To change your subscription options, visit > > https://lists.reproducible-builds.org/listinfo/rb-general. > > > > To unsubscribe, send an email to > > [email protected]. > > > Hi Holger, > > If you try to create the ntpd user does the system tell you it exists > already as /etc/passwd says? > > Regards! > Jathan >
This is documented in https://svnweb.freebsd.org/base/head/UPDATING?view=markup#l405 Btw adding manual entries in passwd does not work, because this is not what is used, a db has to be generated via pwd_mkdb. the high level tools: useradd, pw are doing it automatically. By default, it is like pam_userdb on linux. Best regards, Bapt
signature.asc
Description: PGP signature
_______________________________________________ [email protected] mailing list To change your subscription options, visit https://lists.reproducible-builds.org/listinfo/rb-general. To unsubscribe, send an email to [email protected].
