Michael Ho has posted comments on this change. ( 
http://gerrit.cloudera.org:8080/8439 )

Change subject: IMPALA-5054: [SECURITY] Enable KRPC w/ TLS in Impala
......................................................................


Patch Set 1:

(4 comments)

http://gerrit.cloudera.org:8080/#/c/8439/1/be/src/rpc/rpc-mgr.h
File be/src/rpc/rpc-mgr.h:

http://gerrit.cloudera.org:8080/#/c/8439/1/be/src/rpc/rpc-mgr.h@105
PS1, Line 105:   void use_tls(bool value) { use_tls_ = value; }
Doesn't seem necessary to have this if we can pass this in the constructor. If 
you decide to keep it, can you please rename it SetUseTLS(bool use_tls) ?


http://gerrit.cloudera.org:8080/#/c/8439/1/be/src/rpc/rpc-mgr.h@181
PS1, Line 181: bool use_tls_ = false;
const bool use_tls_; and initialize it in the constructor.


http://gerrit.cloudera.org:8080/#/c/8439/1/be/src/runtime/exec-env.cc
File be/src/runtime/exec-env.cc:

http://gerrit.cloudera.org:8080/#/c/8439/1/be/src/runtime/exec-env.cc@175
PS1, Line 175:     rpc_mgr_->use_tls(IsInternalTlsConfigured());
This flag looks like something one should pass to the constructor of RpcMgr ?


http://gerrit.cloudera.org:8080/#/c/8439/1/be/src/util/openssl-util.h
File be/src/util/openssl-util.h:

http://gerrit.cloudera.org:8080/#/c/8439/1/be/src/util/openssl-util.h@28
PS1, Line 28: //
nit: ///



--
To view, visit http://gerrit.cloudera.org:8080/8439
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-Project: Impala-ASF
Gerrit-Branch: master
Gerrit-MessageType: comment
Gerrit-Change-Id: I9a14a44fdea9ab668f3714eb69fdb188bce38f5a
Gerrit-Change-Number: 8439
Gerrit-PatchSet: 1
Gerrit-Owner: Sailesh Mukil <sail...@cloudera.com>
Gerrit-Reviewer: Dan Hecht <dhe...@cloudera.com>
Gerrit-Reviewer: Michael Ho <k...@cloudera.com>
Gerrit-Reviewer: Sailesh Mukil <sail...@cloudera.com>
Gerrit-Comment-Date: Thu, 30 Nov 2017 01:58:58 +0000
Gerrit-HasComments: Yes

Reply via email to