Peter Rozsa has posted comments on this change. ( http://gerrit.cloudera.org:8080/24521 )
Change subject: IMPALA-15052: Add read support for unshredded VARIANT values ...................................................................... Patch Set 5: (2 comments) http://gerrit.cloudera.org:8080/#/c/24521/5/fe/src/main/java/org/apache/impala/analysis/Analyzer.java File fe/src/main/java/org/apache/impala/analysis/Analyzer.java: http://gerrit.cloudera.org:8080/#/c/24521/5/fe/src/main/java/org/apache/impala/analysis/Analyzer.java@1862 PS5, Line 1862: public void createVariantTuplesAndSlotDescs(SlotDescriptor desc) it's a code duplication from createStructTuplesAndSlotDescs, can it be collapsed into one method? Unifying the two types as compound types could help here as well. http://gerrit.cloudera.org:8080/#/c/24521/5/tests/query_test/test_iceberg.py File tests/query_test/test_iceberg.py: http://gerrit.cloudera.org:8080/#/c/24521/5/tests/query_test/test_iceberg.py@2366 PS5, Line 2366: 19 nit: where does this number come from? -- To view, visit http://gerrit.cloudera.org:8080/24521 To unsubscribe, visit http://gerrit.cloudera.org:8080/settings Gerrit-Project: Impala-ASF Gerrit-Branch: master Gerrit-MessageType: comment Gerrit-Change-Id: Ie2f8a7c9b1d4e5f6a0c3b8d7e9f1a2b4c6d8e0f1 Gerrit-Change-Number: 24521 Gerrit-PatchSet: 5 Gerrit-Owner: Zoltan Borok-Nagy <[email protected]> Gerrit-Reviewer: Balazs Hevele <[email protected]> Gerrit-Reviewer: Csaba Ringhofer <[email protected]> Gerrit-Reviewer: Impala Public Jenkins <[email protected]> Gerrit-Reviewer: Noemi Pap-Takacs <[email protected]> Gerrit-Reviewer: Peter Rozsa <[email protected]> Gerrit-Reviewer: Zoltan Borok-Nagy <[email protected]> Gerrit-Comment-Date: Tue, 21 Jul 2026 09:09:48 +0000 Gerrit-HasComments: Yes
