Csaba Ringhofer has posted comments on this change. ( 
http://gerrit.cloudera.org:8080/17038 )

Change subject: MPALA-10482: Select-star query on unrelative collection column 
of transactional table hits IllegalStateException
......................................................................


Patch Set 1:

(3 comments)

lgtm in general, a few ideas for improvement

http://gerrit.cloudera.org:8080/#/c/17038/1/fe/src/main/java/org/apache/impala/analysis/SelectStmt.java
File fe/src/main/java/org/apache/impala/analysis/SelectStmt.java:

http://gerrit.cloudera.org:8080/#/c/17038/1/fe/src/main/java/org/apache/impala/analysis/SelectStmt.java@130
PS1, Line 130:   // Aliases of the hidden table refs added during query 
rewrite. E.g. full ACID scans can
             :   // add auxiliary table refs to the FROM clause. We need to 
exclude these table refs
             :   // during star expansion.
I am not too familiar with the full ACID rewrites, but my guess is that these 
hidden table refs are about always adding the base table ref, as it is needed 
to be able to remove deleted rows. Am I right?

If this is the only reason, including it in the name could improve readability 
IMO, e.g. hiddenfullAcidBaseTableRefs_


http://gerrit.cloudera.org:8080/#/c/17038/1/fe/src/main/java/org/apache/impala/analysis/SelectStmt.java@133
PS1, Line 133: hiddenTableRefs_
optional: I think that it would be slightly better to store this information in 
a boolean in TableRef. There could be a setter, and a getter or 
IsHiddenExpandStar() function.

The reason is that during debugging you often have a table ref, and it can be 
useful to see this information about its origin.


http://gerrit.cloudera.org:8080/#/c/17038/1/testdata/workloads/functional-query/queries/QueryTest/nested-types-scanner-basic.test
File 
testdata/workloads/functional-query/queries/QueryTest/nested-types-scanner-basic.test:

http://gerrit.cloudera.org:8080/#/c/17038/1/testdata/workloads/functional-query/queries/QueryTest/nested-types-scanner-basic.test@317
PS1, Line 317: ====
Can you add a bit more complex query? The idea is to include the same hidden 
table ref twice, e.g.
select * from complextypestbl.int_array a1 join complextypestbl.int_array a2 on 
a1.item=a2.item where a1.item<2;



--
To view, visit http://gerrit.cloudera.org:8080/17038
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-Project: Impala-ASF
Gerrit-Branch: master
Gerrit-MessageType: comment
Gerrit-Change-Id: I8fc758d3c1e75c7066936d590aec8bff8d2b00b0
Gerrit-Change-Number: 17038
Gerrit-PatchSet: 1
Gerrit-Owner: Zoltan Borok-Nagy <borokna...@cloudera.com>
Gerrit-Reviewer: Csaba Ringhofer <csringho...@cloudera.com>
Gerrit-Reviewer: Impala Public Jenkins <impala-public-jenk...@cloudera.com>
Gerrit-Reviewer: Quanlong Huang <huangquanl...@gmail.com>
Gerrit-Comment-Date: Mon, 08 Feb 2021 17:49:59 +0000
Gerrit-HasComments: Yes

Reply via email to