Sailesh Mukil has posted comments on this change.

Change subject: KuduRPC integration with OpenSSL
......................................................................


Patch Set 1:

(18 comments)

http://gerrit.cloudera.org:8080/#/c/4789/1/src/kudu/rpc/rpc-test-base.h
File src/kudu/rpc/rpc-test-base.h:

Line 347:       // TODO: Figure out a way to properly populate this.
> warning: missing username/bug in TODO [google-readability-todo]
Done


http://gerrit.cloudera.org:8080/#/c/4789/1/src/kudu/util/net/ssl_factory.cc
File src/kudu/util/net/ssl_factory.cc:

Line 32: static void CryptoLockingCallback(int mode, int n, const char*, int) {
> warning: all parameters should be named in a function [readability-named-pa
Done


Line 41: static unsigned long CryptoThreadIDCallback() {
> warning: consider replacing 'unsigned long' with 'uint64' [google-runtime-i
Done


Line 67:   // TODO: Make method configurable.
> warning: missing username/bug in TODO [google-readability-todo]
Done


Line 120: }
> warning: namespace 'kudu' not terminated with a closing comment [google-rea
Done


http://gerrit.cloudera.org:8080/#/c/4789/1/src/kudu/util/net/ssl_factory.h
File src/kudu/util/net/ssl_factory.h:

Line 20: #include <sys/uio.h>
> warning: #includes are not sorted properly [llvm-include-order]
Done


Line 46:   Status LoadCertificate(std::string& certificate_path);
> warning: non-const reference parameter 'certificate_path', make it const or
Done


Line 49:   Status LoadPrivateKey(std::string&  key_path);
> warning: non-const reference parameter 'key_path', make it const or use a p
Done


Line 52:   Status LoadCertificateAuthority(std::string& certificate_path);
> warning: non-const reference parameter 'certificate_path', make it const or
Done


Line 75:     } else {
> warning: don't use else after return [readability-else-after-return]
Done


Line 83: }
> warning: namespace 'kudu' not terminated with a closing comment [google-rea
Done


http://gerrit.cloudera.org:8080/#/c/4789/1/src/kudu/util/net/ssl_socket.cc
File src/kudu/util/net/ssl_socket.cc:

Line 22: #include <openssl/err.h>
> warning: #includes are not sorted properly [llvm-include-order]
Done


Line 55:   std::string common_name((char*)utf8_cn);
> warning: C-style casts are discouraged; use reinterpret_cast [google-readab
Done


Line 63: bool VerifyHost(std::string& hostname, std::string& subject_name, int 
size) {
> warning: non-const reference parameter 'subject_name', make it const or use
Done


Line 63: bool VerifyHost(std::string& hostname, std::string& subject_name, int 
size) {
> warning: non-const reference parameter 'hostname', make it const or use a p
Done


Line 65:   size_t leftmost_size = subject_name.find_first_of(".");
> warning: 'find_first_of' called with a string literal consisting of a singl
Done


Line 68:     size_t wildcard_pos = subject_name.find_first_of("*", 
leftmost_size);
> warning: 'find_first_of' called with a string literal consisting of a singl
Done


Line 210: }
> warning: namespace 'kudu' not terminated with a closing comment [google-rea
Done


-- 
To view, visit http://gerrit.cloudera.org:8080/4789
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: I27167faa4e6a78e59b46093055b16682c93af0ea
Gerrit-PatchSet: 1
Gerrit-Project: kudu
Gerrit-Branch: master
Gerrit-Owner: Sailesh Mukil <sail...@cloudera.com>
Gerrit-Reviewer: Alexey Serbin <aser...@cloudera.com>
Gerrit-Reviewer: Dan Burkert <danburk...@apache.org>
Gerrit-Reviewer: Kudu Jenkins
Gerrit-Reviewer: Sailesh Mukil <sail...@cloudera.com>
Gerrit-Reviewer: Tidy Bot
Gerrit-Reviewer: Todd Lipcon <t...@apache.org>
Gerrit-HasComments: Yes

Reply via email to