Will Berkeley has posted comments on this change.

Change subject: KUDU-2101 Include a table summary at the bottom
......................................................................


Patch Set 2:

(3 comments)

http://gerrit.cloudera.org:8080/#/c/7707/2/src/kudu/tools/ksck.cc
File src/kudu/tools/ksck.cc:

PS2, Line 235:               if (left.TableStatus() == CheckResult::OK && 
right.TableStatus() == CheckResult::OK) {
             :                 return left.name < right.name;
             :               }
             :               if (left.TableStatus() == CheckResult::OK && 
right.TableStatus() != CheckResult::OK) {
             :                 return true;
             :               }
             :               if (left.TableStatus() != CheckResult::OK && 
right.TableStatus() == CheckResult::OK) {
             :                 return false;
             :               }
             :               if (left.TableStatus() != CheckResult::OK && 
right.TableStatus() != CheckResult::OK) {
             :                 return left.name < right.name;
             :               }
> slightly simpler option:
Done


PS2, Line 249: col_names
> do you need this variable? I would guess you could just pass the brace list
No, don't need it, but I thought it was a bit more readable. Will change.


PS2, Line 265: row
> same - need the var?
Ditto


-- 
To view, visit http://gerrit.cloudera.org:8080/7707
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: I1913352e3a1f91b4bb07e2f5001c8cc94d5155d4
Gerrit-PatchSet: 2
Gerrit-Project: kudu
Gerrit-Branch: master
Gerrit-Owner: Will Berkeley <wdberke...@gmail.com>
Gerrit-Reviewer: Jean-Daniel Cryans <jdcry...@apache.org>
Gerrit-Reviewer: Kudu Jenkins
Gerrit-Reviewer: Todd Lipcon <t...@apache.org>
Gerrit-Reviewer: Will Berkeley <wdberke...@gmail.com>
Gerrit-HasComments: Yes

Reply via email to