Andrew Wong has posted comments on this change. ( 
http://gerrit.cloudera.org:8080/15556 )

Change subject: Add core algorithms for columnar serialization
......................................................................


Patch Set 4:

(4 comments)

http://gerrit.cloudera.org:8080/#/c/15556/4/src/kudu/common/columnar_serialization-test.cc
File src/kudu/common/columnar_serialization-test.cc:

http://gerrit.cloudera.org:8080/#/c/15556/4/src/kudu/common/columnar_serialization-test.cc@46
PS4, Line 46:   static constexpr int kTypeSize = sizeof(DataType);
Think it's worth testing other data sizes?


http://gerrit.cloudera.org:8080/#/c/15556/4/src/kudu/common/columnar_serialization.cc
File src/kudu/common/columnar_serialization.cc:

http://gerrit.cloudera.org:8080/#/c/15556/4/src/kudu/common/columnar_serialization.cc@78
PS4, Line 78:   void Flush() {
            :     while (num_buffered_bits_ > 0) {
            :       *dst_++ = buffered_values_ & 0xff;
            :       buffered_values_ >>= 8;
            :       num_buffered_bits_ -= 8;
            :     }
            :   }
nit: maybe mention that this won't fix "alignment" issues, eg if 
num_buffered_bits_ becomes negative. But that's OK since this should only be 
called once anyway.


http://gerrit.cloudera.org:8080/#/c/15556/4/src/kudu/common/columnar_serialization.cc@132
PS4, Line 132: //
             : // NOTE: this assumes that dst_values_buf and non_null_bitmap 
are valid for the full range
             : // of indices [0, dst_idx + n_rows). The implementation may 
redundantly re-zero cells
             : // at indexes less than dst_idx.
Just making sure I'm reading this right -- this is referring to the alignment 
calls in the implementation, right?


http://gerrit.cloudera.org:8080/#/c/15556/4/src/kudu/common/columnar_serialization.cc@136
PS4, Line 136: type_size
nit: maybe add units to the name? Same with the template arg.



--
To view, visit http://gerrit.cloudera.org:8080/15556
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-Project: kudu
Gerrit-Branch: master
Gerrit-MessageType: comment
Gerrit-Change-Id: I16f2993081aac54609aab4d8219ef0bf6c7708c2
Gerrit-Change-Number: 15556
Gerrit-PatchSet: 4
Gerrit-Owner: Todd Lipcon <t...@apache.org>
Gerrit-Reviewer: Adar Dembo <a...@cloudera.com>
Gerrit-Reviewer: Andrew Wong <andrew.w...@cloudera.com>
Gerrit-Reviewer: Andrew Wong <aw...@cloudera.com>
Gerrit-Reviewer: Grant Henke <granthe...@apache.org>
Gerrit-Reviewer: Kudu Jenkins (120)
Gerrit-Reviewer: Tidy Bot (241)
Gerrit-Reviewer: Todd Lipcon <t...@apache.org>
Gerrit-Comment-Date: Wed, 25 Mar 2020 22:39:16 +0000
Gerrit-HasComments: Yes

Reply via email to