Ashwani Raina has posted comments on this change. ( 
http://gerrit.cloudera.org:8080/21098 )

Change subject: [compaction] Code cleanup and readability improvement
......................................................................


Patch Set 3:

(11 comments)

http://gerrit.cloudera.org:8080/#/c/21098/2/src/kudu/tablet/compaction.cc
File src/kudu/tablet/compaction.cc:

http://gerrit.cloudera.org:8080/#/c/21098/2/src/kudu/tablet/compaction.cc@996
PS2, Line 996: Mutation** new_undo_head) {
> While you are this, could you move this parameter to come before 'out' para
Done


http://gerrit.cloudera.org:8080/#/c/21098/2/src/kudu/tablet/compaction.cc@1182
PS2, Line 1182: bool RemoveAncientUndos(const HistoryGcOpts& history_gc_opts,
              :                         const Mutation* redo_head,
              :                         Mutation** undo_head) {
              :   if (!history_gc_opts.gc_enabled()) {
> While you are at this, maybe modify the signature of this function to retur
Done


http://gerrit.cloudera.org:8080/#/c/21098/2/src/kudu/tablet/compaction.cc@1235
PS2, Line 1235:
> While you are at this, could you move this parameter to come before the out
Done


http://gerrit.cloudera.org:8080/#/c/21098/2/src/kudu/tablet/compaction.cc@1403
PS2, Line 1403:
> Why not to check for the return status of this call?
Done


http://gerrit.cloudera.org:8080/#/c/21098/2/src/kudu/tablet/compaction.cc@1408
PS2, Line 1408:                  
> ditto
Done


http://gerrit.cloudera.org:8080/#/c/21098/2/src/kudu/tablet/compaction.cc@1411
PS2, Line 1411:
              :   DVLOG(4) << "Output Row: " << 
dst_row->schema()->DebugRow(*dst_row)
              :            << "; RowId: " << index_in_current_drs;
              :
> Why not to move this to the upper level, and avoid passing an extra out par
Done


http://gerrit.cloudera.org:8080/#/c/21098/2/src/kudu/tablet/compaction.cc@1421
PS2, Line 1421: u = new_undos_head;
> Maybe, move the whole definition of UndoListSanityCheck() along with the pl
Done


http://gerrit.cloudera.org:8080/#/c/21098/2/src/kudu/tablet/compaction.cc@1451
PS2, Line 1451:
> Could this be passed as 'const CompactionInputRow&' instead?
Done


http://gerrit.cloudera.org:8080/#/c/21098/2/src/kudu/tablet/compaction.cc@1452
PS2, Line 1452: Are
> Why not 'size_t'?  It seems the involved functions under the hood actually
Done


http://gerrit.cloudera.org:8080/#/c/21098/2/src/kudu/tablet/compaction.cc@1452
PS2, Line 1452: a* aren
> nit: cur_row_idx ?
Done


http://gerrit.cloudera.org:8080/#/c/21098/2/src/kudu/tablet/compaction.cc@1543
PS2, Line 1543:
> Could this become
Done



--
To view, visit http://gerrit.cloudera.org:8080/21098
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-Project: kudu
Gerrit-Branch: master
Gerrit-MessageType: comment
Gerrit-Change-Id: I54709b5e27751581c889854911323fbddab1c4ab
Gerrit-Change-Number: 21098
Gerrit-PatchSet: 3
Gerrit-Owner: Ashwani Raina <ara...@cloudera.com>
Gerrit-Reviewer: Alexey Serbin <ale...@apache.org>
Gerrit-Reviewer: Ashwani Raina <ara...@cloudera.com>
Gerrit-Reviewer: Attila Bukor <abu...@apache.org>
Gerrit-Reviewer: Kudu Jenkins (120)
Gerrit-Reviewer: Mahesh Reddy <mre...@cloudera.com>
Gerrit-Reviewer: Marton Greber <greber...@gmail.com>
Gerrit-Comment-Date: Wed, 03 Apr 2024 16:42:02 +0000
Gerrit-HasComments: Yes

Reply via email to