-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/36575/#review92464
-----------------------------------------------------------

Ship it!



src/tests/master_tests.cpp (line 3198)
<https://reviews.apache.org/r/36575/#comment146659>

    I know you're just copying code from previous tests, but I'd like to 
suggest that we come back here and replace trailing underscore variable names, 
in this case we can cleanly do something like s/labelsObject_/find/ and then 
`JSON::Array labelsObject = find.get();` below.


- Benjamin Hindman


On July 21, 2015, 4:45 p.m., Kapil Arya wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/36575/
> -----------------------------------------------------------
> 
> (Updated July 21, 2015, 4:45 p.m.)
> 
> 
> Review request for mesos, Benjamin Hindman, Ben Mahler, and Niklas Nielsen.
> 
> 
> Bugs: MESOS-3076
>     https://issues.apache.org/jira/browse/MESOS-3076
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> The labels would allow executors and Slave modules to pass in some
> meta-data about the task to the framework and Mesos-DNS (via state.json).
> 
> 
> Diffs
> -----
> 
>   include/mesos/mesos.proto 1763129da535561503e89cbd8c4a371f8553d8d6 
>   src/common/http.cpp 2bb1ba87a2755a4bd9b762280dea6fce81db1320 
>   src/common/protobuf_utils.hpp afe5a85d3f58eaabb16807253c5fcc07cabcf8e8 
>   src/common/protobuf_utils.cpp 9ac81c38efd70f92c64a5865fa79fe516e84dd92 
>   src/tests/master_tests.cpp 767c86cbde31eeb49d110d04bfb5a3eb5d469afc 
>   src/tests/slave_tests.cpp 89cc7f68b33b037626ca6056647c360b5a6d5901 
> 
> Diff: https://reviews.apache.org/r/36575/diff/
> 
> 
> Testing
> -------
> 
> make check with new tests to verify state.json output.
> 
> 
> Thanks,
> 
> Kapil Arya
> 
>

Reply via email to