-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/41789/#review115326
-----------------------------------------------------------


Looks good. Besides the previously mentioned `http::request()` name change and 
the redundant code in `createRequest()`s, this looks shippable.


3rdparty/libprocess/include/process/http.hpp (lines 812 - 814)
<https://reviews.apache.org/r/41789/#comment176293>

    Seems like a good candidate for a doxygen-style @param



3rdparty/libprocess/src/http.cpp (lines 1240 - 1268)
<https://reviews.apache.org/r/41789/#comment176295>

    Looks like a lot of redundant content between these two `createRequest()` 
calls. Can one of them call the other, or both of them call a common helper? 
Let's try to remove code duplication whenever possible.



3rdparty/libprocess/src/http.cpp (line 1277)
<https://reviews.apache.org/r/41789/#comment176294>

    s/enableSSL?/enableSSL ?/ since we like whitespace around our operators.



3rdparty/libprocess/src/tests/http_tests.cpp (line 685)
<https://reviews.apache.org/r/41789/#comment176299>

    Rename to `validateDeleteHttpRequest` since that's what it's doing, and it 
clearly won't validate any other `http::Request`s



3rdparty/libprocess/src/tests/http_tests.cpp (line 705)
<https://reviews.apache.org/r/41789/#comment176300>

    "Newline when calling or defining a function: indent with 4 spaces."
    Although you were correct for the previous line:
    "Newline for an assignment statement: indent with 2 spaces."
    See http://mesos.apache.org/documentation/latest/c++-style-guide/


- Adam B


On Jan. 17, 2016, 10:48 p.m., Yongqiao Wang wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/41789/
> -----------------------------------------------------------
> 
> (Updated Jan. 17, 2016, 10:48 p.m.)
> 
> 
> Review request for mesos, Adam B, Joerg Schad, Joris Van Remoortere, Neil 
> Conway, and Qian Zhang.
> 
> 
> Bugs: MESOS-3763
>     https://issues.apache.org/jira/browse/MESOS-3763
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> Expose the internal::http::request function in the header and not add an 
> additional method/overload for put function.
> 
> (TODO): Clean the other instances of post/get to use the http::request method.
> 
> 
> Diffs
> -----
> 
>   3rdparty/libprocess/include/process/http.hpp 
> 1fe549e9c3c64b310048388d90ab04e5641e08a1 
>   3rdparty/libprocess/src/http.cpp 40fd87c4aa1417d4746a5e4268c30c0e55d0ec0e 
>   3rdparty/libprocess/src/tests/http_tests.cpp 
> c23d0bf1929686cfc42969f39ce046f4794539d4 
> 
> Diff: https://reviews.apache.org/r/41789/diff/
> 
> 
> Testing
> -------
> 
> Make & Make check successfully.
> 
> 
> Thanks,
> 
> Yongqiao Wang
> 
>

Reply via email to