-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/45270/#review129011
-----------------------------------------------------------




src/CMakeLists.txt (lines 52 - 54)
<https://reviews.apache.org/r/45270/#comment192472>

    the naming here looks bad. We should rename them to:
    ```
    PROVISIONER_DOCKER
    ISOLATOR_CNI_SPEC
    ISOLATOR_DOCKER_VOLUME_SPEC
    ```



src/CMakeLists.txt (line 63)
<https://reviews.apache.org/r/45270/#comment192473>

    You need to update the protobuf here as well (also adding the new one you 
just added).



src/slave/containerizer/mesos/isolators/docker/volume/spec.hpp (line 29)
<https://reviews.apache.org/r/45270/#comment192477>

    Let's not yet introduce file yet.



src/slave/containerizer/mesos/isolators/docker/volume/spec.proto (line 19)
<https://reviews.apache.org/r/45270/#comment192476>

    Why this namespace? This is technically not 'spec', but the _state_ scheme 
used by the isolator. We should call the protobuf file 'state.proto'.
    
    I would suggest we still put it under `package mesos.internal.slave`, and 
call it `DockerVolumeMount`.
    
    s/ExternalMountList/DockerVolumeState/



src/slave/containerizer/mesos/isolators/docker/volume/spec.proto (lines 21 - 35)
<https://reviews.apache.org/r/45270/#comment192474>

    Why do you need to checkpoint 'container_path', 'mount_point' and 
'driver_options'?


- Jie Yu


On April 14, 2016, 4:41 a.m., Guangya Liu wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/45270/
> -----------------------------------------------------------
> 
> (Updated April 14, 2016, 4:41 a.m.)
> 
> 
> Review request for mesos, David vonThenen, Gilbert Song, haosdent huang, and 
> Jie Yu.
> 
> 
> Bugs: MESOS-5013
>     https://issues.apache.org/jira/browse/MESOS-5013
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> Added spec protobut for external mount.
> 
> 
> Diffs
> -----
> 
>   src/CMakeLists.txt ca59a1824352423f4db6ef8bb41acc6fe602c041 
>   src/Makefile.am 139935fb40f8986427c85537a400ff945e54433f 
>   src/slave/containerizer/mesos/isolators/docker/volume/spec.hpp PRE-CREATION 
>   src/slave/containerizer/mesos/isolators/docker/volume/spec.proto 
> PRE-CREATION 
> 
> Diff: https://reviews.apache.org/r/45270/diff/
> 
> 
> Testing
> -------
> 
> make
> make check
> 
> 
> Thanks,
> 
> Guangya Liu
> 
>

Reply via email to