> On April 22, 2016, 9:35 a.m., Adam B wrote:
> > src/tests/cluster.cpp, line 392
> > <https://reviews.apache.org/r/45922/diff/7-8/?file=1348011#file1348011line392>
> >
> >     Double underscores for variable names are discouraged (usually only 
> > acceptable for continuation function names).
> >     Maybe the original parameter is `providedAuthorizer`, and 
> > `authorizer__` becomes `newAuthorizer`, then you could have:
> >     `authorizer = providedAuthorizer;`
> >     `if(...) newAuthorizer = Authorizer::create();`
> >     `if(newAuthorizer.isSome()) authorizer = newAuthorizer;`
> >     Or maybe you've got better names, but you get the idea.

Thanks for the explanation! I've changed them to `authorizer`, 
`providedAuthorizer` and `createdAuthorizer`.


- Jan


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/45922/#review130041
-----------------------------------------------------------


On April 22, 2016, 12:05 p.m., Jan Schlicht wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/45922/
> -----------------------------------------------------------
> 
> (Updated April 22, 2016, 12:05 p.m.)
> 
> 
> Review request for mesos, Adam B and Alexander Rojas.
> 
> 
> Bugs: MESOS-5142
>     https://issues.apache.org/jira/browse/MESOS-5142
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> Added agent authorization flags.
> 
> 
> Diffs
> -----
> 
>   docs/configuration.md 86ba66ac62295ca148524bcb2e57fee560ac4ac5 
>   src/local/local.cpp 7de8a2423185e49dfa849d069938d3243b4f4956 
>   src/slave/constants.hpp 9978c11fec40055dd42f19c20cd3e9fef4e78cea 
>   src/slave/flags.hpp ee520acc459564fe68272950948fc80c5e24513a 
>   src/slave/flags.cpp 10d2974bd2b6e79255fc894979607f0d2d00c315 
>   src/slave/main.cpp 38bd00584dd9c6a872398678b2288edeed1cd2a4 
>   src/slave/slave.hpp 20a4bcd0bb9dad06ea81fc4ad9b2fa462c69d2c5 
>   src/slave/slave.cpp a365e8f5f8d63bf80614fccf6adf35a4fee07526 
>   src/tests/cluster.hpp 96ec52af16776e91200aa755c7847f56e33d71f4 
>   src/tests/cluster.cpp 3e5fdf6b32a0d99d3ca83743386232d38471e34f 
>   src/tests/mesos.hpp e4b63d41d883807ac39846799468b80e88c84e0b 
>   src/tests/mesos.cpp b5937af7713e1ee2af475518b3e968b2defa8beb 
> 
> Diff: https://reviews.apache.org/r/45922/diff/
> 
> 
> Testing
> -------
> 
> make check
> 
> 
> Thanks,
> 
> Jan Schlicht
> 
>

Reply via email to