-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/48593/#review137147
-----------------------------------------------------------




src/common/values.cpp (line 282)
<https://reviews.apache.org/r/48593/#comment202303>

    Usually we perfer to return `Value::Ranges` directly.
    ```
    Value::Ranges IntervalSet2Ranges(const IntervalSet<int>& set)
    ```
    
    In additional, `convertToRanges` maybe a better name



src/common/values.cpp (line 285)
<https://reviews.apache.org/r/48593/#comment202302>

    I think we could use foreach here?


- haosdent huang


On June 12, 2016, 3:28 a.m., Yanyan Hu wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/48593/
> -----------------------------------------------------------
> 
> (Updated June 12, 2016, 3:28 a.m.)
> 
> 
> Review request for mesos.
> 
> 
> Bugs: MESOS-5425
>     https://issues.apache.org/jira/browse/MESOS-5425
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> This patch reimplement Ranges subtraction using
> IntervalSet data type: Ranges values will be
> converted to IntervalSet values for subtraction
> and the result will be converted back to Ranges
> after subtraction is done. This change is for
> fixing jira MESOS-5425.
> 
> 
> Diffs
> -----
> 
>   src/common/values.cpp 587cb68551d438621e215953e89818b623b7f71b 
> 
> Diff: https://reviews.apache.org/r/48593/diff/
> 
> 
> Testing
> -------
> 
> make check
> 
> 
> Thanks,
> 
> Yanyan Hu
> 
>

Reply via email to