> On Sept. 20, 2016, 3:43 a.m., Guangya Liu wrote: > > include/mesos/resources.hpp, lines 187-188 > > <https://reviews.apache.org/r/51999/diff/2/?file=1504205#file1504205line187> > > > > Why update here, I prefer > > > > ``` > > parses text in the form "name(role):value;name:value;...". > > ```
I do not think it matters. The change was done since the previous line did not fit this within 80 chars. Anyways with the refactor, this is not an issue anymore. > On Sept. 20, 2016, 3:43 a.m., Guangya Liu wrote: > > include/mesos/resources.hpp, line 201 > > <https://reviews.apache.org/r/51999/diff/2/?file=1504205#file1504205line201> > > > > I think that we should find a better name for this, the above API > > `parse` is actually also parsing a text. > > > > What about `parseResourceVector` or else some other meaningful name in > > your mind? Resolved with the refactor. > On Sept. 20, 2016, 3:43 a.m., Guangya Liu wrote: > > src/slave/containerizer/containerizer.cpp, line 64 > > <https://reviews.apache.org/r/51999/diff/2/?file=1504208#file1504208line64> > > > > I suggest that we move this to > > https://reviews.apache.org/r/51879/diff/3#index_header Resolved with the refactor. - Anindya ----------------------------------------------------------- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/51999/#review149603 ----------------------------------------------------------- On Sept. 19, 2016, 10:42 p.m., Anindya Sinha wrote: > > ----------------------------------------------------------- > This is an automatically generated e-mail. To reply, visit: > https://reviews.apache.org/r/51999/ > ----------------------------------------------------------- > > (Updated Sept. 19, 2016, 10:42 p.m.) > > > Review request for mesos and Jiang Yan Xu. > > > Bugs: MESOS-6062 > https://issues.apache.org/jira/browse/MESOS-6062 > > > Repository: mesos > > > Description > ------- > > During parsing of resources in the startup flags of mesos agent, all > the valid resources (including empty resources) are accumulated in a > vector of Resource protobufs. > > > Diffs > ----- > > include/mesos/resources.hpp 3ef8cacee529addc745b4aeb6398d7606c61b749 > include/mesos/v1/resources.hpp ef56b4960b103a3efd916fab64796aa334ba44c6 > src/common/resources.cpp 4602bff22ec7ff77f069056085ad92bfa04595f3 > src/slave/containerizer/containerizer.cpp > d46882baa904fd439bffb23c324828b777228f1c > src/tests/resources_tests.cpp 3e493007d6d1d8194d07035aaa1cde28dedf2b5a > src/v1/resources.cpp 7c4db44d4c31a8295cc16b0ce1ef5adf314e6ac6 > > Diff: https://reviews.apache.org/r/51999/diff/ > > > Testing > ------- > > > Thanks, > > Anindya Sinha > >