-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/52064/#review160091
-----------------------------------------------------------




site/Rakefile (line 23)
<https://reviews.apache.org/r/52064/#comment231092>

    puts "Updating documentations from the Apache Mesos codebase"



site/Rakefile (line 28)
<https://reviews.apache.org/r/52064/#comment231091>

    `git = Git.open('..')`



site/Rakefile (line 29)
<https://reviews.apache.org/r/52064/#comment231094>

    `origin_branch` is a better name for what this variable used for?



site/Rakefile (line 32)
<https://reviews.apache.org/r/52064/#comment231089>

    I think need to select it from releases.yml



site/Rakefile (line 44)
<https://reviews.apache.org/r/52064/#comment231093>

    Move this into the function.



site/Rakefile (line 88)
<https://reviews.apache.org/r/52064/#comment231090>

    `def generate_docs`



site/Rakefile (lines 88 - 129)
<https://reviews.apache.org/r/52064/#comment231098>

    Since this function only used in task `task :update_docs`, let's move this 
into 
    
    ```
    task :update_docs do
    ...
    ```



site/Rakefile (lines 120 - 121)
<https://reviews.apache.org/r/52064/#comment231096>

    This is not match the original code.



site/Rakefile (line 122)
<https://reviews.apache.org/r/52064/#comment231097>

    Replace all `\/latest\/` looks a bit dangerous. Do you have an example for 
this?



site/build.sh (line 25)
<https://reviews.apache.org/r/52064/#comment231087>

    I think should not include this file?



site/config.rb (lines 47 - 50)
<https://reviews.apache.org/r/52064/#comment231099>

    Hmm, could not get the point that why need to change here?
    
    I think `"./source/documentation/latest/*.md"` have already find all files 
in `latest`? I could not find any subfolder under `latest` so far.



site/data/releases.yml (lines 104 - 105)
<https://reviews.apache.org/r/52064/#comment231086>

    How about change "Some older versions do not have documentation, and 
sometimes there may be tags for versions that are not yet released."
    to "This requires the associate tag exists in git repository."



site/data/releases.yml (line 108)
<https://reviews.apache.org/r/52064/#comment231083>

    I think we only need to keep the version `>=0.26.0`. This reduce the 
website generation time as well.



site/source/assets/css/main.css (lines 39 - 41)
<https://reviews.apache.org/r/52064/#comment231088>

    Could not find the differece for this css change. Is it necessary?



site/source/assets/js/versions.js (line 4)
<https://reviews.apache.org/r/52064/#comment231104>

    we use `pathRegex` style in javascript. Please update following names.



site/source/assets/js/versions.js (line 14)
<https://reviews.apache.org/r/52064/#comment231102>

    Add peroid at the end of comment.



site/source/assets/js/versions.js (line 22)
<https://reviews.apache.org/r/52064/#comment231103>

    Add `;` at the end of this line.



site/source/assets/js/versions.js (line 24)
<https://reviews.apache.org/r/52064/#comment231105>

    Add `;` at the end.



site/source/assets/js/versions.js (lines 27 - 37)
<https://reviews.apache.org/r/52064/#comment231106>

    I think we could remove this part after we only list versions greater than 
0.26.0 .



site/source/assets/js/versions.js (line 39)
<https://reviews.apache.org/r/52064/#comment231107>

    `window.location.href = path;`



site/source/layouts/documentation.erb (line 16)
<https://reviews.apache.org/r/52064/#comment231101>

    Do you think `Back` is necessary here? Since we could click `<-` button in 
the browser.



site/source/layouts/gettingstarted.erb (line 1)
<https://reviews.apache.org/r/52064/#comment231100>

    This layout file is unused, right?


- haosdent huang


On Dec. 12, 2016, 10:03 p.m., Tim Anderegg wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/52064/
> -----------------------------------------------------------
> 
> (Updated Dec. 12, 2016, 10:03 p.m.)
> 
> 
> Review request for mesos, haosdent huang and Vinod Kone.
> 
> 
> Bugs: MESOS-3011
>     https://issues.apache.org/jira/browse/MESOS-3011
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> Support for multiple versions of docs.
> 
> 
> Diffs
> -----
> 
>   site/Dockerfile 8ba0be0c28e924f7a2b89e6e5a3237deb3751a41 
>   site/Gemfile 4dcd0a5ad452085e6e3bb152a6547575636cd807 
>   site/Gemfile.lock 1393246f06631155bb052669a86e431778e891bf 
>   site/Rakefile 01356891c29f9e69fa0f7813cf87e7662eda400b 
>   site/build.sh 11f15e15621c4d3db1472e88911787b9b3100f97 
>   site/config.rb 9e6738fccc48365e16221188269c1ed40772eca7 
>   site/data/releases.yml 755300aa83a1017362129bad256381d10c815609 
>   site/source/assets/css/main.css 83596ddbd833e36b60bdbbd487ebd464b3874119 
>   site/source/assets/js/versions.js PRE-CREATION 
>   site/source/layouts/basic.erb 7464e40b619e883daad93c72c3fbdbfbdda8f152 
>   site/source/layouts/documentation.erb 
> a91f916a5fb7348b2702c272e7a2059bdf628c66 
>   site/source/layouts/gettingstarted.erb PRE-CREATION 
> 
> Diff: https://reviews.apache.org/r/52064/diff/
> 
> 
> Testing
> -------
> 
> Testing was done manually to verify that the documentation was built for each 
> version of Mesos that is supported (some older versions do not have 
> compatible documentation).
> 
> 
> Thanks,
> 
> Tim Anderegg
> 
>

Reply via email to