----------------------------------------------------------- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/61575/#review183019 -----------------------------------------------------------
src/tests/default_executor_tests.cpp Lines 599 (patched) <https://reviews.apache.org/r/61575/#comment259008> Please use `ASSERT_FALSE(offers->offers().empty())` instead. src/tests/default_executor_tests.cpp Lines 609 (patched) <https://reviews.apache.org/r/61575/#comment259010> Remove the empty line. src/tests/default_executor_tests.cpp Lines 621 (patched) <https://reviews.apache.org/r/61575/#comment259014> I think we should make the grace period a bit longer to be able to check if a `TASK_KILLING` status update is sent. src/tests/default_executor_tests.cpp Lines 625-626 (patched) <https://reviews.apache.org/r/61575/#comment259011> I think that it'd be more readable to remove this from here, and to use the following instead of the `CALL` block that follows: ``` v1::Offer::Operation launchGroup = v1::LAUNCH_GROUP( executorInfo, v1::createTaskGroupInfo({task1, task2})); mesos.send(v1::createCallAccept(frameworkId, offer, {launchGroup})); ``` src/tests/default_executor_tests.cpp Lines 629-630 (patched) <https://reviews.apache.org/r/61575/#comment259012> If you use the following, you can remove the acknowledge block bellow: ``` EXPECT_CALL(*scheduler, update(_, _)) .WillOnce(DoAll( FutureArg<1>(&update1), v1::scheduler::SendAcknowledge( frameworkId, offer.agent_id()))); ``` src/tests/default_executor_tests.cpp Lines 675 (patched) <https://reviews.apache.org/r/61575/#comment259013> s/signify/signal/ src/tests/default_executor_tests.cpp Lines 721 (patched) <https://reviews.apache.org/r/61575/#comment259015> This checks that the process finally got a `SIGKILL`, but we can't be sure if it got a `SIGTERM` before that. I couldn't find a test that checks this with the other executors, but I think that we should at least add a TODO. - Gastón Kleiman On Aug. 15, 2017, 10:11 p.m., Anand Mazumdar wrote: > > ----------------------------------------------------------- > This is an automatically generated e-mail. To reply, visit: > https://reviews.apache.org/r/61575/ > ----------------------------------------------------------- > > (Updated Aug. 15, 2017, 10:11 p.m.) > > > Review request for mesos, Gastón Kleiman, Jie Yu, and Vinod Kone. > > > Bugs: MESOS-7879 > https://issues.apache.org/jira/browse/MESOS-7879 > > > Repository: mesos > > > Description > ------- > > This also required a small modification to the kill test helper binary > to write a marker file signifying that the signal handlers have been > set up correctly. > > > Diffs > ----- > > src/tests/default_executor_tests.cpp > b9776314a8781963b92ba9ac297654f61a443bc8 > src/tests/kill_policy_test_helper.hpp > 29651102ec46b477e6e797c6e6bdef5b10afa665 > src/tests/kill_policy_test_helper.cpp > a1880595ff015475f1ba49437d49f7397da19422 > > > Diff: https://reviews.apache.org/r/61575/diff/3/ > > > Testing > ------- > > make check > > > Thanks, > > Anand Mazumdar > >