-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/65395/#review197852
-----------------------------------------------------------


Fix it, then Ship it!





src/checks/checker.cpp
Lines 41 (patched)
<https://reviews.apache.org/r/65395/#comment278143>

    Do you need to include this guy here?



src/checks/checker_process.hpp
Lines 94-95 (patched)
<https://reviews.apache.org/r/65395/#comment278144>

    Are these passed by value on purpose? Here and below.



src/checks/checker_process.cpp
Lines 288 (patched)
<https://reviews.apache.org/r/65395/#comment278147>

    Please avoid saying "health" in checker process: there are also 
non-interpreting checks!



src/checks/checker_process.cpp
Lines 288-289 (patched)
<https://reviews.apache.org/r/65395/#comment278148>

    Let's mention that they are all launched directly from the library's user, 
i.e. the executor.



src/checks/checker_process.cpp
Lines 290-291 (patched)
<https://reviews.apache.org/r/65395/#comment278149>

    ... but the checks still originate from the library's user, i.e., executor.



src/checks/checker_process.cpp
Lines 295 (patched)
<https://reviews.apache.org/r/65395/#comment278151>

    The library uses Agent API to delegate running the command...



src/checks/checker_process.cpp
Lines 300 (patched)
<https://reviews.apache.org/r/65395/#comment278152>

    I'd spell out the variable names here and bellow for aesthetic reasons. 
Leave the decision to you : )



src/checks/checker_process.cpp
Lines 319 (patched)
<https://reviews.apache.org/r/65395/#comment278154>

    Why space between `[=]` and `(`? Here and below.



src/checks/checker_process.cpp
Lines 332 (patched)
<https://reviews.apache.org/r/65395/#comment278160>

    Can this create a copy if optimizations are turned off? Let's say `const 
runtime::Nested&` for clarity and consistency.



src/checks/checker_process.cpp
Lines 362-363 (original), 438-443 (patched)
<https://reviews.apache.org/r/65395/#comment278162>

    Maybe move it closer to `cloneWithSetns()`?



src/checks/checker_process.cpp
Lines 440-442 (patched)
<https://reviews.apache.org/r/65395/#comment278161>

    s/getCloneFunc/getCustomCloneFunc



src/docker/executor.cpp
Lines 44 (patched)
<https://reviews.apache.org/r/65395/#comment278164>

    Do you need it here?



src/launcher/default_executor.cpp
Lines 48 (patched)
<https://reviews.apache.org/r/65395/#comment278165>

    Do you need this include?


- Alexander Rukletsov


On Feb. 8, 2018, 5:49 p.m., Akash Gupta wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/65395/
> -----------------------------------------------------------
> 
> (Updated Feb. 8, 2018, 5:49 p.m.)
> 
> 
> Review request for mesos, Alexander Rukletsov, Andrew Schwartzmeyer, and 
> Gaston Kleiman.
> 
> 
> Bugs: MESOS-8498
>     https://issues.apache.org/jira/browse/MESOS-8498
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> Refactored health check code to separate the logic for each check
> type and runtime (Plain/Docker/Nested). Now the matrix of different
> possiblilites is cleanly enumerated, making it easier to add
> future health checks, such as the ones for Windows.
> 
> 
> Diffs
> -----
> 
>   src/checks/checker.hpp 93502270f31e80c5f7c94b5b456625e9cdea1837 
>   src/checks/checker.cpp fff0aac504b4283a210f936e00c977fa60d88b3d 
>   src/checks/checker_process.hpp 510f3b2e6e689faaf26595214ce377c2b5518f28 
>   src/checks/checker_process.cpp ddb197b8cc2c503fef5ae20af32f5881fff9833f 
>   src/checks/health_checker.hpp 019fbd791f250ecc28ff59d779f90e7ccbf0c685 
>   src/checks/health_checker.cpp eaf9a18817eeeff7c29c7a4b9d1b183f398760a3 
>   src/docker/executor.cpp 80e2d81169f0d4303ca1ddbcef9fa87fe52601fc 
>   src/launcher/default_executor.cpp 8720dada8bc6ca66f9e0fec6dc265eda3dcc7407 
>   src/launcher/executor.cpp e4b9785fed8cd106edcc178071687e82f54016e3 
> 
> 
> Diff: https://reviews.apache.org/r/65395/diff/5/
> 
> 
> Testing
> -------
> 
> make check
> 
> 
> Thanks,
> 
> Akash Gupta
> 
>

Reply via email to