-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/66145/#review200376
-----------------------------------------------------------




src/tests/slave_tests.cpp
Lines 4930 (patched)
<https://reviews.apache.org/r/66145/#comment281087>

    I think the following name is a little easier to read:
    
    s/TasksLaunchReorderUnscheduleGC/LaunchTasksReorderUnscheduleGC/



src/tests/slave_tests.cpp
Lines 4938 (patched)
<https://reviews.apache.org/r/66145/#comment281088>

    Let's move this declaration/assignment down so it's directly above where it 
first gets used in the `EXPECT_CALL`.



src/tests/slave_tests.cpp
Lines 4940-4943 (patched)
<https://reviews.apache.org/r/66145/#comment281090>

    Be consistent here for the creation of the agent dependencies: let's either 
have a newline between each line, or no newlines at all.



src/tests/slave_tests.cpp
Lines 4969 (patched)
<https://reviews.apache.org/r/66145/#comment281091>

    Is this necessary?



src/tests/slave_tests.cpp
Lines 5045-5046 (patched)
<https://reviews.apache.org/r/66145/#comment281094>

    Usually when only one word of a comment runs onto the next line, i'll split 
a bit earlier to improve readability. Also, need a period at the end of the 
comment:
    
    ```
      // Reorder the task group launches by resuming
      // the processing of `taskGroup2` first.
    ```



src/tests/slave_tests.cpp
Lines 5049-5051 (patched)
<https://reviews.apache.org/r/66145/#comment281092>

    Should we confirm here that the second task has not launched yet?
    
    i.e.
    ```
    ASSERT_TRUE(taskStarting2.isPending());
    ```
    
    Also, enclose `taskGroup2` in backticks, here and below.



src/tests/slave_tests.cpp
Lines 5055 (patched)
<https://reviews.apache.org/r/66145/#comment281096>

    s/subseuqently/subsequently/


- Greg Mann


On March 21, 2018, 9:57 p.m., Meng Zhu wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/66145/
> -----------------------------------------------------------
> 
> (Updated March 21, 2018, 9:57 p.m.)
> 
> 
> Review request for mesos, Chun-Hung Hsiao and Greg Mann.
> 
> 
> Bugs: MESOS-8617 and MESOS-8624
>     https://issues.apache.org/jira/browse/MESOS-8617
>     https://issues.apache.org/jira/browse/MESOS-8624
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> Agent should launch the task in their receiving order.
> On the task launch path, there are currently two
> asynchronous steps which may complete out of order:
> unschedule GC and task authorization.
> 
> This test simulates the reordering of the completions
> of unschedule GC step and verify that, despite the
> reordering, tasks can still launch in their original order.
> 
> 
> Diffs
> -----
> 
>   src/tests/slave_tests.cpp 028cd32c7043eba4e6f2045956471bd0bf42371c 
> 
> 
> Diff: https://reviews.apache.org/r/66145/diff/4/
> 
> 
> Testing
> -------
> 
> make check
> 
> 
> Thanks,
> 
> Meng Zhu
> 
>

Reply via email to