-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/66460/#review200661
-----------------------------------------------------------




src/java/jni/org_apache_mesos_v1_scheduler_V0Mesos.cpp
Lines 143 (patched)
<https://reviews.apache.org/r/66460/#comment281492>

    What do you think about using `LOG(FATAL)` here instead of `UNREACHABLE()` 
in order to provide some useful logging before terminating? Might be nicer for 
a user than having to dig through the source to understand exactly what's going 
on.



src/scheduler/scheduler.cpp
Lines 266 (patched)
<https://reviews.apache.org/r/66460/#comment281495>

    Suggestion: I think it might improve readability slightly to use a name 
like `callMessage` instead of `call_`? Here and in the continuations below. Up 
to you.



src/scheduler/scheduler.cpp
Lines 760-762 (patched)
<https://reviews.apache.org/r/66460/#comment281501>

    Hmm is this an invariant we want to bake into this library? Another option 
might be:
    
    ```
    LOG(WARNING) << "Response for " << call_.type() << " unexpectedly included 
body: '" << response.body << "'";
    ```



src/scheduler/scheduler.cpp
Lines 783-785 (patched)
<https://reviews.apache.org/r/66460/#comment281503>

    Is this comment accurate? If the response body is non-empty and couldn't be 
deserialized, then we would hit the `.isError()` case above, right?


- Greg Mann


On April 4, 2018, 11:53 p.m., Gaston Kleiman wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/66460/
> -----------------------------------------------------------
> 
> (Updated April 4, 2018, 11:53 p.m.)
> 
> 
> Review request for mesos and Greg Mann.
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> This patch adds a `call()` method to the scheduler library that allows
> clients to send a `v1::scheduler::Call` to the master and receive a
> `v1::scheduler::Response`.
> 
> It is going to be used to test operation state reconciliation.
> 
> 
> Diffs
> -----
> 
>   include/mesos/v1/scheduler.hpp d56e08861d5190ef66992d383dc5710d8f6ce661 
>   src/java/jni/org_apache_mesos_v1_scheduler_V0Mesos.cpp 
> 60b17b9be74132c81532d22eba681feb899b22a3 
>   src/scheduler/scheduler.cpp ecef916ffd0797a13552525ff2cda0f99ca57e74 
> 
> 
> Diff: https://reviews.apache.org/r/66460/diff/1/
> 
> 
> Testing
> -------
> 
> `sudo bin/mesos-tests` on GNU/Linux
> 
> 
> Thanks,
> 
> Gaston Kleiman
> 
>

Reply via email to