-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/68639/#review208400
-----------------------------------------------------------




include/mesos/v1/resources.hpp
Lines 695-696 (original), 704-705 (patched)
<https://reviews.apache.org/r/68639/#comment292296>

    This sounds like a commit message and less like documentation for the 
current state.
    
    Maybe just something like this?
    
        We name the `vector` field `noMutationWithoutExclusiveOwnership` ...



include/mesos/v1/resources.hpp
Line 703 (original), 714 (patched)
<https://reviews.apache.org/r/68639/#comment292299>

    I like how transparent this naming makes the need for future improvements, 
but it would be great if it would still transport that this is a container of 
`Resource_`.
    
    Something like 
`resources[NoMutationWithoutExclusiveOwnership|Unsafe|NotConcurrencySafe|...]` 
would make the resulting usages more readable.
    
    We could also accompany this with a name for the type users could use, e.g.,
    
        using Resources_Unsafe = std::shared_ptr<Resource_>;
        
    These could be used now in places we'd use cow wrappers once the `TODO` 
gets implemented.


- Benjamin Bannier


On Sept. 6, 2018, 2:13 a.m., Meng Zhu wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/68639/
> -----------------------------------------------------------
> 
> (Updated Sept. 6, 2018, 2:13 a.m.)
> 
> 
> Review request for mesos, Benjamin Bannier, Benjamin Mahler, and Gastón 
> Kleiman.
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> Due to the copy-on-write optimization (MESOS-6765), one needs to
> check the `use_count` of `Resource_` before mutating. Currently,
> there is no mechanism to enforce this. As a short-term mitigation
> measure, we rename `resources` to `noMutationWithoutExclusiveOwnership`
> to alert people about obtaining an exclusive ownership before mutating
> the `Resource_` objects.
> 
> 
> Diffs
> -----
> 
>   include/mesos/resources.hpp 6f81b14f8bc090a144eeae8f15639c370366166d 
>   include/mesos/v1/resources.hpp 09110530da16678abf6bf6b308906dd8ccc8180a 
>   src/common/resources.cpp 3e63cdedb9261970dbeb9bb9f97eed65819f68a7 
>   src/v1/resources.cpp 3683a331e0859cd6f2ad061db6ba67112ecfcb0d 
> 
> 
> Diff: https://reviews.apache.org/r/68639/diff/1/
> 
> 
> Testing
> -------
> 
> make check
> 
> 
> Thanks,
> 
> Meng Zhu
> 
>

Reply via email to