I wasn't sure where to jump into this thread, but my vote is to keep the 
generator since it is a helpful "canonical example" for those trying to get 
started.

However, I do suggest one change, that might sound a bit radical, but which 
I think supports most of the thinking I'm seeing in this thread: rename the 
generator to something that makes it clear it's more for educational 
purposes than anything else.  

Something like "example_resource" might make it really, really obvious that 
the code is an example, shows all the possible actions, even has a couple 
of responders, etc... basically a way to see a good example of both code 
and forms that follow all of the naming conventions.  But it's clear it's 
just an *example* and not simply a real starting point.  

$ rails g example_resource Product title sku 

Of course, it *is* a real starting point for those of us who understand 
Rails and use it like Jose does - we know how to customize what we want - 
but for those new to Rails it's clear it's just an example to help them 
understand the possibilities and get familiar with the conventions.

I think also getting the name "resource" in there helps normalize our 
vocabulary a bit more instead of "scaffold" which isn't really used 
anywhere else in the framework.

Jeff

-- 
You received this message because you are subscribed to the Google Groups "Ruby 
on Rails: Core" group.
To view this discussion on the web visit 
https://groups.google.com/d/msg/rubyonrails-core/-/NglvoM95wiIJ.
To post to this group, send email to rubyonrails-core@googlegroups.com.
To unsubscribe from this group, send email to 
rubyonrails-core+unsubscr...@googlegroups.com.
For more options, visit this group at 
http://groups.google.com/group/rubyonrails-core?hl=en.

Reply via email to