Le 20/09/2013 13:40, Henri Sivonen a écrit :
On Tue, Sep 10, 2013 at 6:47 PM, Simon Sapin<simon.sa...@exyr.org>  wrote:
     /// Call this to indicate the end of the input.
     /// The Decoder instance should be discarded afterwards.
     /// Some encodings may append some final output at this point.
     /// May raise the decoding_error condition.
     fn flush(output: &mut ~str) -> Option<DecodeError>;
Please call this "finish" instead of calling it "flush". In other
APIs, for example JDK APIs, flush really just means flushing the
current buffers instead of ending the stream, so calling the method
that does end-of-stream processing "flush" would be confusing.

"flush" is the name that rust-encoding uses, but I argee that "finish" is better for what it does.

--
Simon Sapin
_______________________________________________
Rust-dev mailing list
Rust-dev@mozilla.org
https://mail.mozilla.org/listinfo/rust-dev

Reply via email to