Ask yourself, are these arguments you give for current is_prime(x) 
behaviour not just the inertia of your thinking.

Wolfram tells me plainly "1/3 (2^23 + 1) is a prime number"---no ambiguity, 
no attempt to show a glimpse of algebraic truth.

Pari gives
? isprime((2^23+1)/3)
%1 = 1

Giac:
>> is_prime((2^23+1)/3)
1

SymPy however:
In [7]: isprime((2**23+1)/3)
Out[7]: False

But then it's clear that the value is not integer:
In [8]: (2**23+1)/3
Out[8]: 2796203.0

Why not improve mathematics? Why not define the primality term you apply in 
the element is_prime() as having a different name than "prime"? Why not 
introduce 123/1 as notation to avoid ambiguities in mathematics? I'm quite 
astonished that mathematicians allow these fuzziness in their language, it 
is unusual. 

-- 
You received this message because you are subscribed to the Google Groups 
"sage-devel" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to sage-devel+unsubscr...@googlegroups.com.
To post to this group, send email to sage-devel@googlegroups.com.
Visit this group at https://groups.google.com/group/sage-devel.
For more options, visit https://groups.google.com/d/optout.

Reply via email to