Re: RFC 290 (v2) Better english names for -X

2000-09-27 Thread Nathan Wiger

Adam Turoff wrote:
> 
> >   PRL> -r  freadable()
> >   PRL> -w  fwriteable()
> >   PRL> -x  fexecable()
> >   PRL> -o  fowned()
> >
> >   PRL> -R  Freadable()
> >   PRL> -W  Fwriteable()
> >   PRL> -X  Fexecable()
> >   PRL> -O  Fowned()
> >
> > this looks decent to me.
> 
> I reserve the right to switch to readable/writeable iff the socket/exists
> issue has a resolution.  Thoughts anyone?

I actually like the above because of the common prefix. It makes it
quite clear these are file tests.
 
> > maybe make the prefix f_ to make it a little
> > more readable (overriding that word again! :)?
> 
> I can't think of any builtins that use _

Indeed, no builtins include _. In fact, the warning

   Unquoted string "stuff" may clash with future reserved word

is only raised if:

  You used a bareword that might someday be claimed as a
  reserved word. It's best to put such a word in quotes,
  or capitalize it somehow, or insert an underbar into it.
 
> > also f/Fexecable() looks very odd.
> 
> Patches welcome for f/F.

Yeah, mixed case gives me the willies! Bigtime. Plus, see above. Here's
some:

   frealreadable()
   frealwriteable()
   frealexecable()
   frealowned

I was going to list other alternatives, but I think those work just
fine, personally. Long is not necessarily bad; this is "use english"
after all.

-Nate



Re: RFC 290 (v2) Better english names for -X

2000-09-27 Thread Uri Guttman

> "AT" == Adam Turoff <[EMAIL PROTECTED]> writes:


  AT> I can't think of any builtins that use _, but it's going to be 
  AT> exposed by use english, so perhaps that qualifies it.  I'm 
  AT> on the fence though. If it's going to be *_writeable, is_writable()
  AT> looks better.  It is tom's original proposal, after all.

fine with me. but i like f_ (or plain f) better as is_ doesn't work well
with access/modified etc. using f/F is more consistant and marks them as
file tests.

  AT> Patches welcome for f/F.

that was about the execable part, not the f/F

  AT> No, I chose execable intentionally.  Probably change it to executable
  AT> in v3 anyway.

who gave you permission to invent new words? :)

uri

-- 
Uri Guttman  -  [EMAIL PROTECTED]  --  http://www.sysarch.com
SYStems ARCHitecture, Software Engineering, Perl, Internet, UNIX Consulting
The Perl Books Page  ---  http://www.sysarch.com/cgi-bin/perl_books
The Best Search Engine on the Net  --  http://www.northernlight.com



Re: RFC 290 (v2) Better english names for -X

2000-09-27 Thread Adam Turoff

On Wed, Sep 27, 2000 at 03:48:33AM -0400, Uri Guttman wrote:
> > "PRL" == Perl6 RFC Librarian <[EMAIL PROTECTED]> writes:
> 
>   PRL> -r  freadable()
>   PRL> -w  fwriteable()
>   PRL> -x  fexecable()
>   PRL> -o  fowned()
> 
>   PRL> -R  Freadable()
>   PRL> -W  Fwriteable()
>   PRL> -X  Fexecable()
>   PRL> -O  Fowned()
>
> this looks decent to me. 

Well, it leaves readable for AIO callbacks, so of course you're going
to say that.  :-)

I reserve the right to switch to readable/writeable iff the socket/exists
issue has a resolution.  Thoughts anyone?

> maybe make the prefix f_ to make it a little
> more readable (overriding that word again! :)?

I can't think of any builtins that use _, but it's going to be 
exposed by use english, so perhaps that qualifies it.  I'm 
on the fence though. If it's going to be *_writeable, is_writable()
looks better.  It is tom's original proposal, after all.

> also f/Fexecable() looks very odd. 

Patches welcome for f/F.

> is that your choice or were your right
> and left hands fighting again? executable is probably the better term
> and who cares about 2 chars more if you are using this.

No, I chose execable intentionally.  Probably change it to executable
in v3 anyway.

Z.




Re: RFC 290 (v2) Better english names for -X

2000-09-27 Thread Uri Guttman

> "PRL" == Perl6 RFC Librarian <[EMAIL PROTECTED]> writes:

  PRL> -r  freadable()
  PRL> -w  fwriteable()
  PRL> -x  fexecable()
  PRL> -o  fowned()

  PRL> -R  Freadable()
  PRL> -W  Fwriteable()
  PRL> -X  Fexecable()
  PRL> -O  Fowned()

  PRL> -e  fexists()
  PRL> -z  fzero()
  PRL> -s  fsize()

  PRL> -f  ffile()
  PRL> -d  fdir()
  PRL> -l  flink()
  PRL> -p  fpipe()
  PRL> -S  fsocket()
  PRL> -b  fblock()
  PRL> -c  fchar()
  PRL> -t  ftty()

  PRL> -u  fsetuid()
  PRL> -g  fsetgid()
  PRL> -k  fsticky()

  PRL> -T  ftext()
  PRL> -B  fbinary()

  PRL> -M  fage()
  PRL> -A  faccessed()
  PRL> -C  fchanged()

this looks decent to me. maybe make the prefix f_ to make it a little
more readable (overriding that word again! :)?

also f/Fexecable() looks very odd. is that your choice or were your right
and left hands fighting again? executable is probably the better term
and who cares about 2 chars more if you are using this.

uri

-- 
Uri Guttman  -  [EMAIL PROTECTED]  --  http://www.sysarch.com
SYStems ARCHitecture, Software Engineering, Perl, Internet, UNIX Consulting
The Perl Books Page  ---  http://www.sysarch.com/cgi-bin/perl_books
The Best Search Engine on the Net  --  http://www.northernlight.com