[PATCH v4] Driver support for FSL RaidEngine device.

2014-04-14 Thread xuelin.shi
From: Xuelin Shi The RaidEngine is a new FSL hardware used for Raid5/6 acceration. This patch enables the RaidEngine functionality and provides hardware offloading capability for memcpy, xor and pq computation. It works with async_tx. Signed-off-by: Harninder Rai Signed-off-by: Naveen Burmi S

[PATCH v2 1/2] fsl/corenet_generic: add a particular initialization for platform

2014-04-14 Thread Dongsheng Wang
From: Wang Dongsheng Corenet_generic is a generic platform initialization. Those based on the corenet_generic board maybe need a particular initialize to enable/set some IP-Blocks. So add "Fix Generic Initialization" to solve this kind of special cases. Signed-off-by: Wang Dongsheng --- *v2* 1

[PATCH v2 2/2] fsl/corenet_generic: add t104x platform diu special initialization

2014-04-14 Thread Dongsheng Wang
From: Wang Dongsheng T104x Platforms based on corenet_generic. The platforms DIU-block that need a special initialization to solve some callback functions, those functions depend on platform handle. Signed-off-by: Wang Dongsheng --- This patch is *depends on* Prabhakar Kushwaha support T104x pa

RE: [PATCH 2/2] fsl/mpic_timer: make mpic_timer to support deep sleep feature

2014-04-14 Thread dongsheng.w...@freescale.com
> -Original Message- > From: Wood Scott-B07421 > Sent: Tuesday, April 15, 2014 7:36 AM > To: Wang Dongsheng-B40534 > Cc: Jin Zhengxiong-R64188; Li Yang-Leo-R58472; Zhao Chenhui-B35336; linuxppc- > d...@lists.ozlabs.org > Subject: Re: [PATCH 2/2] fsl/mpic_timer: make mpic_timer to support

RE: [PATCH v3] dmaengine: driver support for FSL RaidEngine device.

2014-04-14 Thread Xuelin Shi
Yes, "depend on !ASYNC_TX_CHANNEL_SWITCH" is better since fsldma selects this condition. Thanks, Xuelin Shi -Original Message- From: Dan Williams [mailto:dan.j.willi...@intel.com] Sent: 2014年4月15日 8:30 To: Shi Xuelin-B29237 Cc: Koul, Vinod; andriy.shevche...@intel.com; dmaeng...@vger.ke

Re: [PATCH] ASoC: fsl_sai: Fix incorrect condition check in trigger()

2014-04-14 Thread Nicolin Chen
On Mon, Apr 14, 2014 at 09:31:26PM +0100, Mark Brown wrote: > On Fri, Apr 11, 2014 at 10:10:00PM +0800, Nicolin Chen wrote: > > > + /* Check if the opposite FRDE is also disabled */ > > + if (!(tx ? rcsr & FSL_SAI_CSR_FRDE : tcsr & FSL_SAI_CSR_FRDE)) { > > I've applied this si

Re: [PATCH v2 2/2] ARM: dts: Append clock bindings for sai2 on VF610 platform

2014-04-14 Thread Nicolin Chen
On Mon, Apr 14, 2014 at 09:38:51PM +0100, Mark Brown wrote: > On Wed, Apr 02, 2014 at 06:10:20PM +0800, Nicolin Chen wrote: > > Since we added fours clock to the DT binding, we should update the current > > SAI dts/dtsi so as not to break their functions. > > This doesn't apply against v3.15-rc1,

Re: [PATCH v2 1/2] ASoC: fsl_sai: Add clock controls for SAI

2014-04-14 Thread Nicolin Chen
On Mon, Apr 14, 2014 at 09:43:31PM +0100, Mark Brown wrote: > On Wed, Apr 02, 2014 at 06:10:19PM +0800, Nicolin Chen wrote: > > > -- clock-names : Must include the "sai" entry. > > +- clock-names : Must include the "bus" for register access and "mclk1" > > "mclk2" > > + "mclk3" for bit clock and

RE: [PATCH 1/2] powerpc/mpc85xx: add two functions to get suspend state which is standby or mem

2014-04-14 Thread dongsheng.w...@freescale.com
> -Original Message- > From: Wood Scott-B07421 > Sent: Tuesday, April 15, 2014 7:27 AM > To: Wang Dongsheng-B40534 > Cc: Jin Zhengxiong-R64188; Li Yang-Leo-R58472; Zhao Chenhui-B35336; linuxppc- > d...@lists.ozlabs.org > Subject: Re: [PATCH 1/2] powerpc/mpc85xx: add two functions to get s

Re: [PATCH v3] dmaengine: driver support for FSL RaidEngine device.

2014-04-14 Thread Dan Williams
On Sun, Apr 13, 2014 at 7:48 PM, Xuelin Shi wrote: > Hi Dan, > > fsl dma device and fsl raid device are two differenct devices that both > provide async_memcpy > capability, so I use !FSL_DMA to disable the fsl dma device. > > That's to say, either select fsldma device, either fsl raid device. >

Re: [PATCH 2/2] fsl/mpic_timer: make mpic_timer to support deep sleep feature

2014-04-14 Thread Scott Wood
On Mon, 2014-04-14 at 10:24 +0800, Dongsheng Wang wrote: > From: Wang Dongsheng > > At T104x platfrom the timer clock will be changed when system going to > deep sleep. Could you elaborate on what is changing and why? > +#include > #include So much for, "The driver currently is only tested

Re: [PATCH 1/2] powerpc/mpc85xx: add two functions to get suspend state which is standby or mem

2014-04-14 Thread Scott Wood
On Mon, 2014-04-14 at 10:24 +0800, Dongsheng Wang wrote: > From: Wang Dongsheng > > Add set_pm_suspend_state & pm_suspend_state functions to set/get suspend > state. > When system going to sleep, devices can get the system suspend > state(STANDBY/MEM) > through pm_suspend_state function and han

Re: [PATCH] powerpc/85xx: Add OCA4080 board support

2014-04-14 Thread Scott Wood
On Mon, 2014-04-14 at 14:35 +0200, Martijn de Gouw wrote: > + lbc: localbus@ffe124000 { > + reg = <0xf 0xfe124000 0 0x1000>; > + ranges = <0 0 0xf 0xef80 0x80>; > + > + flash@0,0 { > + #address-cells = <1>; > +

[PATCH 18/20] cpufreq: pasemi: Use cpufreq_for_each_entry macro for iteration

2014-04-14 Thread Stratos Karafotis
The cpufreq core supports the cpufreq_for_each_entry macro helper for iteration over the cpufreq_frequency_table, so use it. It should have no functional changes. Signed-off-by: Stratos Karafotis --- Please note that I was no able to compile test this patch due to lack of cross compiler. dri

Re: [PATCH 1/1] powerpc: Increase COMMAND_LINE_SIZE to 2048 from 512.

2014-04-14 Thread Joseph Salisbury
On 04/14/2014 11:30 AM, Joseph Salisbury wrote: > BugLink: http://bugs.launchpad.net/bugs/1306677 > > While booting the PPC64EL kernel, the command line gets truncated to 512 > characters. This is due to a hard limit of 512 defined for COMMAND_LINE_SIZE. > It would be beneficial to have a comman

[PATCH 1/1] powerpc: Increase COMMAND_LINE_SIZE to 2048 from 512.

2014-04-14 Thread Joseph Salisbury
BugLink: http://bugs.launchpad.net/bugs/1306677 While booting the PPC64EL kernel, the command line gets truncated to 512 characters. This is due to a hard limit of 512 defined for COMMAND_LINE_SIZE. It would be beneficial to have a command line longer than 512 characters, as iscsi targets and

Re: [PATCH] ASoC: fsl_sai: Use FSL_SAI_xXR() and regmap_update_bits() to simplify code

2014-04-14 Thread Mark Brown
On Fri, Apr 11, 2014 at 06:30:09PM +0800, Nicolin Chen wrote: > By doing this, the driver can drop around 50 lines and become neater. Applied, thanks. signature.asc Description: Digital signature ___ Linuxppc-dev mailing list Linuxppc-dev@lists.ozlabs.

Re: [PATCH v2 1/2] ASoC: fsl_sai: Add clock controls for SAI

2014-04-14 Thread Mark Brown
On Wed, Apr 02, 2014 at 06:10:19PM +0800, Nicolin Chen wrote: > -- clock-names : Must include the "sai" entry. > +- clock-names : Must include the "bus" for register access and "mclk1" > "mclk2" > + "mclk3" for bit clock and frame clock providing. This breaks compatibilty with old DTs - it just

Re: [PATCH v2 2/2] ARM: dts: Append clock bindings for sai2 on VF610 platform

2014-04-14 Thread Mark Brown
On Wed, Apr 02, 2014 at 06:10:20PM +0800, Nicolin Chen wrote: > Since we added fours clock to the DT binding, we should update the current > SAI dts/dtsi so as not to break their functions. This doesn't apply against v3.15-rc1, can you please check and resend? signature.asc Description: Digital

Re: [PATCH] ASoC: fsl_sai: Fix incorrect condition check in trigger()

2014-04-14 Thread Mark Brown
On Fri, Apr 11, 2014 at 10:10:00PM +0800, Nicolin Chen wrote: > + /* Check if the opposite FRDE is also disabled */ > + if (!(tx ? rcsr & FSL_SAI_CSR_FRDE : tcsr & FSL_SAI_CSR_FRDE)) { I've applied this since it's a fix but this is *not* a triumph of legibility, the terner

Re: [PATCH v3 6/8] DMA: Freescale: change descriptor release process for supporting async_tx

2014-04-14 Thread Andy Shevchenko
On Fri, 2014-04-11 at 16:33 +0800, Hongbo Zhang wrote: > >>> + * hardware channel, subsequent descriptors are either in > >>> + * process or have not been submitted > >> Dot at the eol. Check in all comments. > > > > Even though I saw there are other comments without the dots, I th

Re: [PATCH v3 4/8] DMA: Freescale: add fsl_dma_free_descriptor() to reduce code duplication

2014-04-14 Thread Andy Shevchenko
On Fri, 2014-04-11 at 16:14 +0800, Hongbo Zhang wrote: > On 04/10/2014 07:29 PM, Andy Shevchenko wrote: > > On Thu, 2014-04-10 at 15:10 +0800, hongbo.zh...@freescale.com wrote: [] > >> @@ -819,8 +826,7 @@ static void fsldma_cleanup_descriptor(struct > >> fsldma_chan *chan, > >>dma_run_depend

[PATCH 2/2] PCI/MSI: Phase out pci_enable_msi_block()

2014-04-14 Thread Alexander Gordeev
There are no users of pci_enable_msi_block() function have left. Obsolete it in favor of pci_enable_msi_range() and pci_enable_msi_exact() functions. Up until now, when enabling MSI mode for a device a single successful call to arch_msi_check_device() was followed by a single call to arch_setup_ms

[PATCH] powerpc/85xx: Add OCA4080 board support

2014-04-14 Thread Martijn de Gouw
From: Martijn de Gouw OCA4080 overview: - 1.466 GHz Freescale QorIQ P4080E Processor - 4Gbyte DDR3 on board - 8Mbyte Nor flash - Serial RapidIO 1.2 - 1 x 10/100/1000 BASE-T front ethernet - 1 x 1000 BASE-BX ethernet on AMC connector Signed-off-by: Martijn de Gouw --- arch/powerpc/boot/dts/oca4

Re: [PATCH 2/2] PCI/MSI: Phase out pci_enable_msi_block()

2014-04-14 Thread Alexander Gordeev
On Mon, Apr 14, 2014 at 09:14:07AM +0200, Alexander Gordeev wrote: > @@ -1244,7 +1241,7 @@ static inline void pcie_set_ecrc_checking(struct > pci_dev *dev) { } > static inline void pcie_ecrc_get_policy(char *str) { } > #endif > > -#define pci_enable_msi(pdev) pci_enable_msi_block(pdev, 1) > +#

[PATCH 3/3] powerpc: Bump BOOT_COMMAND_LINE_SIZE to 2048

2014-04-14 Thread Anton Blanchard
Bump the boot wrapper BOOT_COMMAND_LINE_SIZE to match the kernel. Signed-off-by: Anton Blanchard --- We export this in an ELF section so userspace tools can edit it. We should be safe so long as we are only increasing it shouldn't we? Index: b/arch/powerpc/boot/ops.h ===

[PATCH 2/3] powerpc: Bump COMMAND_LINE_SIZE to 2048

2014-04-14 Thread Anton Blanchard
I've had a report that the current limit is too small for an automated network based installer. Bump it. Signed-off-by: Anton Blanchard --- diff --git a/arch/powerpc/include/uapi/asm/setup.h b/arch/powerpc/include/uapi/asm/setup.h index 552df83..0516e97 100644 --- a/arch/powerpc/include/uapi/as

[PATCH 1/3] powerpc: Rename duplicate COMMAND_LINE_SIZE define

2014-04-14 Thread Anton Blanchard
We have two definitions of COMMAND_LINE_SIZE, one for the kernel and one for the boot wrapper. I assume this is so the boot wrapper can be self sufficient and not rely on kernel headers. Having two defines with the same name is confusing, I just updated the wrong one when trying to bump it. Make

[PATCH] powerpc: Fix error return in rtas_flash module init

2014-04-14 Thread Anton Blanchard
module_init should return 0 or a negative errno. Signed-off-by: Anton Blanchard --- diff --git a/arch/powerpc/kernel/rtas_flash.c b/arch/powerpc/kernel/rtas_flash.c index 2f3cdb0..658e89d 100644 --- a/arch/powerpc/kernel/rtas_flash.c +++ b/arch/powerpc/kernel/rtas_flash.c @@ -705,7 +705,7 @@ sta

Re: [PATCH v3] powerpc: kvm: make _PAGE_NUMA take effect

2014-04-14 Thread Alexander Graf
On 14.04.14 10:08, liu ping fan wrote: On Mon, Apr 14, 2014 at 2:43 PM, Alexander Graf wrote: On 13.04.14 04:27, Liu ping fan wrote: On Fri, Apr 11, 2014 at 10:03 PM, Alexander Graf wrote: On 11.04.2014, at 13:45, Liu Ping Fan wrote: When we mark pte with _PAGE_NUMA we already call mmu_n

Re: [PATCH v3] powerpc: kvm: make _PAGE_NUMA take effect

2014-04-14 Thread liu ping fan
On Mon, Apr 14, 2014 at 2:43 PM, Alexander Graf wrote: > > On 13.04.14 04:27, Liu ping fan wrote: >> >> On Fri, Apr 11, 2014 at 10:03 PM, Alexander Graf wrote: >>> >>> On 11.04.2014, at 13:45, Liu Ping Fan >>> wrote: >>> When we mark pte with _PAGE_NUMA we already call mmu_notifier_inv

[PATCH v2 07/15] powerpc/boot: define typedef ihandle as u32

2014-04-14 Thread Cédric Le Goater
This makes ihandle 64bit friendly. Signed-off-by: Cédric Le Goater --- arch/powerpc/boot/of.h|2 +- arch/powerpc/boot/oflib.c | 10 +- 2 files changed, 6 insertions(+), 6 deletions(-) diff --git a/arch/powerpc/boot/of.h b/arch/powerpc/boot/of.h index 504a0a31b685..e1ef620082f7

[PATCH v2 15/15] powerpc/boot: add support for 64bit little endian wrapper

2014-04-14 Thread Cédric Le Goater
The code is only slightly modified : entry points now use the FIXUP_ENDIAN trampoline to switch endian order. The 32bit wrapper is kept for big endian kernels and 64bit is enforced for little endian kernels with a PPC64_BOOT_WRAPPER config option. The linker script is generated using the kernel pr

[PATCH v2 14/15] powerpc/boot: add a global entry point for pseries

2014-04-14 Thread Cédric Le Goater
When entering the boot wrapper in little endian, we will need to fix the endian order using a fixup trampoline like in the kernel. This patch overrides the _zimage_start entry point for this purpose. Signed-off-by: Cédric Le Goater --- Changes since v1: - pseries is not the only platform gener

[PATCH v2 12/15] powerpc/boot: define a routine to enter prom

2014-04-14 Thread Cédric Le Goater
This patch defines a 'prom' routine similar to 'enter_prom' in the kernel. The difference is in the MSR which is built before entering prom. Big endian order is enforced as in the kernel but 32bit mode is not. It prepares ground for the next patches which will introduce Little endian order. Signe

[PATCH v2 11/15] powerpc/boot: add little endian support to elf utils

2014-04-14 Thread Cédric Le Goater
Signed-off-by: Cédric Le Goater --- arch/powerpc/boot/elf_util.c |4 1 file changed, 4 insertions(+) diff --git a/arch/powerpc/boot/elf_util.c b/arch/powerpc/boot/elf_util.c index 1567a0c0f05c..316552dea4d8 100644 --- a/arch/powerpc/boot/elf_util.c +++ b/arch/powerpc/boot/elf_util.c @@

[PATCH v2 13/15] powerpc/boot: modify entry point for 64bit

2014-04-14 Thread Cédric Le Goater
This patch adds support a 64bit wrapper entry point. As in 32bit, the entry point does its own relocation and can be loaded at any address by the firmware. Signed-off-by: Cédric Le Goater --- arch/powerpc/boot/crt0.S | 108 -- 1 file changed, 104 inse

[PATCH v2 10/15] powerpc/boot: add 64bit and little endian support to addnote

2014-04-14 Thread Cédric Le Goater
It could certainly be improved using Elf macros and byteswapping routines, but the initial version of the code is organised to be a single file program with limited dependencies. yaboot is the same. Please scream if you want a total rewrite. Signed-off-by: Cédric Le Goater --- Changes since RFC

[PATCH v2 06/15] powerpc/boot: rework of_claim() to make it 64bit friendly

2014-04-14 Thread Cédric Le Goater
This patch fixes 64bit compile warnings and updates the wrapper code to converge the kernel code in prom_init. Signed-off-by: Cédric Le Goater --- Changes since v1: - use PROM_ERROR to test return addr arch/powerpc/boot/of.c|4 ++-- arch/powerpc/boot/of.h|3 ++- arch/powerpc/

[PATCH v2 09/15] powerpc/boot: define byteswapping routines for little endian

2014-04-14 Thread Cédric Le Goater
These are not the most efficient versions of swab but the wrapper does not do much byte swapping. On a big endian cpu, these routines are a no-op. Signed-off-by: Cédric Le Goater --- arch/powerpc/boot/of.h |7 +++ arch/powerpc/boot/swab.h | 29 + 2 files c

[PATCH v2 05/15] powerpc/boot: add PROM_ERROR define in oflib

2014-04-14 Thread Cédric Le Goater
This is mostly useful to make to the boot wrapper code closer with the kernel code in prom_init. Signed-off-by: Cédric Le Goater --- Changes since v1: - moved PROM_ERROR definition in of.h. of_try_claim() will make use of it in the next patch. arch/powerpc/boot/of.h|2 ++ arch/po

[PATCH v2 08/15] powerpc/boot: fix compile warning in 64bit

2014-04-14 Thread Cédric Le Goater
arch/powerpc/boot/oflib.c:211:9: warning: cast to pointer from integer of \ different size [-Wint-to-pointer-cast] return (phandle) of_call_prom("finddevice", 1, 1, name); This is a work around. The definite solution would be to define the phandle typedef as a u32, as in the k

[PATCH v2 04/15] powerpc/boot: add byteswapping routines in oflib

2014-04-14 Thread Cédric Le Goater
Values will need to be byte-swapped when calling prom (big endian) from a little endian boot wrapper. Signed-off-by: Cédric Le Goater --- arch/powerpc/boot/of.h|3 +++ arch/powerpc/boot/ofconsole.c |6 -- arch/powerpc/boot/oflib.c | 22 +++--- 3 files ch

[PATCH v2 03/15] powerpc/boot: use prom_arg_t in oflib

2014-04-14 Thread Cédric Le Goater
This patch updates the wrapper code to converge with the kernel code in prom_init. Signed-off-by: Cédric Le Goater --- arch/powerpc/boot/oflib.c | 10 ++ 1 file changed, 6 insertions(+), 4 deletions(-) diff --git a/arch/powerpc/boot/oflib.c b/arch/powerpc/boot/oflib.c index c3288a3446

[PATCH v2 02/15] powerpc/boot: use a common prom_args struct in oflib

2014-04-14 Thread Cédric Le Goater
This patch fixes warnings when the wrapper is compiled in 64bit and updates the boot wrapper code related to prom to converge with the kernel code in prom_init. This should make the review of changes easier. The kernel has a different number of possible arguments (10) when entering prom. There doe

[PATCH v2 00/15] powerpc/boot: 64bit little endian wrapper

2014-04-14 Thread Cédric Le Goater
Hi, The following patchset adds support for 64bit little endian boot wrapper. It is based on original code from Andrew Tauferner. The first patches provide fixes for 64bit support. I also changed the prom code to make it converge with the prom_init kernel code. They have a lot in common and t

[PATCH v2 01/15] powerpc/boot: fix do_div for 64bit wrapper

2014-04-14 Thread Cédric Le Goater
When the boot wrapper is compiled in 64bit, there is no need to use __div64_32. Signed-off-by: Cédric Le Goater --- arch/powerpc/boot/stdio.c | 14 ++ 1 file changed, 14 insertions(+) diff --git a/arch/powerpc/boot/stdio.c b/arch/powerpc/boot/stdio.c index 5b57800bbc67..a701261b17

[PATCH 2/2] PCI/MSI: Phase out pci_enable_msi_block()

2014-04-14 Thread Alexander Gordeev
There are no users of pci_enable_msi_block() function have left. Obsolete it in favor of pci_enable_msi_range() and pci_enable_msi_exact() functions. Up until now, when enabling MSI mode for a device, a single successful call to arch_msi_check_device() was followed by a single call to arch_setup_m

[PATCH 0/2] Phase out pci_enable_msi_block()

2014-04-14 Thread Alexander Gordeev
Hello, This series is against 3.15-rc1. This update obsoletes pci_enable_msi_block() function in favor of pci_enable_msi_range() and pci_enable_msi_exact(). Cc: Frank Haverkamp Cc: Greg Kroah-Hartman Cc: linux-m...@linux-mips.org Cc: linuxppc-dev@lists.ozlabs.org Cc: linux-s...@vger.kernel.or