[Python-ideas] Re: Descriptor __get__ and __set__ argument discrepancy

2023-10-19 Thread Antoine Rozo
ry useful. > > DG > ___ > Python-ideas mailing list -- python-ideas@python.org > To unsubscribe send an email to python-ideas-le...@python.org > https://mail.python.org/mailman3/lists/python-ideas.python.org/ > Message archived at > htt

[Python-ideas] Re: Extract variable name from itself

2023-09-12 Thread Antoine Rozo
gt; Regards, > DG > ___ > Python-ideas mailing list -- python-ideas@python.org > To unsubscribe send an email to python-ideas-le...@python.org > https://mail.python.org/mailman3/lists/python-ideas.python.org/ > Message arch

[Python-ideas] Re: Make ellipsis an indicator of missing implementation

2023-04-27 Thread Antoine Rozo
Python-ideas mailing list -- python-ideas@python.org > To unsubscribe send an email to python-ideas-le...@python.org > https://mail.python.org/mailman3/lists/python-ideas.python.org/ > Message archived at > https://mail.python.org/archives/list/python-ideas@python.org/mes

[Python-ideas] Re: Ampersand operator for strings

2023-03-11 Thread Antoine Rozo
/A7RPR3FSBXEMRYAUXJVYYROCHVHL7DVP/ > > Code of Conduct: http://python.org/psf/codeofconduct/ > > _______ > Python-ideas mailing list -- python-ideas@python.org > To unsubscribe send an email to python-ideas-le...@python.org > https://mail

[Python-ideas] Re: join() could add separators at start or end

2023-03-10 Thread Antoine Rozo
out it as Ben suspects in one or two > cases. > > Best wishes > Rob Cliffe > ___ > Python-ideas mailing list -- python-ideas@python.org > To unsubscribe send an email to python-ideas-le...@python.org > https://mail.python.org/

[Python-ideas] Re: Delete dictionary entry if key exists using -= operator via __isub__()

2022-04-28 Thread Antoine Rozo
/mail.python.org/archives/list/python-ideas@python.org/message/BBFALX57PJI4ALF4O6YGYMHMLNL4U4YI/ > Code of Conduct: http://python.org/psf/codeofconduct/ > -- Antoine Rozo ___ Python-ideas mailing list -- python-ideas@python.org To unsubscribe s

[Python-ideas] Re: mro and super don't feel so pythonic

2022-04-13 Thread Antoine Rozo
st -- python-ideas@python.org > To unsubscribe send an email to python-ideas-le...@python.org > https://mail.python.org/mailman3/lists/python-ideas.python.org/ > Message archived at > https://mail.python.org/archives/list/python-ideas@python.org/message/KWXDZBGZBX3LLCP3FQ33T

[Python-ideas] Re: mro and super don't feel so pythonic

2022-04-08 Thread Antoine Rozo
If these examples were possible (I wouldn't say they are smart designs) they would lead to recursion errors. Limitations on MRO are good, they force to keep a quite simple structure. Le jeu. 7 avr. 2022 à 17:41, malmiteria a écrit : > Antoine Rozo writes: > > If the only feature you

[Python-ideas] Re: mro and super don't feel so pythonic

2022-04-07 Thread Antoine Rozo
tic MRO, is needed to make that work. > I'm curious about this exemple, do you have a link to share so i could > have a look at the code / change in code? This could be a good exercice. > ___ > Python-ideas mailing list -- python

[Python-ideas] Re: define an idiomatic way to make a generator that throws StopIteration immediately and add it to PEP8

2021-09-03 Thread Antoine Rozo
; Code of Conduct: http://python.org/psf/codeofconduct/ -- Antoine Rozo ___ Python-ideas mailing list -- python-ideas@python.org To unsubscribe send an email to python-ideas-le...@python.org https://mail.python.org/mailman3/lists/python-ideas.python.org/ Mess

[Python-ideas] Re: staticmethod with property

2021-08-25 Thread Antoine Rozo
gt; Python-ideas mailing list -- python-ideas@python.org > To unsubscribe send an email to python-ideas-le...@python.org > https://mail.python.org/mailman3/lists/python-ideas.python.org/ > Message archived at > https://mail.python.org/archives/list/python-ideas@python.org/message/M45PDOVAKJPF

[Python-ideas] Re: Getting rid of FOR loops and simplifying cicular conviolutions with Circular Indexing

2020-11-25 Thread Antoine Rozo
/mail.python.org/archives/list/python-ideas@python.org/message/5TJYKFLBHB26WEFFQXMY6AGWS34XTIUR/ >> Code of Conduct: http://python.org/psf/codeofconduct/ >> > > > -- > > CALVIN SPEALMAN > > SENIOR QUALITY ENGINEER > > cspea...@redhat.com M: +1.336.210.5107

[Python-ideas] Re: Getting rid of FOR loops and simplifying cicular conviolutions with Circular Indexing

2020-11-25 Thread Antoine Rozo
arrays is offered by the fact that n-dimensional DFT reduces n-dimensional > circular convolution to element-wise multiplication. > > ___ > Python-ideas mailing list -- python-ideas@python.org > To unsubscribe send an email to python-ideas-le...@p

[Python-ideas] Re: Equality between some of the indexed collections

2020-05-02 Thread Antoine Rozo
onduct: http://python.org/psf/codeofconduct/ > > ___ > Python-ideas mailing list -- python-ideas@python.org > To unsubscribe send an email to python-ideas-le...@python.org > https://mail.python.org/mailman3/lists/python-ideas.python.org/

[Python-ideas] Re: SQL string prefix idea

2020-02-21 Thread Antoine Rozo
de of Conduct: http://python.org/psf/codeofconduct/ -- Antoine Rozo ___ Python-ideas mailing list -- python-ideas@python.org To unsubscribe send an email to python-ideas-le...@python.org https://mail.python.org/mailman3/lists/python-ideas.py

[Python-ideas] Re: Proposal: Complex comprehensions containing statements

2020-02-21 Thread Antoine Rozo
> Would you feel better if `yield` was always required? Yes but then it's the same as defining a generator-function. > For almost all the examples I've provided a corresponding equivalent in the > current syntax, so are you saying that you're still confused now or that you > can't figure it

[Python-ideas] Re: Proposal: Complex comprehensions containing statements

2020-02-21 Thread Antoine Rozo
ld be the clear winner in any similar situation - > no careful judgement needed. This would become the one (and only one) obvious > way to do it. The new syntax has the elegance of list comprehensions and the > flexibility of multiple statements. It's completely scalable and works &g

[Python-ideas] Re: Add Binary module.

2020-02-16 Thread Antoine Rozo
..@python.org > https://mail.python.org/mailman3/lists/python-ideas.python.org/ > Message archived at > https://mail.python.org/archives/list/python-ideas@python.org/message/RJLGYE4N7NR6JYFSA64VES375U45PIKW/ > Code of Conduct: http://python.org/psf/codeofconduct/ -- Antoine Rozo _

[Python-ideas] Re: Add Binary module.

2020-02-16 Thread Antoine Rozo
-le...@python.org > https://mail.python.org/mailman3/lists/python-ideas.python.org/ > Message archived at > https://mail.python.org/archives/list/python-ideas@python.org/message/VGPNG4IBWGRWPEQOAKCNTLBINWQS4BZO/ > Code of Conduct: http://python.org/psf/codeofconduct/ -- Antoine Rozo __

[Python-ideas] Re: Annotated string literals

2020-02-03 Thread Antoine Rozo
gt; > Code of Conduct: http://python.org/psf/codeofconduct/ > _______ > Python-ideas mailing list -- python-ideas@python.org > To unsubscribe send an email to python-ideas-le...@python.org > https://mail.python.org/mailman3/lists/python-ideas.python.o

[Python-ideas] Re: The "When" Keyword

2019-12-29 Thread Antoine Rozo
python.org/archives/list/python-ideas@python.org/message/3VOQUSHPYTKLL65V6BUN4MMKKJOXCIKO/ > Code of Conduct: http://python.org/psf/codeofconduct/ -- Antoine Rozo ___ Python-ideas mailing list -- python-ideas@python.org To unsubscribe send an email to pyth

[Python-ideas] Re: Moving PEP 584 forward (dict + and += operators)

2019-12-03 Thread Antoine Rozo
(the behavior is a bit more obvious). I'm mostly just curious if the > difference between |= and dict.update() would end up being similar as far as > performance goes, with |= having a negligible advantage over dict.update() in > most situations. > __

[Python-ideas] Re: Additional meanings for "in" operator and ability to customize implementation

2019-10-13 Thread Antoine Rozo
on.org > https://mail.python.org/mailman3/lists/python-ideas.python.org/ > Message archived at > https://mail.python.org/archives/list/python-ideas@python.org/message/LOWRX42JL3SWG4QSOMV3WX4SOLJBXPXV/ > Code of Conduct: http://python.org/psf/codeofconduct/ > -- Antoine Rozo

Re: [Python-ideas] ternary without else

2018-05-26 Thread Antoine Rozo
Dismiss my message, I have read `if "art_wt" not in article`. But in the same way, you could have a function to reset a value in your dict if the current value evaluates to False. 2018-05-26 11:21 GMT+02:00 Antoine Rozo <antoine.r...@gmail.com>: > > if not article[&quo

Re: [Python-ideas] ternary without else

2018-05-26 Thread Antoine Rozo
eas mailing list >> Python-ideas@python.org >> https://mail.python.org/mailman/listinfo/python-ideas >> Code of Conduct: http://python.org/psf/codeofconduct/ >> > > > ___ > Python-ideas mailing list > Python-ideas@python.org > https://mail.python.org/mailman/listinfo/python-ideas > Code of Conduct: http://python.org/psf/codeofconduct/ > > -- Antoine Rozo ___ Python-ideas mailing list Python-ideas@python.org https://mail.python.org/mailman/listinfo/python-ideas Code of Conduct: http://python.org/psf/codeofconduct/

Re: [Python-ideas] Allow additional separator character in variables

2017-11-18 Thread Antoine Rozo
t; So is my proposal, and as usual urging for constructive conversation. > (i.e. proposing to write own language/translator is not constructive > conversation) > > > Cheers, > Mikhail > _______ > Python-ideas mailing list > Python-i

Re: [Python-ideas] install pip packages from Python prompt

2017-10-29 Thread Antoine Rozo
e the > > following line in their Python interpreter. > >pip("install woolamaloo-sheepshavers-goodies --user") > > which will install a package which will in turn, as dependencies, > > pull in a number of packages which are relevant for sheep shaving but > > w

Re: [Python-ideas] Add a module itertools.recipes

2017-10-14 Thread Antoine Rozo
Chris Angelico <ros...@gmail.com>: > On Sat, Oct 14, 2017 at 5:16 AM, Antoine Rozo <antoine.r...@gmail.com> > wrote: > > Hello, > > > > A very useful part of the itertools module's documentation is the section > > "Recipes", giving utility functions

[Python-ideas] Add a module itertools.recipes

2017-10-13 Thread Antoine Rozo
). Can we consider making itertools a package and adding a module itertools.recipes that implements all these utilility functions? Regards. -- Antoine Rozo ___ Python-ideas mailing list Python-ideas@python.org https://mail.python.org/mailman/listinfo/python-

Re: [Python-ideas] Make map() better

2017-09-15 Thread Antoine Rozo
dopt it. I see this only has promoting a peaceful > coexistence. > > Another pain point is python uses [].append() and JS uses [].join() Having > a wrapper for append would be helpful. > > And for that matter, why isn't append/extend a global? I can add things to > lots of dif

Re: [Python-ideas] Make map() better

2017-09-14 Thread Antoine Rozo
ite multi-language code > involving Python and JS. > > ChrisA > ___ > Python-ideas mailing list > Python-ideas@python.org > https://mail.python.org/mailman/listinfo/python-ideas > Code of Conduct: http://python.org/psf/code

Re: [Python-ideas] Make map() better

2017-09-14 Thread Antoine Rozo
t what >>> point does a method become a global? A member? Do we take the path that >>> everything is a global? Or should all methods be members? So far it seems >>> arbitrary. >>> >> >> Okay, its arbitrary. >> >> Why is it called [].len instead of [].length or {}.size? Why None >>

Re: [Python-ideas] New PEP 550: Execution Context

2017-08-11 Thread Antoine Rozo
te`` for generators and coroutines. > > The following code:: > > class Context: > > def __enter__(self): > self.old_x = get_execution_context_item('x') > set_execution_context_item('x', 'something') > > def __exit__(self, *err

Re: [Python-ideas] Pseudo methods

2017-08-04 Thread Antoine Rozo
readability > * Easy to understand > > ~Paul > > > ___ > Python-ideas mailing list > Python-ideas@python.org > https://mail.python.org/mailman/listinfo/python-ideas > Code of Conduct: http://python.org/psf/codeofconduct/ >

Re: [Python-ideas] ImportError raised for a circular import

2017-06-13 Thread Antoine Rozo
gt; > I am willing to work on a patch. > > Barry > > ___ > Python-ideas mailing list > Python-ideas@python.org > https://mail.python.org/mailman/listinfo/python-ideas > Code of Conduct: http://python.org/psf/codeofconduct/ > -- Antoine

Re: [Python-ideas] π = math.pi

2017-06-01 Thread Antoine Rozo
-ideas@python.org > https://mail.python.org/mailman/listinfo/python-ideas > Code of Conduct: http://python.org/psf/codeofconduct/ > > > > ___ > Python-ideas mailing list > Python-ideas@python.org > https://

Re: [Python-ideas] JavaScript-Style Object Creation in Python (using a constructor function instead of a class to create objects)

2017-05-14 Thread Antoine Rozo
t; > -- > Steve > ___ > Python-ideas mailing list > Python-ideas@python.org > https://mail.python.org/mailman/listinfo/python-ideas > Code of Conduct: http://python.org/psf/codeofconduct/ > -- Antoine Rozo __

Re: [Python-ideas] JavaScript-Style Object Creation in Python (using a constructor function instead of a class to create objects)

2017-05-14 Thread Antoine Rozo
gt;> better, and most of what it does are things that Python already does >>> better and has done better for years. In short, I don't see any >>> advantages at all to doing classes this way, and there are some >>> non-negligible disadvantages. >>> >> >