+1
It would be nice to have generic supertype constraints, with syntax along the
lines of `where A:B`.
Not sure if this is the same as what’s being suggested.
Example:
struct ViewWrapper {
let views:[T]
func add(_ view:V) -> ViewWrapper where V:T { // V must be a
subtype of T
I would also +1000 Xcode integration, whoever does it. I’m tired of fighting
with command-line mumbo jumbo just to setup and manage dependencies. SPM should
pave the way for high-level or junior devs to easily handle their dependencies
in the IDE of their choice.
> On 24 Oct 2017, at 13:46, Adr
> On Oct 12, 2017, at 1:40 PM, Mike Kluev wrote:
>
> let me guess: you put it on a different line exactly because it is in it's
> current ugly form :)
True, and it was making the method signature too long. But at least I have the
option to do that. If we move the annotation to just before th
IMO everyday app building would rarely need to use functions with discardable
results. This is more an issue with libraries or frameworks that support a
fluent interface (e.g. that return self) where an operator chain can be stopped
at any point, unless it clearly doesn’t make sense, in which ca
Best summary I’ve read on this thread for days! :)
> On Apr 5, 2017, at 6:54 PM, Nevin Brackett-Rozinsky via swift-evolution
> wrote:
>
> On Wed, Apr 5, 2017 at 12:02 AM, Chris Lattner via swift-evolution
> mailto:swift-evolution@swift.org>> wrote:
>
> - fileprivate should really become much
-1 to the new proposal. We should avoid a hybrid “private” which is both
lexically scoped *and* “something completely different”. Confusing.
+1 to BJ Homer’s opinion, with the caveat that we at least provide an option
(checkbox?) in the Xcode migrator to migrate “private” to “scoped” so the
pro
• What is your evaluation of the proposal?
-1 as written (see below)
• Is the problem being addressed significant enough to warrant a change to
Swift?
Not as written
• Does this proposal fit well with the feel and direction of Swift?
It does in terms of apparent simplicity, but not in terms of p
Generally I’m in favor of dropping “internal” as being somewhat vague, and
moving forward with module and fileprivate.
public
module
fileprivate (also google friendly)
private
> On Mar 15, 2016, at 5:32 PM, Charles Kissinger via swift-evolution
> wrote:
>
>>
>> On Mar 14, 2016, at 7:38 PM, S