Re: [boost] Re: current_function.hpp extension

2003-07-22 Thread John Torjo


>
> John Torjo schrieb:
>
> > Exactly! Don't do anything! But in order not to do anything, I need to
know
> > whether the compiler support a FUNCTION-like macro or not.
> >
> > Otherwise, I won't know (and assume it has), and print to the user
something
> > like:
> >
> > function= '(unknown)'.
> >
> > Which would you prefer?
>
> I although think, that some additional detection macro, a la
>
> BOOST_HAS_NO_CURRENT_FUNCTION_AVAILABLE
>
> would be useful and consistent to other deficiency flags already existing
> in the Boost library.
>
> Just my personal 0.02 EURO
>
True. With my 0.02 EURO, we already got 4 cents ;-)

Best,
John






___
Unsubscribe & other changes: http://lists.boost.org/mailman/listinfo.cgi/boost


Re: [boost] Re: current_function.hpp extension

2003-07-22 Thread John Torjo


> John Torjo wrote:
>
> > Yes, I remain unconvinced ;-)
> > This is because some compilers do not provide such a FUNCTION facility.
> > VC6 is one of them. What should I do for it?
>
> It sounds like you are asking for the wrong macro!
> You are trying to support a compiler that is outdated and long since
> replaced (but remains in widespread use)  A FUNCTION_NAME patch is
> unlikely to become available.
>
> Rather than assuming BOOST_FUNCTION_NAME is not available unless
> implemented though, you really want a macro that says 'this compiler is
> broken and will never be fixed', BOOST_NO_FUNCTION_NAME or similar.  So
> long as we are strict on allowing compilers into the list, I think all
> interests might be served?

Yes, it looks ok.
But I guess we're on the same side ;-)
This is what we wanted with BOOST_HAS_CURRENT_FUNCTION : just to tell us if
the current compiler has a FUNCTION_NAME facility.
(so, it could be renamed: BOOST_HAS_FUNCTION_NAME)

If we find that a current compiler has a FUNCTION_NAME facility, we (the
maintainer, of course) update the current_function.hpp header.

Where am I wrong?

Best,
John

>
> --
> AlisdairM
>
> ___
> Unsubscribe & other changes:
http://lists.boost.org/mailman/listinfo.cgi/boost
>

___
Unsubscribe & other changes: http://lists.boost.org/mailman/listinfo.cgi/boost


Re: [boost] Re: current_function.hpp extension

2003-07-19 Thread Peter Dimov
Daniel Frey wrote:
> On Sat, 19 Jul 2003 02:08:24 +0200, Pavel Vozenilek wrote:
>
>> "Peter Dimov" <[EMAIL PROTECTED]> wrote in message
>> news:[EMAIL PROTECTED] ...
>> SMART_ASSERT library implements BOOST_HAS_CURRENT_FUNCTION equivalent
>> (it would be ugly to print out the default text).
>
> Log-output again. And look at that workaround they used:
> Runtime-checking the values. Isn't that ugly? (No offense intended
> to the SMART_ASSERT-folks :)

Yes, it's ugly to see "Assertion failed in function (unknown)". The ugliness
provides a strong incentive for people to submit patches that make
BOOST_CURRENT_FUNCTION work on the compilers they are interested in. That's
the goal. Sneaky, huh.

___
Unsubscribe & other changes: http://lists.boost.org/mailman/listinfo.cgi/boost