Re: [OSL | CCIE_Voice] Per VC Frame Relay Fragmentation

2013-08-11 Thread Somphol Boonjing
I have rephrased my question slightly to highlight my dilemma which
involves whether or not to configure fragmentation on all PVCs or only one
out of three.

*Given below detail:*

HQ - SA - 64Kbps   (DLCI 100) - Data & Voice
HQ - SB - 128Kbps  (DLCI 200) - Data Only
HQ - SC - 64Kbps   (DLCI 300) - Data Only

HQ - 256Kbps <--- Aggregate WAN
SA - 64Kbps
SB - 128Kbps
SC - 64Kbps

3xG729 between HQ-SA

*Question: Configure FRF.12 with 10-ms delay for voice traffic.*

[1] According to Table 3-1 Recommended Fragment Sizes, CIR, and Bc Values
for Slow-Speed Frame Relay Links, it should be safe

to use PVC speed as a reference point to calcualte "Maximum Fragment Size
(for 10-ms Delay)".  (As opposed to a physical

interface's speed.) -
http://www.cisco.com/en/US/docs/solutions/Enterprise/WAN_and_MAN/QoS_SRND/WANQoS.html#wp106984

[2] Should I perform the fragmentation on DLCI 200 & DLCI 300 or not?  I
think it is reasonable to assume that since all of

these PVCs will share the same physical interface, fragmenting only for
large frame in DLCI 100 is not enough, therefore I

think it is necessary to also fragment DLCI 200 & DLCI 300.

[For reference, under section FRF.12 on this link, it is stated -
http://www.cisco.com/en/US/tech/tk652/tk698/technologies_configuration_example09186a0080094af9.shtml

"...Any other PVCs that share the same physical interface need to configure
the fragmentation to the size used by the voice PVC..."]

*If I have to bet, should I bet on performing fragmentation on all PVCs or
only perform fragmentation on HQ-SA's PVC?*

*Sample configuration below:*

Class-map match-any signal
 match ip dscp cs3

Class-map match-any voice
 match ip dscp ef

policy-map LLQ
 class voice
  priority 48
 class signal
  bandwidth 8
 class-default
  fair-queue

policy-map SHAPE-SA
 class class-default
  shape average 64000
  service-policy LLQ-SA

policy-map SHAPE-SB
 class class-default
  shape average 128000
  fair-queue

policy-map SHAPE-SC
 class class-default
  shape average 64000
  fair-queue


map-class frame-relay HQ-SA
 frame-relay fragment 80
 service-policy output SHAPE-SA

map-class frame-relay HQ-SB
 frame-relay fragment 160
 service-policy output SHAPE-SB

map-class frame-relay HQ-SC
 frame-relay fragment 80
 service-policy output SHAPE-SC

interface serial 0/0
 encapsulation frame-relay

interface serial 0/0.1 point-to-point
 ip address 192.168.1.1 255.255.255.0
 frame-relay interface-dlci 100
  class HQ-SA

interface serial 0/0.2 point-to-point
 ip address 192.168.2.1 255.255.255.0
 frame-relay interface-dlci 200
  class HQ-SB

interface serial 0/0.3 point-to-point
 ip address 192.168.3.1 255.255.255.0
 frame-relay interface-dlci 300
  class HQ-SC

Regards,
--Somphol.



On Tue, Aug 6, 2013 at 6:16 PM, Somphol Boonjing  wrote:

> Hi,
>
> Can anyone help confirm my understanding on this topic?
>
> My observation is that Per VC fragmentation, while it can be configured as
> when in the example below, is not very useful if not configured for all of
> the existing PVC that shared the same physical interface, isn't it?
>
> With the example below, only one of the VC (DLCI 100) is configured for
> fragmentation while the rest of the VCs (DLCI 200 & DCLI 300) that shared
> the same physical interface are not, then potentially outgoing fragmented
> frames from DLCI 100 could be waiting in queue while a fragmented large
> data frames from DLCI 200/DLCI 300 is being sent out.
>
> Am I correct?
>
>
> (REF:
> http://www.cisco.com/en/US/docs/ios-xml/ios/wan_frly/configuration/12-4t/wan-mqc-fr-tfshp.html#GUID-BAC1F514-EBD4-48FF-87AB-41F2BF86463E
> )
>
> Class-map voice
>
>
>  match ip dscp ef
>
> policy-map llq
>  class voice
>   priority 32
>
> policy-map shape-policy-map
>  class class-default
>   shape average 64000
>   shape adaptive 32000
>   service-policy llq
>
> map-class frame-relay shape-map-class
>  frame-relay fragment 80
>  service-policy output shape-policy-map
>
> interface serial 0/0
>  encapsulation frame-relay
>
> interface serial 0/0.1 point-to-point
>  ip address 192.168.1.1 255.255.255.0
>  frame-relay interface-dlci 100
>   class shape-map-class
>
>
>
> interface serial 0/0.2 point-to-point
>
>
>  ip address 192.168.2.1 255.255.255.0
>  frame-relay interface-dlci 200
>
> interface serial 0/0.3 point-to-point
>
>
>  ip address 192.168.3.1 255.255.255.0
>  frame-relay interface-dlci 300
>
>
> Regards,
> --Somphol
>
>
>
___
For more information regarding industry leading CCIE Lab training, please visit 
www.ipexpert.com

Are you a CCNP or CCIE and looking for a job? Check out 
www.PlatinumPlacement.com

[OSL | CCIE_Voice] Per VC Frame Relay Fragmentation

2013-08-06 Thread Somphol Boonjing
Hi,

Can anyone help confirm my understanding on this topic?

My observation is that Per VC fragmentation, while it can be configured as
when in the example below, is not very useful if not configured for all of
the existing PVC that shared the same physical interface, isn't it?

With the example below, only one of the VC (DLCI 100) is configured for
fragmentation while the rest of the VCs (DLCI 200 & DCLI 300) that shared
the same physical interface are not, then potentially outgoing fragmented
frames from DLCI 100 could be waiting in queue while a fragmented large
data frames from DLCI 200/DLCI 300 is being sent out.

Am I correct?


(REF:
http://www.cisco.com/en/US/docs/ios-xml/ios/wan_frly/configuration/12-4t/wan-mqc-fr-tfshp.html#GUID-BAC1F514-EBD4-48FF-87AB-41F2BF86463E
)

Class-map voice


 match ip dscp ef

policy-map llq
 class voice
  priority 32

policy-map shape-policy-map
 class class-default
  shape average 64000
  shape adaptive 32000
  service-policy llq

map-class frame-relay shape-map-class
 frame-relay fragment 80
 service-policy output shape-policy-map

interface serial 0/0
 encapsulation frame-relay

interface serial 0/0.1 point-to-point
 ip address 192.168.1.1 255.255.255.0
 frame-relay interface-dlci 100
  class shape-map-class


interface serial 0/0.2 point-to-point


 ip address 192.168.2.1 255.255.255.0
 frame-relay interface-dlci 200

interface serial 0/0.3 point-to-point


 ip address 192.168.3.1 255.255.255.0
 frame-relay interface-dlci 300


Regards,
--Somphol
___
For more information regarding industry leading CCIE Lab training, please visit 
www.ipexpert.com

Are you a CCNP or CCIE and looking for a job? Check out 
www.PlatinumPlacement.com