Re: [discuss] find a better name for KameletBinding

2021-08-16 Thread Otavio Rodolfo Piske
Hello,

I'm wondering if the term "slip" in the sense of "to move or proceed
smoothly and readily" [1], which is a synonym for "binding", could
represent the intentions and features in an adequate manner. So, maybe
something along the lines of  "KameletSlip" or "Slip", maybe?

One downside of this term is that there may be a potential confusion and
ambiguity with the "Routing Slip" pattern.

1. https://www.merriam-webster.com/thesaurus/slip

On Mon, Aug 16, 2021 at 10:27 AM Luca Burgazzoli 
wrote:

> Hello,
>
> When the KameletBinding concept was introduced in camel-k, if was meant to
> bind two Kamelets and nothing more, but over time we have added more
> capabilities, like:
>
> - support for processing steps to transform exchanges/messages
> - support to address/source from different systems so the source/sink does
> not need be a kamelet anymore
>
> So I think the term KameletBinding is not more appropriate and to reduce
> confusion, we should try to find a better name.
>
> On top of my mind, I'd see the following names as a possible replacement:
> - Binding so leave Kamelet out of the game as Kamelets are one of the
> option but not the exclusive on
> - Connector as in essence, a KameletBinding describe how to connect A to B
>
> Any opinion ?
>
> ---
> Luca Burgazzoli
>


-- 
Otavio R. Piske
http://orpiske.net


Re: [discuss] find a better name for KameletBinding

2021-08-16 Thread Zoran Regvart
Hi Luca, Cameleers,
naming in IT... from the top of my head

Pipe
Processor
Conduit
Channel
Funnel
Queue
Glue
Caravan or Karavan I guess :)

None of these are particularly excellent, though we should pick a name
that describes the best but also doesn't increase the ambiguity or
cause confusion for end users. E.g. Channel is a particularly bad name
as it's being used in Knative...

zoran

On Mon, Aug 16, 2021 at 10:27 AM Luca Burgazzoli  wrote:
>
> Hello,
>
> When the KameletBinding concept was introduced in camel-k, if was meant to
> bind two Kamelets and nothing more, but over time we have added more
> capabilities, like:
>
> - support for processing steps to transform exchanges/messages
> - support to address/source from different systems so the source/sink does
> not need be a kamelet anymore
>
> So I think the term KameletBinding is not more appropriate and to reduce
> confusion, we should try to find a better name.
>
> On top of my mind, I'd see the following names as a possible replacement:
> - Binding so leave Kamelet out of the game as Kamelets are one of the
> option but not the exclusive on
> - Connector as in essence, a KameletBinding describe how to connect A to B
>
> Any opinion ?
>
> ---
> Luca Burgazzoli



-- 
Zoran Regvart


Re: [discuss] find a better name for KameletBinding

2021-08-16 Thread Andrea Cosentino
Maybe KameletPipe?

Il lun 16 ago 2021, 12:29 Zoran Regvart  ha scritto:

> Hi Luca, Cameleers,
> naming in IT... from the top of my head
>
> Pipe
> Processor
> Conduit
> Channel
> Funnel
> Queue
> Glue
> Caravan or Karavan I guess :)
>
> None of these are particularly excellent, though we should pick a name
> that describes the best but also doesn't increase the ambiguity or
> cause confusion for end users. E.g. Channel is a particularly bad name
> as it's being used in Knative...
>
> zoran
>
> On Mon, Aug 16, 2021 at 10:27 AM Luca Burgazzoli 
> wrote:
> >
> > Hello,
> >
> > When the KameletBinding concept was introduced in camel-k, if was meant
> to
> > bind two Kamelets and nothing more, but over time we have added more
> > capabilities, like:
> >
> > - support for processing steps to transform exchanges/messages
> > - support to address/source from different systems so the source/sink
> does
> > not need be a kamelet anymore
> >
> > So I think the term KameletBinding is not more appropriate and to reduce
> > confusion, we should try to find a better name.
> >
> > On top of my mind, I'd see the following names as a possible replacement:
> > - Binding so leave Kamelet out of the game as Kamelets are one of the
> > option but not the exclusive on
> > - Connector as in essence, a KameletBinding describe how to connect A to
> B
> >
> > Any opinion ?
> >
> > ---
> > Luca Burgazzoli
>
>
>
> --
> Zoran Regvart
>


Re: [discuss] find a better name for KameletBinding

2021-08-16 Thread Antonin Stefanutti
Hi Luca, all,

+1 for Binding.

Users in the Kubernetes ecosystem may already be familiar with the term,
as it seems it's the choice made by projects like Knative and Service Binding,
to convey the general concept of "integrating" in their respective domain.

I find projecting that concept into the integration domain to be a good fit, 
which
Would materialises in Kubernetes as 
bindings.camel.apache.org resources.

On 16 Aug 2021, at 10:27, Luca Burgazzoli 
mailto:lburgazz...@gmail.com>> wrote:

Hello,

When the KameletBinding concept was introduced in camel-k, if was meant to
bind two Kamelets and nothing more, but over time we have added more
capabilities, like:

- support for processing steps to transform exchanges/messages
- support to address/source from different systems so the source/sink does
not need be a kamelet anymore

So I think the term KameletBinding is not more appropriate and to reduce
confusion, we should try to find a better name.

On top of my mind, I'd see the following names as a possible replacement:
- Binding so leave Kamelet out of the game as Kamelets are one of the
option but not the exclusive on
- Connector as in essence, a KameletBinding describe how to connect A to B

Any opinion ?

---
Luca Burgazzoli



Re: [discuss] find a better name for KameletBinding

2021-08-20 Thread John Poth
+1 for Binding

Dropping the Kamelet part makes it clearer that you can bind more
than just Kamelets.

Keeping it as "Binding" gives Kubernetes users a pretty good idea of what
it's going to do without reading the documentation.

On Mon, Aug 16, 2021 at 2:04 PM Antonin Stefanutti
 wrote:

> Hi Luca, all,
>
> +1 for Binding.
>
> Users in the Kubernetes ecosystem may already be familiar with the term,
> as it seems it's the choice made by projects like Knative and Service
> Binding,
> to convey the general concept of "integrating" in their respective domain.
>
> I find projecting that concept into the integration domain to be a good
> fit, which
> Would materialises in Kubernetes as bindings.camel.apache.org<
> http://bindings.camel.apache.org> resources.
>
> On 16 Aug 2021, at 10:27, Luca Burgazzoli  lburgazz...@gmail.com>> wrote:
>
> Hello,
>
> When the KameletBinding concept was introduced in camel-k, if was meant to
> bind two Kamelets and nothing more, but over time we have added more
> capabilities, like:
>
> - support for processing steps to transform exchanges/messages
> - support to address/source from different systems so the source/sink does
> not need be a kamelet anymore
>
> So I think the term KameletBinding is not more appropriate and to reduce
> confusion, we should try to find a better name.
>
> On top of my mind, I'd see the following names as a possible replacement:
> - Binding so leave Kamelet out of the game as Kamelets are one of the
> option but not the exclusive on
> - Connector as in essence, a KameletBinding describe how to connect A to B
>
> Any opinion ?
>
> ---
> Luca Burgazzoli
>
>


Re: [discuss] find a better name for KameletBinding

2021-08-20 Thread Claus Ibsen
Hi

Yeah one of the hardest problem is naming, and after that renaming as
a lot of old stuff "expects" the old name.

I am also leading to Binding, as we have other concepts in Camel K
that are neutral named (no Camel or product in the name) like
Integration, IntegrationKit.
And they are all in the same namespace, so there are no clash on kubernetes.

+1 for Binding



On Fri, Aug 20, 2021 at 10:59 AM John Poth  wrote:
>
> +1 for Binding
>
> Dropping the Kamelet part makes it clearer that you can bind more
> than just Kamelets.
>
> Keeping it as "Binding" gives Kubernetes users a pretty good idea of what
> it's going to do without reading the documentation.
>
> On Mon, Aug 16, 2021 at 2:04 PM Antonin Stefanutti
>  wrote:
>
> > Hi Luca, all,
> >
> > +1 for Binding.
> >
> > Users in the Kubernetes ecosystem may already be familiar with the term,
> > as it seems it's the choice made by projects like Knative and Service
> > Binding,
> > to convey the general concept of "integrating" in their respective domain.
> >
> > I find projecting that concept into the integration domain to be a good
> > fit, which
> > Would materialises in Kubernetes as bindings.camel.apache.org<
> > http://bindings.camel.apache.org> resources.
> >
> > On 16 Aug 2021, at 10:27, Luca Burgazzoli  > lburgazz...@gmail.com>> wrote:
> >
> > Hello,
> >
> > When the KameletBinding concept was introduced in camel-k, if was meant to
> > bind two Kamelets and nothing more, but over time we have added more
> > capabilities, like:
> >
> > - support for processing steps to transform exchanges/messages
> > - support to address/source from different systems so the source/sink does
> > not need be a kamelet anymore
> >
> > So I think the term KameletBinding is not more appropriate and to reduce
> > confusion, we should try to find a better name.
> >
> > On top of my mind, I'd see the following names as a possible replacement:
> > - Binding so leave Kamelet out of the game as Kamelets are one of the
> > option but not the exclusive on
> > - Connector as in essence, a KameletBinding describe how to connect A to B
> >
> > Any opinion ?
> >
> > ---
> > Luca Burgazzoli
> >
> >



-- 
Claus Ibsen
-
http://davsclaus.com @davsclaus
Camel in Action 2: https://www.manning.com/ibsen2


Re: [discuss] find a better name for KameletBinding

2021-08-23 Thread Tadayoshi Sato
"Binding" sounds good to me, too.

On Fri, Aug 20, 2021 at 7:07 PM Claus Ibsen  wrote:

> Hi
>
> Yeah one of the hardest problem is naming, and after that renaming as
> a lot of old stuff "expects" the old name.
>
> I am also leading to Binding, as we have other concepts in Camel K
> that are neutral named (no Camel or product in the name) like
> Integration, IntegrationKit.
> And they are all in the same namespace, so there are no clash on
> kubernetes.
>
> +1 for Binding
>
>
>
> On Fri, Aug 20, 2021 at 10:59 AM John Poth  wrote:
> >
> > +1 for Binding
> >
> > Dropping the Kamelet part makes it clearer that you can bind more
> > than just Kamelets.
> >
> > Keeping it as "Binding" gives Kubernetes users a pretty good idea of what
> > it's going to do without reading the documentation.
> >
> > On Mon, Aug 16, 2021 at 2:04 PM Antonin Stefanutti
> >  wrote:
> >
> > > Hi Luca, all,
> > >
> > > +1 for Binding.
> > >
> > > Users in the Kubernetes ecosystem may already be familiar with the
> term,
> > > as it seems it's the choice made by projects like Knative and Service
> > > Binding,
> > > to convey the general concept of "integrating" in their respective
> domain.
> > >
> > > I find projecting that concept into the integration domain to be a good
> > > fit, which
> > > Would materialises in Kubernetes as bindings.camel.apache.org<
> > > http://bindings.camel.apache.org> resources.
> > >
> > > On 16 Aug 2021, at 10:27, Luca Burgazzoli   > > lburgazz...@gmail.com>> wrote:
> > >
> > > Hello,
> > >
> > > When the KameletBinding concept was introduced in camel-k, if was
> meant to
> > > bind two Kamelets and nothing more, but over time we have added more
> > > capabilities, like:
> > >
> > > - support for processing steps to transform exchanges/messages
> > > - support to address/source from different systems so the source/sink
> does
> > > not need be a kamelet anymore
> > >
> > > So I think the term KameletBinding is not more appropriate and to
> reduce
> > > confusion, we should try to find a better name.
> > >
> > > On top of my mind, I'd see the following names as a possible
> replacement:
> > > - Binding so leave Kamelet out of the game as Kamelets are one of the
> > > option but not the exclusive on
> > > - Connector as in essence, a KameletBinding describe how to connect A
> to B
> > >
> > > Any opinion ?
> > >
> > > ---
> > > Luca Burgazzoli
> > >
> > >
>
>
>
> --
> Claus Ibsen
> -
> http://davsclaus.com @davsclaus
> Camel in Action 2: https://www.manning.com/ibsen2
>


-- 
Tadayoshi Sato


Re: [discuss] find a better name for KameletBinding

2021-08-27 Thread Marat Gubaidullin
Hi!
It looks like we already have "Bindings" but it was deprecated

https://docs.openshift.com/container-platform/3.7/rest_api/api/v1.Binding.html

On Fri, Aug 20, 2021 at 6:18 AM Claus Ibsen  wrote:

> Hi
>
> Yeah one of the hardest problem is naming, and after that renaming as
> a lot of old stuff "expects" the old name.
>
> I am also leading to Binding, as we have other concepts in Camel K
> that are neutral named (no Camel or product in the name) like
> Integration, IntegrationKit.
> And they are all in the same namespace, so there are no clash on
> kubernetes.
>
> +1 for Binding
>
>
>
> On Fri, Aug 20, 2021 at 10:59 AM John Poth  wrote:
> >
> > +1 for Binding
> >
> > Dropping the Kamelet part makes it clearer that you can bind more
> > than just Kamelets.
> >
> > Keeping it as "Binding" gives Kubernetes users a pretty good idea of what
> > it's going to do without reading the documentation.
> >
> > On Mon, Aug 16, 2021 at 2:04 PM Antonin Stefanutti
> >  wrote:
> >
> > > Hi Luca, all,
> > >
> > > +1 for Binding.
> > >
> > > Users in the Kubernetes ecosystem may already be familiar with the
> term,
> > > as it seems it's the choice made by projects like Knative and Service
> > > Binding,
> > > to convey the general concept of "integrating" in their respective
> domain.
> > >
> > > I find projecting that concept into the integration domain to be a good
> > > fit, which
> > > Would materialises in Kubernetes as bindings.camel.apache.org<
> > > http://bindings.camel.apache.org> resources.
> > >
> > > On 16 Aug 2021, at 10:27, Luca Burgazzoli   > > lburgazz...@gmail.com>> wrote:
> > >
> > > Hello,
> > >
> > > When the KameletBinding concept was introduced in camel-k, if was
> meant to
> > > bind two Kamelets and nothing more, but over time we have added more
> > > capabilities, like:
> > >
> > > - support for processing steps to transform exchanges/messages
> > > - support to address/source from different systems so the source/sink
> does
> > > not need be a kamelet anymore
> > >
> > > So I think the term KameletBinding is not more appropriate and to
> reduce
> > > confusion, we should try to find a better name.
> > >
> > > On top of my mind, I'd see the following names as a possible
> replacement:
> > > - Binding so leave Kamelet out of the game as Kamelets are one of the
> > > option but not the exclusive on
> > > - Connector as in essence, a KameletBinding describe how to connect A
> to B
> > >
> > > Any opinion ?
> > >
> > > ---
> > > Luca Burgazzoli
> > >
> > >
>
>
>
> --
> Claus Ibsen
> -
> http://davsclaus.com @davsclaus
> Camel in Action 2: https://www.manning.com/ibsen2
>


Re: [discuss] find a better name for KameletBinding

2021-09-09 Thread Luca Burgazzoli
Opened an issue on camel-k to rename KameletBinding to Binding:
https://github.com/apache/camel-k/issues/2625

---
Luca Burgazzoli


On Fri, Aug 27, 2021 at 10:14 PM Marat Gubaidullin <
marat.gubaidul...@gmail.com> wrote:

> Hi!
> It looks like we already have "Bindings" but it was deprecated
>
>
> https://docs.openshift.com/container-platform/3.7/rest_api/api/v1.Binding.html
>
> On Fri, Aug 20, 2021 at 6:18 AM Claus Ibsen  wrote:
>
> > Hi
> >
> > Yeah one of the hardest problem is naming, and after that renaming as
> > a lot of old stuff "expects" the old name.
> >
> > I am also leading to Binding, as we have other concepts in Camel K
> > that are neutral named (no Camel or product in the name) like
> > Integration, IntegrationKit.
> > And they are all in the same namespace, so there are no clash on
> > kubernetes.
> >
> > +1 for Binding
> >
> >
> >
> > On Fri, Aug 20, 2021 at 10:59 AM John Poth  wrote:
> > >
> > > +1 for Binding
> > >
> > > Dropping the Kamelet part makes it clearer that you can bind more
> > > than just Kamelets.
> > >
> > > Keeping it as "Binding" gives Kubernetes users a pretty good idea of
> what
> > > it's going to do without reading the documentation.
> > >
> > > On Mon, Aug 16, 2021 at 2:04 PM Antonin Stefanutti
> > >  wrote:
> > >
> > > > Hi Luca, all,
> > > >
> > > > +1 for Binding.
> > > >
> > > > Users in the Kubernetes ecosystem may already be familiar with the
> > term,
> > > > as it seems it's the choice made by projects like Knative and Service
> > > > Binding,
> > > > to convey the general concept of "integrating" in their respective
> > domain.
> > > >
> > > > I find projecting that concept into the integration domain to be a
> good
> > > > fit, which
> > > > Would materialises in Kubernetes as bindings.camel.apache.org<
> > > > http://bindings.camel.apache.org> resources.
> > > >
> > > > On 16 Aug 2021, at 10:27, Luca Burgazzoli  >  > > > lburgazz...@gmail.com>> wrote:
> > > >
> > > > Hello,
> > > >
> > > > When the KameletBinding concept was introduced in camel-k, if was
> > meant to
> > > > bind two Kamelets and nothing more, but over time we have added more
> > > > capabilities, like:
> > > >
> > > > - support for processing steps to transform exchanges/messages
> > > > - support to address/source from different systems so the source/sink
> > does
> > > > not need be a kamelet anymore
> > > >
> > > > So I think the term KameletBinding is not more appropriate and to
> > reduce
> > > > confusion, we should try to find a better name.
> > > >
> > > > On top of my mind, I'd see the following names as a possible
> > replacement:
> > > > - Binding so leave Kamelet out of the game as Kamelets are one of the
> > > > option but not the exclusive on
> > > > - Connector as in essence, a KameletBinding describe how to connect A
> > to B
> > > >
> > > > Any opinion ?
> > > >
> > > > ---
> > > > Luca Burgazzoli
> > > >
> > > >
> >
> >
> >
> > --
> > Claus Ibsen
> > -
> > http://davsclaus.com @davsclaus
> > Camel in Action 2: https://www.manning.com/ibsen2
> >
>