Re: [Intel-gfx] [PATCH v4 1/2] drm/edid: Name the detailed monitor range flags

2020-03-09 Thread Manasi Navare
On Mon, Mar 09, 2020 at 10:35:52AM +0200, Jani Nikula wrote:
> On Fri, 06 Mar 2020, Manasi Navare  wrote:
> > On Fri, Mar 06, 2020 at 12:30:46PM +0200, Jani Nikula wrote:
> >> On Thu, 05 Mar 2020, Manasi Navare  wrote:
> >> > This patch adds defines for the detailed monitor
> >> > range flags as per the EDID specification.
> >> >
> >> > Suggested-by: Ville Syrjälä 
> >> > Cc: Ville Syrjälä 
> >> > Cc: Harry Wentland 
> >> > Cc: Clinton A Taylor 
> >> > Cc: Kazlauskas Nicholas 
> >> > Signed-off-by: Manasi Navare 
> >> > ---
> >> >  include/drm/drm_edid.h | 5 +
> >> >  1 file changed, 5 insertions(+)
> >> >
> >> > diff --git a/include/drm/drm_edid.h b/include/drm/drm_edid.h
> >> > index f0b03d401c27..f89c97623845 100644
> >> > --- a/include/drm/drm_edid.h
> >> > +++ b/include/drm/drm_edid.h
> >> > @@ -91,6 +91,11 @@ struct detailed_data_string {
> >> >  u8 str[13];
> >> >  } __attribute__((packed));
> >> >  
> >> > +#define EDID_DEFAULT_GTF_SUPPORT_FLAG   0x00
> >> > +#define EDID_RANGE_LIMITS_ONLY_FLAG 0x01
> >> > +#define EDID_SECONDARY_GTF_SUPPORT_FLAG 0x02
> >> > +#define EDID_CVT_SUPPORT_FLAG   0x04
> >> 
> >> Bikeshed for consideration:
> >> 
> >> drm_edid.h has some macros with DRM_EDID_ prefix, some with EDID_
> >> prefix, and then some with no prefix at all really. Should we start
> >> consolidating on something when we add more?
> >>
> >
> > Yes Jani I did notice the same thing and didnt know which convention
> > to continue to follow but I noticed that majority of the defines were
> > just EDID_ so just used that for these new defines.
> 
> Ah, look again, DRM_EDID_ trumps EDID_ 51 to 15.
> 
> > Is there a particular way you wish to consolidate this and use a specific
> > convention for #defines?
> >
> > I can atleast change these new defines based on a preferred convention and 
> > then
> > separate patches to change the rest in .h and corresponding usages in .c 
> > files.
> 
> I'd suggest DRM_EDID_ for new ones, perhaps eventually rename old ones.

Okay cool, I will rename this to be DRM_EDID_ and then work on renaming others 
later
Thanks for pointing this out.

Regards
Manasi

> 
> BR,
> Jani.
> 
> 
> >
> > Regards
> > Manasi
> >  
> >> BR,
> >> Jani.
> >> 
> >> 
> >> > +
> >> >  struct detailed_data_monitor_range {
> >> >  u8 min_vfreq;
> >> >  u8 max_vfreq;
> >> 
> >> -- 
> >> Jani Nikula, Intel Open Source Graphics Center
> 
> -- 
> Jani Nikula, Intel Open Source Graphics Center
___
dri-devel mailing list
dri-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/dri-devel


Re: [Intel-gfx] [PATCH v4 1/2] drm/edid: Name the detailed monitor range flags

2020-03-09 Thread Jani Nikula
On Fri, 06 Mar 2020, Manasi Navare  wrote:
> On Fri, Mar 06, 2020 at 12:30:46PM +0200, Jani Nikula wrote:
>> On Thu, 05 Mar 2020, Manasi Navare  wrote:
>> > This patch adds defines for the detailed monitor
>> > range flags as per the EDID specification.
>> >
>> > Suggested-by: Ville Syrjälä 
>> > Cc: Ville Syrjälä 
>> > Cc: Harry Wentland 
>> > Cc: Clinton A Taylor 
>> > Cc: Kazlauskas Nicholas 
>> > Signed-off-by: Manasi Navare 
>> > ---
>> >  include/drm/drm_edid.h | 5 +
>> >  1 file changed, 5 insertions(+)
>> >
>> > diff --git a/include/drm/drm_edid.h b/include/drm/drm_edid.h
>> > index f0b03d401c27..f89c97623845 100644
>> > --- a/include/drm/drm_edid.h
>> > +++ b/include/drm/drm_edid.h
>> > @@ -91,6 +91,11 @@ struct detailed_data_string {
>> >u8 str[13];
>> >  } __attribute__((packed));
>> >  
>> > +#define EDID_DEFAULT_GTF_SUPPORT_FLAG   0x00
>> > +#define EDID_RANGE_LIMITS_ONLY_FLAG 0x01
>> > +#define EDID_SECONDARY_GTF_SUPPORT_FLAG 0x02
>> > +#define EDID_CVT_SUPPORT_FLAG   0x04
>> 
>> Bikeshed for consideration:
>> 
>> drm_edid.h has some macros with DRM_EDID_ prefix, some with EDID_
>> prefix, and then some with no prefix at all really. Should we start
>> consolidating on something when we add more?
>>
>
> Yes Jani I did notice the same thing and didnt know which convention
> to continue to follow but I noticed that majority of the defines were
> just EDID_ so just used that for these new defines.

Ah, look again, DRM_EDID_ trumps EDID_ 51 to 15.

> Is there a particular way you wish to consolidate this and use a specific
> convention for #defines?
>
> I can atleast change these new defines based on a preferred convention and 
> then
> separate patches to change the rest in .h and corresponding usages in .c 
> files.

I'd suggest DRM_EDID_ for new ones, perhaps eventually rename old ones.

BR,
Jani.


>
> Regards
> Manasi
>  
>> BR,
>> Jani.
>> 
>> 
>> > +
>> >  struct detailed_data_monitor_range {
>> >u8 min_vfreq;
>> >u8 max_vfreq;
>> 
>> -- 
>> Jani Nikula, Intel Open Source Graphics Center

-- 
Jani Nikula, Intel Open Source Graphics Center
___
dri-devel mailing list
dri-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/dri-devel


Re: [Intel-gfx] [PATCH v4 1/2] drm/edid: Name the detailed monitor range flags

2020-03-06 Thread Manasi Navare
On Fri, Mar 06, 2020 at 12:30:46PM +0200, Jani Nikula wrote:
> On Thu, 05 Mar 2020, Manasi Navare  wrote:
> > This patch adds defines for the detailed monitor
> > range flags as per the EDID specification.
> >
> > Suggested-by: Ville Syrjälä 
> > Cc: Ville Syrjälä 
> > Cc: Harry Wentland 
> > Cc: Clinton A Taylor 
> > Cc: Kazlauskas Nicholas 
> > Signed-off-by: Manasi Navare 
> > ---
> >  include/drm/drm_edid.h | 5 +
> >  1 file changed, 5 insertions(+)
> >
> > diff --git a/include/drm/drm_edid.h b/include/drm/drm_edid.h
> > index f0b03d401c27..f89c97623845 100644
> > --- a/include/drm/drm_edid.h
> > +++ b/include/drm/drm_edid.h
> > @@ -91,6 +91,11 @@ struct detailed_data_string {
> > u8 str[13];
> >  } __attribute__((packed));
> >  
> > +#define EDID_DEFAULT_GTF_SUPPORT_FLAG   0x00
> > +#define EDID_RANGE_LIMITS_ONLY_FLAG 0x01
> > +#define EDID_SECONDARY_GTF_SUPPORT_FLAG 0x02
> > +#define EDID_CVT_SUPPORT_FLAG   0x04
> 
> Bikeshed for consideration:
> 
> drm_edid.h has some macros with DRM_EDID_ prefix, some with EDID_
> prefix, and then some with no prefix at all really. Should we start
> consolidating on something when we add more?
>

Yes Jani I did notice the same thing and didnt know which convention
to continue to follow but I noticed that majority of the defines were
just EDID_ so just used that for these new defines.

Is there a particular way you wish to consolidate this and use a specific
convention for #defines?

I can atleast change these new defines based on a preferred convention and then
separate patches to change the rest in .h and corresponding usages in .c files.

Regards
Manasi
 
> BR,
> Jani.
> 
> 
> > +
> >  struct detailed_data_monitor_range {
> > u8 min_vfreq;
> > u8 max_vfreq;
> 
> -- 
> Jani Nikula, Intel Open Source Graphics Center
___
dri-devel mailing list
dri-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/dri-devel


Re: [Intel-gfx] [PATCH v4 1/2] drm/edid: Name the detailed monitor range flags

2020-03-06 Thread Jani Nikula
On Thu, 05 Mar 2020, Manasi Navare  wrote:
> This patch adds defines for the detailed monitor
> range flags as per the EDID specification.
>
> Suggested-by: Ville Syrjälä 
> Cc: Ville Syrjälä 
> Cc: Harry Wentland 
> Cc: Clinton A Taylor 
> Cc: Kazlauskas Nicholas 
> Signed-off-by: Manasi Navare 
> ---
>  include/drm/drm_edid.h | 5 +
>  1 file changed, 5 insertions(+)
>
> diff --git a/include/drm/drm_edid.h b/include/drm/drm_edid.h
> index f0b03d401c27..f89c97623845 100644
> --- a/include/drm/drm_edid.h
> +++ b/include/drm/drm_edid.h
> @@ -91,6 +91,11 @@ struct detailed_data_string {
>   u8 str[13];
>  } __attribute__((packed));
>  
> +#define EDID_DEFAULT_GTF_SUPPORT_FLAG   0x00
> +#define EDID_RANGE_LIMITS_ONLY_FLAG 0x01
> +#define EDID_SECONDARY_GTF_SUPPORT_FLAG 0x02
> +#define EDID_CVT_SUPPORT_FLAG   0x04

Bikeshed for consideration:

drm_edid.h has some macros with DRM_EDID_ prefix, some with EDID_
prefix, and then some with no prefix at all really. Should we start
consolidating on something when we add more?

BR,
Jani.


> +
>  struct detailed_data_monitor_range {
>   u8 min_vfreq;
>   u8 max_vfreq;

-- 
Jani Nikula, Intel Open Source Graphics Center
___
dri-devel mailing list
dri-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/dri-devel