Re: [PATCH v4] staging: bcm2835-audio: Release resources on module_exit()

2018-03-25 Thread Kirill Marinushkin
On 03/25/18 15:03, Andy Shevchenko wrote:
> On Sun, Mar 25, 2018 at 1:44 PM, Kirill Marinushkin
>  wrote:
>> On 03/25/18 12:33, Andy Shevchenko wrote:
>>> On Fri, Mar 23, 2018 at 9:22 PM, Kirill Marinushkin
>>>  wrote:
 On 03/23/18 17:23, Andy Shevchenko wrote:
> After addressing above, FWIW,
>
> Reviewed-by: Andy Shevchenko 
>>> Seems you missed my tag in new version.
>>> When someone gives you a tag and you are going to send a new version
>>> (w/o drastic changes), it's your responsibility to append it
>>>
>>> I will send a new mail with it, so, this time no need to resend. Just
>>> keep it for the future contributions.
>>>
>> What is a "tag"?
>> I added in-reply-to this email, I added you as CC.
>> Isn't it enough to keep track of the versioning within a mailing list?
>>
>> Could you please clarify: what "tag" should I usually attach in addition?
> Section 13) in Submitting Patches [1] explains that.
>
> [1]: 
> https://elixir.bootlin.com/linux/v4.16-rc6/source/Documentation/process/submitting-patches.rst
>

Thanks!
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel


Re: [PATCH v4] staging: bcm2835-audio: Release resources on module_exit()

2018-03-25 Thread Andy Shevchenko
On Sun, Mar 25, 2018 at 1:44 PM, Kirill Marinushkin
 wrote:
> On 03/25/18 12:33, Andy Shevchenko wrote:
>> On Fri, Mar 23, 2018 at 9:22 PM, Kirill Marinushkin
>>  wrote:
>>> On 03/23/18 17:23, Andy Shevchenko wrote:
 After addressing above, FWIW,

 Reviewed-by: Andy Shevchenko 
>> Seems you missed my tag in new version.
>> When someone gives you a tag and you are going to send a new version
>> (w/o drastic changes), it's your responsibility to append it
>>
>> I will send a new mail with it, so, this time no need to resend. Just
>> keep it for the future contributions.
>>
>
> What is a "tag"?
> I added in-reply-to this email, I added you as CC.
> Isn't it enough to keep track of the versioning within a mailing list?
>
> Could you please clarify: what "tag" should I usually attach in addition?

Section 13) in Submitting Patches [1] explains that.

[1]: 
https://elixir.bootlin.com/linux/v4.16-rc6/source/Documentation/process/submitting-patches.rst

-- 
With Best Regards,
Andy Shevchenko
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel


Re: [PATCH v4] staging: bcm2835-audio: Release resources on module_exit()

2018-03-25 Thread Kirill Marinushkin
On 03/25/18 12:33, Andy Shevchenko wrote:
> On Fri, Mar 23, 2018 at 9:22 PM, Kirill Marinushkin
>  wrote:
>> On 03/23/18 17:23, Andy Shevchenko wrote:
>>> After addressing above, FWIW,
>>>
>>> Reviewed-by: Andy Shevchenko 
> Seems you missed my tag in new version.
> When someone gives you a tag and you are going to send a new version
> (w/o drastic changes), it's your responsibility to append it
>
> I will send a new mail with it, so, this time no need to resend. Just
> keep it for the future contributions.
>

What is a "tag"?
I added in-reply-to this email, I added you as CC.
Isn't it enough to keep track of the versioning within a mailing list?

Could you please clarify: what "tag" should I usually attach in addition?

Best Regards,
Kirill
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel


Re: [PATCH v4] staging: bcm2835-audio: Release resources on module_exit()

2018-03-25 Thread Andy Shevchenko
On Fri, Mar 23, 2018 at 9:22 PM, Kirill Marinushkin
 wrote:
> On 03/23/18 17:23, Andy Shevchenko wrote:

>> After addressing above, FWIW,
>>
>> Reviewed-by: Andy Shevchenko 

Seems you missed my tag in new version.
When someone gives you a tag and you are going to send a new version
(w/o drastic changes), it's your responsibility to append it

I will send a new mail with it, so, this time no need to resend. Just
keep it for the future contributions.

-- 
With Best Regards,
Andy Shevchenko
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel


Re: [PATCH v4] staging: bcm2835-audio: Release resources on module_exit()

2018-03-23 Thread Kirill Marinushkin
On 03/23/18 17:23, Andy Shevchenko wrote:
> On Thu, Mar 22, 2018 at 11:37 PM, Kirill Marinushkin
>  wrote:
>
>
>> +static void snd_devm_release(struct device *dev)
>> +{
>> +   struct bcm2835_chip *chip = dev_get_drvdata(dev);
>> +
>> +   kfree(chip);
>> +}
>> +   device->release = snd_devm_release;
> This is not devm function, so, it would be rather called
> snd_bcm2835_release().

Ah, you mean "devm" in the names. Now I got it.
Agree, I will rename it to "snd_bcm2835_release()"

>
>>  static struct snd_card *snd_devm_card_new(struct device *dev)
>>  {
>> struct snd_card *card;
>> int ret;
>>
>> ret = snd_card_new(dev, -1, NULL, THIS_MODULE, 0, );
>> +   if (ret)
>> return ERR_PTR(ret);
>>
>> return card;
>>  }
> Same here. You removed anything related to devm here, so, please make
> function name consistent.

Good, I will rename it to "snd_bcm2835_card_new()"

> After addressing above, FWIW,
>
> Reviewed-by: Andy Shevchenko 
>

___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel


Re: [PATCH v4] staging: bcm2835-audio: Release resources on module_exit()

2018-03-23 Thread Andy Shevchenko
On Thu, Mar 22, 2018 at 11:37 PM, Kirill Marinushkin
 wrote:


> +static void snd_devm_release(struct device *dev)
> +{
> +   struct bcm2835_chip *chip = dev_get_drvdata(dev);
> +
> +   kfree(chip);
> +}

> +   device->release = snd_devm_release;

This is not devm function, so, it would be rather called
snd_bcm2835_release().

>  static struct snd_card *snd_devm_card_new(struct device *dev)
>  {
> struct snd_card *card;
> int ret;
>
> ret = snd_card_new(dev, -1, NULL, THIS_MODULE, 0, );
> +   if (ret)
> return ERR_PTR(ret);
>
> return card;
>  }

Same here. You removed anything related to devm here, so, please make
function name consistent.

After addressing above, FWIW,

Reviewed-by: Andy Shevchenko 

-- 
With Best Regards,
Andy Shevchenko
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel