[j-nsp] IGMP problem

2013-09-10 Thread Robert Hass
Hi
I would like to setup static IGMP joins between Cisco and Juniper.
But it's not working. Juniper is not sending IGMP Joins.
Same configuration Cisco + Cisco working without issues. Any clues ?

Interface configuration for Juniper at Cisco side:

interface GigabitEthernet1/1/1
 description Juniper
 no switchport
 ip address 10.10.10.21 255.255.255.252
 ip pim passive
!

Here is output of IGMP membership - none :(

cisco#sh ip igmp membership | include GigabitEthernet1/1/1
cisco#

Here is JunOS configuration:

interfaces {
ge-0/0/0 {
unit 0 {
family inet {
address 10.10.10.22/30;
}
}
}
routing-options {
static {
route 0.0.0.0/0 next-hop 10.10.10.21;
}
}
protocols {
igmp {
interface ge-0/0/0.0 {
version 2;
static {
group 231.0.0.3;
group 231.0.0.4;
}
}
}
pim {
rp {
static {
address 10.10.10.255 {
version 2;
}
}
}
interface ge-0/0/0.0 {
mode sparse;
version 2;
}
join-load-balance;
}
}

Rob
___
juniper-nsp mailing list juniper-nsp@puck.nether.net
https://puck.nether.net/mailman/listinfo/juniper-nsp


Re: [j-nsp] IGMP problem

2013-09-10 Thread Vladislav Vasilev
Hi Robert,

What you have below only adds the interface to the OIL for that group. No IGMP 
joins are generated!

Regards,
Vladislav A. VASILEV


On 10 Sep 2013, at 07:51, Robert Hass wrote:

 Hi
 I would like to setup static IGMP joins between Cisco and Juniper.
 But it's not working. Juniper is not sending IGMP Joins.
 Same configuration Cisco + Cisco working without issues. Any clues ?
 
 Interface configuration for Juniper at Cisco side:
 
 interface GigabitEthernet1/1/1
 description Juniper
 no switchport
 ip address 10.10.10.21 255.255.255.252
 ip pim passive
 !
 
 Here is output of IGMP membership - none :(
 
 cisco#sh ip igmp membership | include GigabitEthernet1/1/1
 cisco#
 
 Here is JunOS configuration:
 
 interfaces {
ge-0/0/0 {
unit 0 {
family inet {
address 10.10.10.22/30;
}
}
}
 routing-options {
static {
route 0.0.0.0/0 next-hop 10.10.10.21;
}
 }
 protocols {
igmp {
interface ge-0/0/0.0 {
version 2;
static {
group 231.0.0.3;
group 231.0.0.4;
}
}
}
pim {
rp {
static {
address 10.10.10.255 {
version 2;
}
}
}
interface ge-0/0/0.0 {
mode sparse;
version 2;
}
join-load-balance;
}
 }
 
 Rob
 ___
 juniper-nsp mailing list juniper-nsp@puck.nether.net
 https://puck.nether.net/mailman/listinfo/juniper-nsp

___
juniper-nsp mailing list juniper-nsp@puck.nether.net
https://puck.nether.net/mailman/listinfo/juniper-nsp


Re: [j-nsp] IGMP problem

2013-09-10 Thread Krasimir Avramski
Hello,
Actually this config generates PIM (*,G) joins upstream to RP.
I'm not aware of static igmp joins(generated) or igmp proxies support in
junos (excluding junosE) - though there is a  feature that translates PIM
to 
IGMP/MLDhttp://www.juniper.net/techpubs/en_US/junos11.4/topics/topic-map/mcast-message-translation.html


Krasi


On 10 September 2013 12:55, Vladislav Vasilev
vladislavavasi...@gmail.comwrote:

 Hi Robert,

 What you have below only adds the interface to the OIL for that group. No
 IGMP joins are generated!

 Regards,
 Vladislav A. VASILEV


 On 10 Sep 2013, at 07:51, Robert Hass wrote:

  Hi
  I would like to setup static IGMP joins between Cisco and Juniper.
  But it's not working. Juniper is not sending IGMP Joins.
  Same configuration Cisco + Cisco working without issues. Any clues ?
 
  Interface configuration for Juniper at Cisco side:
 
  interface GigabitEthernet1/1/1
  description Juniper
  no switchport
  ip address 10.10.10.21 255.255.255.252
  ip pim passive
  !
 
  Here is output of IGMP membership - none :(
 
  cisco#sh ip igmp membership | include GigabitEthernet1/1/1
  cisco#
 
  Here is JunOS configuration:
 
  interfaces {
 ge-0/0/0 {
 unit 0 {
 family inet {
 address 10.10.10.22/30;
 }
 }
 }
  routing-options {
 static {
 route 0.0.0.0/0 next-hop 10.10.10.21;
 }
  }
  protocols {
 igmp {
 interface ge-0/0/0.0 {
 version 2;
 static {
 group 231.0.0.3;
 group 231.0.0.4;
 }
 }
 }
 pim {
 rp {
 static {
 address 10.10.10.255 {
 version 2;
 }
 }
 }
 interface ge-0/0/0.0 {
 mode sparse;
 version 2;
 }
 join-load-balance;
 }
  }
 
  Rob
  ___
  juniper-nsp mailing list juniper-nsp@puck.nether.net
  https://puck.nether.net/mailman/listinfo/juniper-nsp

 ___
 juniper-nsp mailing list juniper-nsp@puck.nether.net
 https://puck.nether.net/mailman/listinfo/juniper-nsp

___
juniper-nsp mailing list juniper-nsp@puck.nether.net
https://puck.nether.net/mailman/listinfo/juniper-nsp


Re: [j-nsp] IGMP problem

2013-09-10 Thread Vladislav Vasilev
Robert,

Just noticed you actually have ip pim passive under the interface...

The ip igmp join-group in Cisco IOS generates IGMP joins (and PIM joins 
upstream), and packets sent to the group address get sent up to the CPU (the 
router would reply back to icmp-echo packets sent to the group address - 
convenient for troubleshooting).

On the other hand, the ip igmp static-group in Cisco IOS generates IGMP joins 
(and PIM joins upstream), but packets sent to the group address do not get sent 
up to the CPU.

As Krasi said, in JunOS, you still have the PIM joins upstream, but no IGMP 
joins are generated.

Regards,
Vladislav A. VASILEV


On 10 Sep 2013, at 11:24, Krasimir Avramski wrote:

 Hello,
 Actually this config generates PIM (*,G) joins upstream to RP.
 I'm not aware of static igmp joins(generated) or igmp proxies support in 
 junos (excluding junosE) - though there is a  feature that translates PIM to 
 IGMP/MLD  
 
 Krasi
 
 
 On 10 September 2013 12:55, Vladislav Vasilev vladislavavasi...@gmail.com 
 wrote:
 Hi Robert,
 
 What you have below only adds the interface to the OIL for that group. No 
 IGMP joins are generated!
 
 Regards,
 Vladislav A. VASILEV
 
 
 On 10 Sep 2013, at 07:51, Robert Hass wrote:
 
  Hi
  I would like to setup static IGMP joins between Cisco and Juniper.
  But it's not working. Juniper is not sending IGMP Joins.
  Same configuration Cisco + Cisco working without issues. Any clues ?
 
  Interface configuration for Juniper at Cisco side:
 
  interface GigabitEthernet1/1/1
  description Juniper
  no switchport
  ip address 10.10.10.21 255.255.255.252
  ip pim passive
  !
 
  Here is output of IGMP membership - none :(
 
  cisco#sh ip igmp membership | include GigabitEthernet1/1/1
  cisco#
 
  Here is JunOS configuration:
 
  interfaces {
 ge-0/0/0 {
 unit 0 {
 family inet {
 address 10.10.10.22/30;
 }
 }
 }
  routing-options {
 static {
 route 0.0.0.0/0 next-hop 10.10.10.21;
 }
  }
  protocols {
 igmp {
 interface ge-0/0/0.0 {
 version 2;
 static {
 group 231.0.0.3;
 group 231.0.0.4;
 }
 }
 }
 pim {
 rp {
 static {
 address 10.10.10.255 {
 version 2;
 }
 }
 }
 interface ge-0/0/0.0 {
 mode sparse;
 version 2;
 }
 join-load-balance;
 }
  }
 
  Rob
  ___
  juniper-nsp mailing list juniper-nsp@puck.nether.net
  https://puck.nether.net/mailman/listinfo/juniper-nsp
 
 ___
 juniper-nsp mailing list juniper-nsp@puck.nether.net
 https://puck.nether.net/mailman/listinfo/juniper-nsp
 

___
juniper-nsp mailing list juniper-nsp@puck.nether.net
https://puck.nether.net/mailman/listinfo/juniper-nsp


Re: [j-nsp] IGMP problem

2013-09-10 Thread Mihai Gabriel
You should enable the sap protocol for the group you want to generate join
messages.


On Tue, Sep 10, 2013 at 2:18 PM, Vladislav Vasilev 
vladislavavasi...@gmail.com wrote:

 Robert,

 Just noticed you actually have ip pim passive under the interface...

 The ip igmp join-group in Cisco IOS generates IGMP joins (and PIM joins
 upstream), and packets sent to the group address get sent up to the CPU
 (the router would reply back to icmp-echo packets sent to the group address
 - convenient for troubleshooting).

 On the other hand, the ip igmp static-group in Cisco IOS generates IGMP
 joins (and PIM joins upstream), but packets sent to the group address do
 not get sent up to the CPU.

 As Krasi said, in JunOS, you still have the PIM joins upstream, but no
 IGMP joins are generated.

 Regards,
 Vladislav A. VASILEV


 On 10 Sep 2013, at 11:24, Krasimir Avramski wrote:

  Hello,
  Actually this config generates PIM (*,G) joins upstream to RP.
  I'm not aware of static igmp joins(generated) or igmp proxies support in
 junos (excluding junosE) - though there is a  feature that translates PIM
 to IGMP/MLD
 
  Krasi
 
 
  On 10 September 2013 12:55, Vladislav Vasilev 
 vladislavavasi...@gmail.com wrote:
  Hi Robert,
 
  What you have below only adds the interface to the OIL for that group.
 No IGMP joins are generated!
 
  Regards,
  Vladislav A. VASILEV
 
 
  On 10 Sep 2013, at 07:51, Robert Hass wrote:
 
   Hi
   I would like to setup static IGMP joins between Cisco and Juniper.
   But it's not working. Juniper is not sending IGMP Joins.
   Same configuration Cisco + Cisco working without issues. Any clues ?
  
   Interface configuration for Juniper at Cisco side:
  
   interface GigabitEthernet1/1/1
   description Juniper
   no switchport
   ip address 10.10.10.21 255.255.255.252
   ip pim passive
   !
  
   Here is output of IGMP membership - none :(
  
   cisco#sh ip igmp membership | include GigabitEthernet1/1/1
   cisco#
  
   Here is JunOS configuration:
  
   interfaces {
  ge-0/0/0 {
  unit 0 {
  family inet {
  address 10.10.10.22/30;
  }
  }
  }
   routing-options {
  static {
  route 0.0.0.0/0 next-hop 10.10.10.21;
  }
   }
   protocols {
  igmp {
  interface ge-0/0/0.0 {
  version 2;
  static {
  group 231.0.0.3;
  group 231.0.0.4;
  }
  }
  }
  pim {
  rp {
  static {
  address 10.10.10.255 {
  version 2;
  }
  }
  }
  interface ge-0/0/0.0 {
  mode sparse;
  version 2;
  }
  join-load-balance;
  }
   }
  
   Rob
   ___
   juniper-nsp mailing list juniper-nsp@puck.nether.net
   https://puck.nether.net/mailman/listinfo/juniper-nsp
 
  ___
  juniper-nsp mailing list juniper-nsp@puck.nether.net
  https://puck.nether.net/mailman/listinfo/juniper-nsp
 

 ___
 juniper-nsp mailing list juniper-nsp@puck.nether.net
 https://puck.nether.net/mailman/listinfo/juniper-nsp

___
juniper-nsp mailing list juniper-nsp@puck.nether.net
https://puck.nether.net/mailman/listinfo/juniper-nsp


Re: [j-nsp] VPLS Multihoming on Junos - FEC confusion

2013-09-10 Thread Darren O'Connor
That's my thought too. However even the 12.3 VPLS configuration guide states 
FEC128 multihoming. But again showing with BGP

Thanks
Darren
http://www.mellowd.co.uk/ccie



Date: Mon, 9 Sep 2013 23:30:08 +0300
Subject: Re: [j-nsp] VPLS Multihoming on Junos - FEC confusion
From: kr...@smartcom.bg
To: darre...@outlook.com
CC: juniper-nsp@puck.nether.net

Hello,
IMHO there is mess with docs/terms. FEC 128 multihoming as described has 
nothing to do with ldp. It's bgp signaling and autodiscovery.
Krasi


On 8 September 2013 22:37, Darren O'Connor darre...@outlook.com wrote:







Hi list.



I'm going over the VPLS multihoming options on Juniper's web site. I'm not 
concerned with LAG and MC-LAG for the moment.



As far as I'm aware, FEC128 is when you are using manual discovery of 
pseudowires (LDP) - FEC129 is when you are using BGP auto-discovery.



Juniper techpub for FEC129 multihoming I don't have a problem with as it shows 
how to multihome with BGP: 
https://www.juniper.net/techpubs/en_US/junos/topics/topic-map/vpls-bgp-multihoming.html




The FEC128 multihome techpub says that you cannot enable LDP signalling, you 
have to use BGP signalling: 
http://www.juniper.net/techpubs/en_US/junos/topics/usage-guidelines/vpns-configuring-vpls-multihoming.html






I know that you can use LDP for manual discovery and LDP will then signal VC 
labels. You can also use BGP for auto-discovery and LDP for VC label 
signalling. You can also use BGP for both.



What I don't get is how you could use FEC128 with BGP signalling. Junos doesn't 
give you the option to only signal through BGP but manual discovery through LDP.



So my question is, when exactly would the FEC128 config be used over the FEC129 
config? If you are using BGP for signalling are you not using BGP for discovery 
at the same time?



Or maybe I'm just misunderstanding something.





Thanks

Darren

http://www.mellowd.co.uk/ccie







___

juniper-nsp mailing list juniper-nsp@puck.nether.net

https://puck.nether.net/mailman/listinfo/juniper-nsp


  
___
juniper-nsp mailing list juniper-nsp@puck.nether.net
https://puck.nether.net/mailman/listinfo/juniper-nsp


Re: [j-nsp] VPLS Multihoming on Junos - FEC confusion

2013-09-10 Thread Per Granath
Perhaps this is useful:

https://www.juniper.net/techpubs/en_US/junos/topics/topic-map/vpls-bgp-multihoming.html

There are two places in the configuration where you can configure VPLS 
multihoming. One is for FEC 128, and the other is for FEC 129:

For FEC 128-routing-instances instance-name protocols vpls site site-name 
multi-homing
For FEC 129-routing-instances instance-name protocols vpls multi-homing


-Original Message-
From: juniper-nsp [mailto:juniper-nsp-boun...@puck.nether.net] On Behalf Of 
Darren O'Connor
Sent: Tuesday, September 10, 2013 3:53 PM
To: Krasimir Avramski
Cc: juniper-nsp@puck.nether.net
Subject: Re: [j-nsp] VPLS Multihoming on Junos - FEC confusion

That's my thought too. However even the 12.3 VPLS configuration guide states 
FEC128 multihoming. But again showing with BGP

Thanks
Darren
http://www.mellowd.co.uk/ccie



Date: Mon, 9 Sep 2013 23:30:08 +0300
Subject: Re: [j-nsp] VPLS Multihoming on Junos - FEC confusion
From: kr...@smartcom.bg
To: darre...@outlook.com
CC: juniper-nsp@puck.nether.net

Hello,
IMHO there is mess with docs/terms. FEC 128 multihoming as described has 
nothing to do with ldp. It's bgp signaling and autodiscovery.
Krasi


On 8 September 2013 22:37, Darren O'Connor darre...@outlook.com wrote:







Hi list.



I'm going over the VPLS multihoming options on Juniper's web site. I'm not 
concerned with LAG and MC-LAG for the moment.



As far as I'm aware, FEC128 is when you are using manual discovery of 
pseudowires (LDP) - FEC129 is when you are using BGP auto-discovery.



Juniper techpub for FEC129 multihoming I don't have a problem with as it shows 
how to multihome with BGP: 
https://www.juniper.net/techpubs/en_US/junos/topics/topic-map/vpls-bgp-multihoming.html




The FEC128 multihome techpub says that you cannot enable LDP signalling, you 
have to use BGP signalling: 
http://www.juniper.net/techpubs/en_US/junos/topics/usage-guidelines/vpns-configuring-vpls-multihoming.html






I know that you can use LDP for manual discovery and LDP will then signal VC 
labels. You can also use BGP for auto-discovery and LDP for VC label 
signalling. You can also use BGP for both.



What I don't get is how you could use FEC128 with BGP signalling. Junos doesn't 
give you the option to only signal through BGP but manual discovery through LDP.



So my question is, when exactly would the FEC128 config be used over the FEC129 
config? If you are using BGP for signalling are you not using BGP for discovery 
at the same time?



Or maybe I'm just misunderstanding something.





Thanks

Darren

http://www.mellowd.co.uk/ccie







___

juniper-nsp mailing list juniper-nsp@puck.nether.net

https://puck.nether.net/mailman/listinfo/juniper-nsp


  
___
juniper-nsp mailing list juniper-nsp@puck.nether.net 
https://puck.nether.net/mailman/listinfo/juniper-nsp

___
juniper-nsp mailing list juniper-nsp@puck.nether.net
https://puck.nether.net/mailman/listinfo/juniper-nsp


Re: [j-nsp] VPLS Multihoming on Junos - FEC confusion

2013-09-10 Thread Darren O'Connor
I understand that part, but it doesn't answer the original question. 

Thanks
Darren
http://www.mellowd.co.uk/ccie



 From: per.gran...@gcc.com.cy
 To: darre...@outlook.com; kr...@smartcom.bg
 CC: juniper-nsp@puck.nether.net
 Subject: RE: [j-nsp] VPLS Multihoming on Junos - FEC confusion
 Date: Tue, 10 Sep 2013 13:20:17 +
 
 Perhaps this is useful:
 
 https://www.juniper.net/techpubs/en_US/junos/topics/topic-map/vpls-bgp-multihoming.html
 
 There are two places in the configuration where you can configure VPLS 
 multihoming. One is for FEC 128, and the other is for FEC 129:
 
 For FEC 128-routing-instances instance-name protocols vpls site site-name 
 multi-homing
 For FEC 129-routing-instances instance-name protocols vpls multi-homing
 
 
 -Original Message-
 From: juniper-nsp [mailto:juniper-nsp-boun...@puck.nether.net] On Behalf Of 
 Darren O'Connor
 Sent: Tuesday, September 10, 2013 3:53 PM
 To: Krasimir Avramski
 Cc: juniper-nsp@puck.nether.net
 Subject: Re: [j-nsp] VPLS Multihoming on Junos - FEC confusion
 
 That's my thought too. However even the 12.3 VPLS configuration guide states 
 FEC128 multihoming. But again showing with BGP
 
 Thanks
 Darren
 http://www.mellowd.co.uk/ccie
 
 
 
 Date: Mon, 9 Sep 2013 23:30:08 +0300
 Subject: Re: [j-nsp] VPLS Multihoming on Junos - FEC confusion
 From: kr...@smartcom.bg
 To: darre...@outlook.com
 CC: juniper-nsp@puck.nether.net
 
 Hello,
 IMHO there is mess with docs/terms. FEC 128 multihoming as described has 
 nothing to do with ldp. It's bgp signaling and autodiscovery.
 Krasi
 
 
 On 8 September 2013 22:37, Darren O'Connor darre...@outlook.com wrote:
 
 
 
 
 
 
 
 Hi list.
 
 
 
 I'm going over the VPLS multihoming options on Juniper's web site. I'm not 
 concerned with LAG and MC-LAG for the moment.
 
 
 
 As far as I'm aware, FEC128 is when you are using manual discovery of 
 pseudowires (LDP) - FEC129 is when you are using BGP auto-discovery.
 
 
 
 Juniper techpub for FEC129 multihoming I don't have a problem with as it 
 shows how to multihome with BGP: 
 https://www.juniper.net/techpubs/en_US/junos/topics/topic-map/vpls-bgp-multihoming.html
 
 
 
 
 The FEC128 multihome techpub says that you cannot enable LDP signalling, you 
 have to use BGP signalling: 
 http://www.juniper.net/techpubs/en_US/junos/topics/usage-guidelines/vpns-configuring-vpls-multihoming.html
 
 
 
 
 
 
 I know that you can use LDP for manual discovery and LDP will then signal VC 
 labels. You can also use BGP for auto-discovery and LDP for VC label 
 signalling. You can also use BGP for both.
 
 
 
 What I don't get is how you could use FEC128 with BGP signalling. Junos 
 doesn't give you the option to only signal through BGP but manual discovery 
 through LDP.
 
 
 
 So my question is, when exactly would the FEC128 config be used over the 
 FEC129 config? If you are using BGP for signalling are you not using BGP for 
 discovery at the same time?
 
 
 
 Or maybe I'm just misunderstanding something.
 
 
 
 
 
 Thanks
 
 Darren
 
 http://www.mellowd.co.uk/ccie
 
 
 
 
 
 
 
 ___
 
 juniper-nsp mailing list juniper-nsp@puck.nether.net
 
 https://puck.nether.net/mailman/listinfo/juniper-nsp
 
 
 
 ___
 juniper-nsp mailing list juniper-nsp@puck.nether.net 
 https://puck.nether.net/mailman/listinfo/juniper-nsp
  
___
juniper-nsp mailing list juniper-nsp@puck.nether.net
https://puck.nether.net/mailman/listinfo/juniper-nsp


Re: [j-nsp] Curly braces in AS-path

2013-09-10 Thread Jared Mauch

On Sep 10, 2013, at 12:45 PM, Vincent De Keyzer vinc...@dekeyzer.net wrote:

 Hello all,
 
 the following comes from the TeliaSonera looking glass (http://lg.telia.net/
 ):
 
 Router: Hong Kong
 Command: show route protocol bgp 1.38.0.0/17 table inet.0
 
 inet.0: 518574 destinations, 1103564 routes (518516 active, 113 holddown,
 1207 hidden)
 + = Active Route, - = Last Active, * = Both
 
 1.38.0.0/17*[BGP/170] 1w2d 17:44:34, MED 0, localpref 150
  AS path: 1273 55410 38266 {38266} ?
 to 80.239.130.206 via ge-2/1/1.0
 
 What do the curly braces in the AS path mean? More generally, does someone
 know a document explaining how to interpret the output of sh route prot
 bgp?

AS-SET

http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a0080094826.shtml#aggregatingwiththeassetargument
- Jared


___
juniper-nsp mailing list juniper-nsp@puck.nether.net
https://puck.nether.net/mailman/listinfo/juniper-nsp


[j-nsp] Curly braces in AS-path

2013-09-10 Thread Vincent De Keyzer
Hello all,

the following comes from the TeliaSonera looking glass (http://lg.telia.net/
):

Router: Hong Kong
Command: show route protocol bgp 1.38.0.0/17 table inet.0

inet.0: 518574 destinations, 1103564 routes (518516 active, 113 holddown,
1207 hidden)
+ = Active Route, - = Last Active, * = Both

1.38.0.0/17*[BGP/170] 1w2d 17:44:34, MED 0, localpref 150
  AS path: 1273 55410 38266 {38266} ?
 to 80.239.130.206 via ge-2/1/1.0

What do the curly braces in the AS path mean? More generally, does someone
know a document explaining how to interpret the output of sh route prot
bgp?

Thanks,

Vincent
___
juniper-nsp mailing list juniper-nsp@puck.nether.net
https://puck.nether.net/mailman/listinfo/juniper-nsp


Re: [j-nsp] Curly braces in AS-path

2013-09-10 Thread Phil Shafer
Vincent De Keyzer writes:
What do the curly braces in the AS path mean? More generally, does someone
know a document explaining how to interpret the output of sh route prot
bgp?

I don't see anything under show route protocol bgp:

http://www.juniper.net/techpubs/en_US/junos/topics/reference/command-summary/show-route-protocol.html

But under show route advertising-protocol you get decoder ring:

http://www.juniper.net/techpubs/en_US/junos/topics/reference/command-summary/show-route-advertising-protocol.html

AS path through which the route was learned. The letters at the
end of the AS path indicate the path origin, providing an
indication of the state of the route at the point at which the
AS path originated:

I - IGP.
E - EGP.
? - Incomplete; typically, the AS path was aggregated.

When AS path numbers are included in the route, the format is as follows:

[ ] - Brackets enclose the local AS number associated with the
AS path if configured on the router, or if AS path prepending
is configured.
{ } - Braces enclose AS sets, which are groups of AS numbers
in which the order does not matter. A set commonly results from
route aggregation. The numbers in each AS set are displayed in
ascending order.
( ) - Parentheses enclose a confederation.
( [ ] ) - Parentheses and brackets enclose a confederation set.

Note: In Junos OS Release 10.3 and later, the AS path field
displays an unrecognized attribute and associated hexadecimal
value if BGP receives attribute 128 (attribute set) and you
have not configured an independent domain in any routing instance.

Thanks,
 Phil

___
juniper-nsp mailing list juniper-nsp@puck.nether.net
https://puck.nether.net/mailman/listinfo/juniper-nsp


Re: [j-nsp] Curly braces in AS-path

2013-09-10 Thread Michael Hallgren
Hi, AS-set normally. Used in context of aggregation. 

Cheers
mh 

 Message d'origine 
De : Vincent De Keyzer vinc...@dekeyzer.net 
Date :  
A : juniper-nsp@puck.nether.net 
Objet : [j-nsp] Curly braces in AS-path 
 
Hello all,

the following comes from the TeliaSonera looking glass (http://lg.telia.net/
):

Router: Hong Kong
Command: show route protocol bgp 1.38.0.0/17 table inet.0

inet.0: 518574 destinations, 1103564 routes (518516 active, 113 holddown,
1207 hidden)
+ = Active Route, - = Last Active, * = Both

1.38.0.0/17    *[BGP/170] 1w2d 17:44:34, MED 0, localpref 150
  AS path: 1273 55410 38266 {38266} ?
     to 80.239.130.206 via ge-2/1/1.0

What do the curly braces in the AS path mean? More generally, does someone
know a document explaining how to interpret the output of sh route prot
bgp?

Thanks,

Vincent
___
juniper-nsp mailing list juniper-nsp@puck.nether.net
https://puck.nether.net/mailman/listinfo/juniper-nsp
___
juniper-nsp mailing list juniper-nsp@puck.nether.net
https://puck.nether.net/mailman/listinfo/juniper-nsp

Re: [j-nsp] Curly braces in AS-path

2013-09-10 Thread Antonio Sanchez-Monge
Hi,

This is an AS Set that is generated when a route is aggregated.


http://www.rfc-editor.org/rfc/rfc4271.txt

Section 5.1.6


Thanks,


Antonio Sánchez-Monge
Juniper Networks

Want to win up to 200 Junosphere VM days? Take the Mastering Junos
Configuration Challenge!

http://juni.pr/14yzj5v






___
juniper-nsp mailing list juniper-nsp@puck.nether.net
https://puck.nether.net/mailman/listinfo/juniper-nsp


[j-nsp] WIN Junosphere VM credits by taking the Mastering Junos Configuration Challenge!

2013-09-10 Thread Antonio Sanchez-Monge
Hi,

Apologies for the wide distribution, I thought it may be of interest to
someone.

We just launched a remote hands-on worldwide Junos challenge. It's a
tricky one, hope you like it.

Take the Mastering Junos Configuration Challenge!

http://juni.pr/14yzj5v


Also you can subscribe to that blog to get notified of possible future
hands-on challenges on different topics (networking, security, etc...).

Thanks,
Ato



___
juniper-nsp mailing list juniper-nsp@puck.nether.net
https://puck.nether.net/mailman/listinfo/juniper-nsp


[j-nsp] Help: Learning routes from same ASN, cisco vs juniper

2013-09-10 Thread OBrien, Will
I've found an interesting issue and I wanted to get some thoughts before 
talking to JTAC about it.


I have a few of MX480s.  In the past, I've advertised a dedicated /24 from my 
lab to my providers upstream.
That /24 was never learned by my primary MX.

The issue comes down to either the MX or the Cisco filtering routes that are 
from the same ASN.  It's been a couple of years since I ran across this and I 
can't remember who was at fault.


This behavior is biting my with regard to my DR site.


At my DR, I have a SRX with say ASN 1234. It's advertising a /24.

At my primary site, I also use ASN1234. I do not receive the /24 via BGP.

So, either the Cisco (7600 I think) isn't advertising the route to me because 
it's from my ASN - OR - The MX is filtering it because it's from my ASN and 
coming in on a eBGP link.


If it's the MX, I'm certain I can write an import filter, but I'm having an 
issue hunting down syntax on that.
If it's the Cisco, then I can yell at the provider to have them open a TAC 
case. 



Like I said, I ran across this a few years ago, but can't remember who was at 
fault. I could build a multi-hop neighbor relationship to get around this, but 
surely there's a simpler solution...
___
juniper-nsp mailing list juniper-nsp@puck.nether.net
https://puck.nether.net/mailman/listinfo/juniper-nsp


Re: [j-nsp] Help: Learning routes from same ASN, cisco vs juniper

2013-09-10 Thread David Miller


On 9/10/2013 1:28 PM, OBrien, Will wrote:
 I've found an interesting issue and I wanted to get some thoughts before 
 talking to JTAC about it.
 
 
 I have a few of MX480s.  In the past, I've advertised a dedicated /24 from my 
 lab to my providers upstream.
 That /24 was never learned by my primary MX.
 
 The issue comes down to either the MX or the Cisco filtering routes that are 
 from the same ASN.  It's been a couple of years since I ran across this and I 
 can't remember who was at fault.
 
 
 This behavior is biting my with regard to my DR site.
 
 
 At my DR, I have a SRX with say ASN 1234. It's advertising a /24.
 
 At my primary site, I also use ASN1234. I do not receive the /24 via BGP.
 
 So, either the Cisco (7600 I think) isn't advertising the route to me because 
 it's from my ASN - OR - The MX is filtering it because it's from my ASN and 
 coming in on a eBGP link.
 
 
 If it's the MX, I'm certain I can write an import filter, but I'm having an 
 issue hunting down syntax on that.
 If it's the Cisco, then I can yell at the provider to have them open a TAC 
 case. 
 
 
 
 Like I said, I ran across this a few years ago, but can't remember who was at 
 fault. I could build a multi-hop neighbor relationship to get around this, 
 but surely there's a simpler solution...

In Juniper:

https://www.juniper.net/techpubs/en_US/junos/topics/reference/configuration-statement/loops-edit-protocols-bgp-family.html

protocols {
bgp {
neighbor 10.2.3.4 {
family inet {
unicast {
loops 1;
}
}
}
}
}

-set-

set protocols bgp neighbor 10.2.3.4 family inet unicast loops 1

^^ Will allow AS in path 1 time (can be set higher).

-DMM



signature.asc
Description: OpenPGP digital signature
___
juniper-nsp mailing list juniper-nsp@puck.nether.net
https://puck.nether.net/mailman/listinfo/juniper-nsp

[j-nsp] virtual router on mx

2013-09-10 Thread Piotr

Hello,

On my mx240 ( 11.4R5.5) i try to make virtual router with additional bgp 
session to my isp. Main bgp session in main routing table goes via 
ae0.74, extra session in vr blackhole should go via ae0.77. Problem is 
that there is no communication with peer in this virtual router. When i 
ping remote site from interface in vr blackhole i see this packets on 
interface in main router.. I don't know why junos  transmit packets via 
main routing table ?


Appreciate the help
many thanks
Peter


below config and some output


p2p addresses:
me: 10.10.7.154/30
remote: 10.10.7.153/30


# show interfaces ae0.74
description main_interface;
vlan-id 74;
family inet {
address 10.10.7.130/30;
}


#show interfaces ae0.77
description vr-blackholing;
vlan-id 77;
family inet {
address 10.10.7.154/30;
}



# show routing-instances blackhole
instance-type virtual-router;
interface ae0.77;
routing-options {
static {
route 10.10.0.243/32 next-hop 10.10.7.153;
}
autonomous-system 138;
}
protocols {
bgp {
group blackhole {
type external;
multihop;
local-address 10.10.7.154;
import blackhole-in;
export blackhole-out;
peer-as 123;
neighbor 10.10.0.243;
}
}
}


# run show route 10.10.7.153
inet.0: 466059 destinations, 1693894 routes (466053 active, 6 holddown, 
2 hidden)



10.10.0.0/16 *[BGP/170] 1w5d 12:40:05, MED 0, localpref 1141, from 
10.10.0.243

  AS path: 123 I
 to 10.10.7.129 via ae0.74


blackhole.inet.0: 4 destinations, 4 routes (4 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

10.10.7.152/30   *[Direct/0] 00:47:23
 via ae0.77




___
juniper-nsp mailing list juniper-nsp@puck.nether.net
https://puck.nether.net/mailman/listinfo/juniper-nsp


[j-nsp] m10 re-333 latest version of junos

2013-09-10 Thread N. Max Pierson
Hi list,

I have a couple of old m10s with re-333s in them and I would like to
upgrade them to whatever the last version of Junos code they can run. These
are lab routers and not production. Can someone point me in the right
direction? I've seen a few folks say 10.4 will work, but I only see the
m120, m160, m320 etc on the downloads page. I assume the m120 image would
work in this case?

Thanks All!
___
juniper-nsp mailing list juniper-nsp@puck.nether.net
https://puck.nether.net/mailman/listinfo/juniper-nsp


Re: [j-nsp] m10 re-333 latest version of junos

2013-09-10 Thread Jerry Jones
Depends a lot of which flavor you have with what memory

This RE came with either 246M or 768M of memory and an 80MB flash

Note: For M-series, MX-series, and T-series routing platforms, the CompactFlash 
card memory requirement for JUNOS software Release 9.0 is 1 GB. For M7i and 
M10i routing platforms with only 256 MB of memory, see the Customer Support 
Center JTAC Technical Bulletin PSN-2007-10-001: 
https://www.juniper.net/alerts/viewalert.jsp?txtAlertNumber=PSN-2007-10-001actionBtn=Search.

Hope this helps


On Sep 10, 2013, at 2:49 PM, N. Max Pierson nmaxpier...@gmail.com wrote:

Hi list,

I have a couple of old m10s with re-333s in them and I would like to
upgrade them to whatever the last version of Junos code they can run. These
are lab routers and not production. Can someone point me in the right
direction? I've seen a few folks say 10.4 will work, but I only see the
m120, m160, m320 etc on the downloads page. I assume the m120 image would
work in this case?

Thanks All!
___
juniper-nsp mailing list juniper-nsp@puck.nether.net
https://puck.nether.net/mailman/listinfo/juniper-nsp

___
juniper-nsp mailing list juniper-nsp@puck.nether.net
https://puck.nether.net/mailman/listinfo/juniper-nsp


[j-nsp] M5 or M10 AC power supplies

2013-09-10 Thread Chuck Anderson
I have an old M10 (not M10i) with DC power supplies.  Does anyone have
any AC power supplies they'd be willing to part with or trade for the
2 DC ones I have?  This is just for playing around in the home lab...

Alternatively, does anyone know of a cheap way to get enough DC power
for these in a lab that doesn't have DC power?  Each power supply
needs 14A at 48V, about 700W.

This needs to be really cheap or free, because otherwise I'm just
going to trash the whole router.

Thanks,
Chuck
___
juniper-nsp mailing list juniper-nsp@puck.nether.net
https://puck.nether.net/mailman/listinfo/juniper-nsp


Re: [j-nsp] VPLS Multihoming on Junos - FEC confusion

2013-09-10 Thread Krasimir Avramski
Hi,

Note the junos 7.5 release introduction of
multi-hominghttp://www.juniper.net/techpubs/en_US/junos/topics/reference/configuration-statement/multi-homing-edit-protocols-vpls.htmlstanza
(under routing-instances
instance-name protocols vpls site site-name) specified in FEC 128 doc.
Believe me that with 7.5 release only BGP signaling/autodiscovery was
supported -  I remember that at this time there was VPLS standard
battlehttp://www.lightreading.com/document.asp?doc_id=589392


Krasi


On 10 September 2013 17:18, Darren O'Connor darre...@outlook.com wrote:

 I understand that part, but it doesn't answer the original question.

 Thanks
 Darren
 http://www.mellowd.co.uk/ccie



  From: per.gran...@gcc.com.cy
  To: darre...@outlook.com; kr...@smartcom.bg
  CC: juniper-nsp@puck.nether.net
  Subject: RE: [j-nsp] VPLS Multihoming on Junos - FEC confusion
  Date: Tue, 10 Sep 2013 13:20:17 +
 
  Perhaps this is useful:
 
 
 https://www.juniper.net/techpubs/en_US/junos/topics/topic-map/vpls-bgp-multihoming.html
 
  There are two places in the configuration where you can configure VPLS
 multihoming. One is for FEC 128, and the other is for FEC 129:
 
  For FEC 128-routing-instances instance-name protocols vpls site
 site-name multi-homing
  For FEC 129-routing-instances instance-name protocols vpls multi-homing
 
 
  -Original Message-
  From: juniper-nsp [mailto:juniper-nsp-boun...@puck.nether.net] On
 Behalf Of Darren O'Connor
  Sent: Tuesday, September 10, 2013 3:53 PM
  To: Krasimir Avramski
  Cc: juniper-nsp@puck.nether.net
  Subject: Re: [j-nsp] VPLS Multihoming on Junos - FEC confusion
 
  That's my thought too. However even the 12.3 VPLS configuration guide
 states FEC128 multihoming. But again showing with BGP
 
  Thanks
  Darren
  http://www.mellowd.co.uk/ccie
 
 
 
  Date: Mon, 9 Sep 2013 23:30:08 +0300
  Subject: Re: [j-nsp] VPLS Multihoming on Junos - FEC confusion
  From: kr...@smartcom.bg
  To: darre...@outlook.com
  CC: juniper-nsp@puck.nether.net
 
  Hello,
  IMHO there is mess with docs/terms. FEC 128 multihoming as described has
 nothing to do with ldp. It's bgp signaling and autodiscovery.
  Krasi
 
 
  On 8 September 2013 22:37, Darren O'Connor darre...@outlook.com wrote:
 
 
 
 
 
 
 
  Hi list.
 
 
 
  I'm going over the VPLS multihoming options on Juniper's web site. I'm
 not concerned with LAG and MC-LAG for the moment.
 
 
 
  As far as I'm aware, FEC128 is when you are using manual discovery of
 pseudowires (LDP) - FEC129 is when you are using BGP auto-discovery.
 
 
 
  Juniper techpub for FEC129 multihoming I don't have a problem with as it
 shows how to multihome with BGP:
 https://www.juniper.net/techpubs/en_US/junos/topics/topic-map/vpls-bgp-multihoming.html
 
 
 
 
  The FEC128 multihome techpub says that you cannot enable LDP signalling,
 you have to use BGP signalling:
 http://www.juniper.net/techpubs/en_US/junos/topics/usage-guidelines/vpns-configuring-vpls-multihoming.html
 
 
 
 
 
 
  I know that you can use LDP for manual discovery and LDP will then
 signal VC labels. You can also use BGP for auto-discovery and LDP for VC
 label signalling. You can also use BGP for both.
 
 
 
  What I don't get is how you could use FEC128 with BGP signalling. Junos
 doesn't give you the option to only signal through BGP but manual discovery
 through LDP.
 
 
 
  So my question is, when exactly would the FEC128 config be used over the
 FEC129 config? If you are using BGP for signalling are you not using BGP
 for discovery at the same time?
 
 
 
  Or maybe I'm just misunderstanding something.
 
 
 
 
 
  Thanks
 
  Darren
 
  http://www.mellowd.co.uk/ccie
 
 
 
 
 
 
 
  ___
 
  juniper-nsp mailing list juniper-nsp@puck.nether.net
 
  https://puck.nether.net/mailman/listinfo/juniper-nsp
 
 
 
  ___
  juniper-nsp mailing list juniper-nsp@puck.nether.net
 https://puck.nether.net/mailman/listinfo/juniper-nsp

 ___
 juniper-nsp mailing list juniper-nsp@puck.nether.net
 https://puck.nether.net/mailman/listinfo/juniper-nsp

___
juniper-nsp mailing list juniper-nsp@puck.nether.net
https://puck.nether.net/mailman/listinfo/juniper-nsp


Re: [j-nsp] m10 re-333 latest version of junos

2013-09-10 Thread Tobias Heister
Hi,

Am 10.09.2013 21:49, schrieb N. Max Pierson:
 I have a couple of old m10s with re-333s in them and I would like to
 upgrade them to whatever the last version of Junos code they can run. These
 are lab routers and not production. Can someone point me in the right
 direction? I've seen a few folks say 10.4 will work, but I only see the
 m120, m160, m320 etc on the downloads page. I assume the m120 image would
 work in this case?

We are currently running 10.4 (R9 i should upgrade them) on our lab M5s with 
RE2.0 or RE3.0.

You can use the M-series, MX high end series  T-series Install Package which 
is a universal image for all the m-series devices. In theory newer releases (11 
or even 12) should work as well, but i have not tried it myself. It might be 
they removed support for EOL Hardware somewhere down the line.

Depending on the release you come from you might need/want to use the 
M-series, MX high end series  T-series Install Media if you do not want to 
perform a nearly endless upgrade chain. 

You might need additional compact flash to install the newer releases. We used 
off the shelf cf cards which just worked. If you can find some old memory it 
can be quite handy because the newer releases use lots of memory.

This Router is currently idle with basically factory default configuration
 lab@LR2 show chassis routing-engine
 Routing Engine status:
 Temperature 36 degrees C / 96 degrees F
 CPU temperature 36 degrees C / 96 degrees F
 DRAM   384 MB
 Memory utilization  77 percent
 CPU utilization:
   User   0 percent
   Background 0 percent
   Kernel 1 percent
   Interrupt  0 percent
   Idle  98 percent
 Model  RE-2.0

-- 
Kind Regards
Tobias Heister
___
juniper-nsp mailing list juniper-nsp@puck.nether.net
https://puck.nether.net/mailman/listinfo/juniper-nsp


Re: [j-nsp] M5 or M10 AC power supplies

2013-09-10 Thread Michael Loftis
I was pretty sure the old M5/M10 were around 500W, max, total.  You
sure that 700W isn't just the rating on the PSU? I'd bet you only need
A couple hundred total to run it unless it's fully
configured...Something like this -
http://www.trcelectronics.com/View/Mean-Well/HRP-200-48.shtml



On Tue, Sep 10, 2013 at 2:16 PM, Chuck Anderson c...@wpi.edu wrote:
 I have an old M10 (not M10i) with DC power supplies.  Does anyone have
 any AC power supplies they'd be willing to part with or trade for the
 2 DC ones I have?  This is just for playing around in the home lab...

 Alternatively, does anyone know of a cheap way to get enough DC power
 for these in a lab that doesn't have DC power?  Each power supply
 needs 14A at 48V, about 700W.

 This needs to be really cheap or free, because otherwise I'm just
 going to trash the whole router.

 Thanks,
 Chuck
 ___
 juniper-nsp mailing list juniper-nsp@puck.nether.net
 https://puck.nether.net/mailman/listinfo/juniper-nsp



-- 

Genius might be described as a supreme capacity for getting its possessors
into trouble of all kinds.
-- Samuel Butler
___
juniper-nsp mailing list juniper-nsp@puck.nether.net
https://puck.nether.net/mailman/listinfo/juniper-nsp


Re: [j-nsp] m10 re-333 latest version of junos

2013-09-10 Thread N. Max Pierson
I have the 768M flavor and have already upgraded the CF to 2GB. I'm
currently on 8.5 and wanted to get to the latest version for these 2 lab
boxes.

I'll give 10.4 a shot for now.

Thanks for all of the responses!


On Tue, Sep 10, 2013 at 4:10 PM, Jerry Jones jjo...@danrj.com wrote:

 Depends a lot of which flavor you have with what memory

 This RE came with either 246M or 768M of memory and an 80MB flash

 *Note: *For M-series, MX-series, and T-series routing platforms, the
 CompactFlash card memory requirement for JUNOS software Release 9.0 is 1
 GB. For M7i and M10i routing platforms with only 256 MB of memory, see the
 Customer Support Center JTAC Technical Bulletin PSN-2007-10-001:
 https://www.juniper.net/alerts/viewalert.jsp?txtAlertNumber=PSN-2007-10-001actionBtn=Search
 .

 Hope this helps


 On Sep 10, 2013, at 2:49 PM, N. Max Pierson nmaxpier...@gmail.com wrote:

 Hi list,

 I have a couple of old m10s with re-333s in them and I would like to
 upgrade them to whatever the last version of Junos code they can run. These
 are lab routers and not production. Can someone point me in the right
 direction? I've seen a few folks say 10.4 will work, but I only see the
 m120, m160, m320 etc on the downloads page. I assume the m120 image would
 work in this case?

 Thanks All!
 ___
 juniper-nsp mailing list juniper-nsp@puck.nether.net
 https://puck.nether.net/mailman/listinfo/juniper-nsp


___
juniper-nsp mailing list juniper-nsp@puck.nether.net
https://puck.nether.net/mailman/listinfo/juniper-nsp