Re: Review Request 123735: version of QmlObject with a static engine

2015-05-21 Thread Marco Martin

---
This is an automatically generated e-mail. To reply, visit:
https://git.reviewboard.kde.org/r/123735/
---

(Updated May 21, 2015, 4:02 p.m.)


Review request for KDE Frameworks and Plasma.


Repository: kdeclarative


Description
---

to make easier doing applications like plasma that use a lot of qml to have a 
single engine make a subclass of QmlObject called QmlObjectSharedEngine that 
has a single, static QQmlEngine

Adds a class called QuickViewSharedEngine that has the same behavior as 
QmlObjectSharedEngine(using it): static QQmlEngine, separed rootContexts() for 
each instance.
This is used by desktopviews and panelviews to share their engine.

Unfortunately it may not be possible to get the applet configuration dialogs to 
use this, since they still need a separed engine in order to have a different 
controls style (qstyle based) than the stuff in the desktop/panel


Diffs (updated)
-

  autotests/CMakeLists.txt adc1102 
  autotests/quickviewsharedengine.cpp PRE-CREATION 
  autotests/util.h PRE-CREATION 
  autotests/util.cpp PRE-CREATION 
  src/kdeclarative/CMakeLists.txt d73bff0 
  src/kdeclarative/kdeclarative.cpp b3906e2 
  src/kdeclarative/qmlobject.h f26b67d 
  src/kdeclarative/qmlobject.cpp c483665 
  src/kdeclarative/qmlobjectsharedengine.h PRE-CREATION 
  src/kdeclarative/qmlobjectsharedengine.cpp PRE-CREATION 
  src/quickaddons/CMakeLists.txt 777d07c 
  src/quickaddons/quickviewsharedengine.h PRE-CREATION 
  src/quickaddons/quickviewsharedengine.cpp PRE-CREATION 

Diff: https://git.reviewboard.kde.org/r/123735/diff/


Testing
---


Thanks,

Marco Martin

___
Kde-frameworks-devel mailing list
Kde-frameworks-devel@kde.org
https://mail.kde.org/mailman/listinfo/kde-frameworks-devel


Re: Review Request 123872: Add TranslationDomain attribute to kconfig_compiler

2015-05-21 Thread Matthew Dawson

---
This is an automatically generated e-mail. To reply, visit:
https://git.reviewboard.kde.org/r/123872/#review80698
---


LGTM in general, but could you please add/update a unit test to test all the 
possible cominbations of the translation?

- Matthew Dawson


On May 21, 2015, 11:21 a.m., Chusslove Illich wrote:
> 
> ---
> This is an automatically generated e-mail. To reply, visit:
> https://git.reviewboard.kde.org/r/123872/
> ---
> 
> (Updated May 21, 2015, 11:21 a.m.)
> 
> 
> Review request for KDE Frameworks, Alexander Potashev and Matthew Dawson.
> 
> 
> Repository: kconfig
> 
> 
> Description
> ---
> 
> When using Ki18n as the translation system, library .kcfg files also need to 
> specify the translation domain. This is analogous to the TRANSLATION_DOMAIN 
> define in C++ code, and translationDomain attribute in .rc files.
> 
> 
> Diffs
> -
> 
>   src/kconfig_compiler/kconfig_compiler.cpp 7160bb5 
> 
> Diff: https://git.reviewboard.kde.org/r/123872/diff/
> 
> 
> Testing
> ---
> 
> Compiles.
> 
> 
> Thanks,
> 
> Chusslove Illich
> 
>

___
Kde-frameworks-devel mailing list
Kde-frameworks-devel@kde.org
https://mail.kde.org/mailman/listinfo/kde-frameworks-devel


Review Request 123872: Add TranslationDomain attribute to kconfig_compiler

2015-05-21 Thread Chusslove Illich

---
This is an automatically generated e-mail. To reply, visit:
https://git.reviewboard.kde.org/r/123872/
---

Review request for KDE Frameworks, Alexander Potashev and Matthew Dawson.


Repository: kconfig


Description
---

When using Ki18n as the translation system, library .kcfg files also need to 
specify the translation domain. This is analogous to the TRANSLATION_DOMAIN 
define in C++ code, and translationDomain attribute in .rc files.


Diffs
-

  src/kconfig_compiler/kconfig_compiler.cpp 7160bb5 

Diff: https://git.reviewboard.kde.org/r/123872/diff/


Testing
---

Compiles.


Thanks,

Chusslove Illich

___
Kde-frameworks-devel mailing list
Kde-frameworks-devel@kde.org
https://mail.kde.org/mailman/listinfo/kde-frameworks-devel


Re: Review Request 123735: version of QmlObject with a static engine

2015-05-21 Thread Vishesh Handa

---
This is an automatically generated e-mail. To reply, visit:
https://git.reviewboard.kde.org/r/123735/#review80695
---

Ship it!


Awesome. I love the test!


autotests/quickviewsharedengine.cpp (line 189)


Very minor thing -

QCOMPARE(view->status(), QQcmlComponent::Error);
QCOMPARE(view->errors().count(), 1);



src/kdeclarative/qmlobjectsharedengine.cpp (line 48)


Could you please add a comment specifying why 2 refs is the magic number.

I understand that it's our own engineRef and s_engine, but it took me a bit 
to figure it out.

How about -
// Delete when we along with the static shared pointer are the only 
references to it.


- Vishesh Handa


On May 21, 2015, 10:52 a.m., Marco Martin wrote:
> 
> ---
> This is an automatically generated e-mail. To reply, visit:
> https://git.reviewboard.kde.org/r/123735/
> ---
> 
> (Updated May 21, 2015, 10:52 a.m.)
> 
> 
> Review request for KDE Frameworks and Plasma.
> 
> 
> Repository: kdeclarative
> 
> 
> Description
> ---
> 
> to make easier doing applications like plasma that use a lot of qml to have a 
> single engine make a subclass of QmlObject called QmlObjectSharedEngine that 
> has a single, static QQmlEngine
> 
> Adds a class called QuickViewSharedEngine that has the same behavior as 
> QmlObjectSharedEngine(using it): static QQmlEngine, separed rootContexts() 
> for each instance.
> This is used by desktopviews and panelviews to share their engine.
> 
> Unfortunately it may not be possible to get the applet configuration dialogs 
> to use this, since they still need a separed engine in order to have a 
> different controls style (qstyle based) than the stuff in the desktop/panel
> 
> 
> Diffs
> -
> 
>   autotests/CMakeLists.txt adc1102 
>   autotests/quickviewsharedengine.cpp PRE-CREATION 
>   autotests/util.h PRE-CREATION 
>   autotests/util.cpp PRE-CREATION 
>   src/kdeclarative/CMakeLists.txt d73bff0 
>   src/kdeclarative/kdeclarative.cpp b3906e2 
>   src/kdeclarative/qmlobject.h f26b67d 
>   src/kdeclarative/qmlobject.cpp c483665 
>   src/kdeclarative/qmlobjectsharedengine.h PRE-CREATION 
>   src/kdeclarative/qmlobjectsharedengine.cpp PRE-CREATION 
>   src/quickaddons/CMakeLists.txt 777d07c 
>   src/quickaddons/quickviewsharedengine.h PRE-CREATION 
>   src/quickaddons/quickviewsharedengine.cpp PRE-CREATION 
> 
> Diff: https://git.reviewboard.kde.org/r/123735/diff/
> 
> 
> Testing
> ---
> 
> 
> Thanks,
> 
> Marco Martin
> 
>

___
Kde-frameworks-devel mailing list
Kde-frameworks-devel@kde.org
https://mail.kde.org/mailman/listinfo/kde-frameworks-devel


KI18n programmer's guide mentions non-existent kcfgc parameter TranslationDomain

2015-05-21 Thread Alexander Potashev
Hi,

The current ki18n/docs/programmers-guide.md says that a
TranslationDomain field in .kcfgc file can be used to set the
translation domain. But in fact, KConfig's kconfig_compiler_kf5 does
not read that field.

Is there a plan to revive support for TranslationDomain in
kconfig_compiler_kf5, or we can remove it from the the KI18n
programmer's guide?


By the way, Okteta already uses this field, likely because it's in the docs:
  
kasten/controllers/view/bytetable/bytetableviewsettings.kcfgc:TranslationDomain=liboktetakasten
  
kasten/controllers/view/info/infoviewsettings.kcfgc:TranslationDomain=liboktetakasten
  
kasten/controllers/view/structures/settings/structviewpreferences.kcfgc:TranslationDomain=liboktetakasten

-- 
Alexander Potashev
___
Kde-frameworks-devel mailing list
Kde-frameworks-devel@kde.org
https://mail.kde.org/mailman/listinfo/kde-frameworks-devel


Re: Review Request 123850: Fix entities with wrong links

2015-05-21 Thread Burkhard Lück

---
This is an automatically generated e-mail. To reply, visit:
https://git.reviewboard.kde.org/r/123850/
---

(Updated May 21, 2015, 11:54 a.m.)


Status
--

This change has been marked as submitted.


Review request for Documentation, KDE Frameworks and Luigi Toscano.


Changes
---

Submitted with commit 7957a1c24490e3d42f21983c0d237a3f208faabe by Burkhard Lück 
to branch master.


Repository: kdoctools


Description
---

* replace link in install-compile.docbook to page with kde4 specific 
instructions with link to main page of techbase
  following the old link to techbase.kde.org/Getting_Started the user is 
greeted with 
  "These build instructions are outdated as of 2012..." and all infos on that 
page are about kde4, not about kf5.
  (we need a page on techbase with instructions how to build kf5 applications)

* install-intro.docbook
  remove usage of entity &package; kde does only release single application 
tarballs (with a few exceptions like calligra, kdepim, kdewebdev)
  &kde-ftp; and &FTP; are gone you can get source tarballs afaik only via 
download.kde.org

The target audience of the application docbooks are users installing packages 
from distribution; not users building from sources.
Therefore we should remove the appendix "installation" using the entities 
install-compile.docbook and install-intro.docbook in kf5 application handbooks
and remove these entities in KF 6

The obsolete ftp link in install-intro.docbook is a bug and should be fixed in 
master/kdelibs and stable/kdelibs and stable/kdoctools kf5 as well


Diffs
-

  src/customization/en/entities/install-compile.docbook 855b0de 
  src/customization/en/entities/install-intro.docbook 3f6f5ed 

Diff: https://git.reviewboard.kde.org/r/123850/diff/


Testing
---


Thanks,

Burkhard Lück

___
Kde-frameworks-devel mailing list
Kde-frameworks-devel@kde.org
https://mail.kde.org/mailman/listinfo/kde-frameworks-devel


Re: Review Request 123857: Fix crash after a user has launched kbuildsycoca as root.

2015-05-21 Thread David Edmundson

---
This is an automatically generated e-mail. To reply, visit:
https://git.reviewboard.kde.org/r/123857/
---

(Updated May 21, 2015, 11:36 a.m.)


Review request for KDE Frameworks.


Repository: kservice


Description
---

3 commits fixing; a crash, what caused the crash, and why we weren't auto 
recovering from it.

QFile::open() will return a Read/Write error on failed access,
PermissionsError is only in the result of a setPermissions call.

CCBUG: 342438

If running as root, keep file ownership the same as the original file we're 
replacing.

$HOME is often preserved as root, making us write cache files in the
user's home directory. 

CCBUG: 342438

Guard against being unable to open stream

This can happen if we are unable to open the database when a
notifyDatabaseChanged signal is emitted.
Other places guard also against this eventuality.

BUG: 342438


Diffs (updated)
-

  src/kbuildsycoca/kbuildsycoca.cpp d14f1f950cdb0d8c9fefbce2a4740f211d3d97a1 
  src/services/kservicegroupfactory.cpp 
8cfc6c6670d3b87e8ed6bdfe4aeac947846afc18 

Diff: https://git.reviewboard.kde.org/r/123857/diff/


Testing
---


Thanks,

David Edmundson

___
Kde-frameworks-devel mailing list
Kde-frameworks-devel@kde.org
https://mail.kde.org/mailman/listinfo/kde-frameworks-devel


Re: Review Request 123735: version of QmlObject with a static engine

2015-05-21 Thread Marco Martin

---
This is an automatically generated e-mail. To reply, visit:
https://git.reviewboard.kde.org/r/123735/
---

(Updated May 21, 2015, 10:52 a.m.)


Review request for KDE Frameworks and Plasma.


Changes
---

added a test taken from QQuickView one

make sure the behavior passes the tests


Repository: kdeclarative


Description
---

to make easier doing applications like plasma that use a lot of qml to have a 
single engine make a subclass of QmlObject called QmlObjectSharedEngine that 
has a single, static QQmlEngine

Adds a class called QuickViewSharedEngine that has the same behavior as 
QmlObjectSharedEngine(using it): static QQmlEngine, separed rootContexts() for 
each instance.
This is used by desktopviews and panelviews to share their engine.

Unfortunately it may not be possible to get the applet configuration dialogs to 
use this, since they still need a separed engine in order to have a different 
controls style (qstyle based) than the stuff in the desktop/panel


Diffs (updated)
-

  autotests/CMakeLists.txt adc1102 
  autotests/quickviewsharedengine.cpp PRE-CREATION 
  autotests/util.h PRE-CREATION 
  autotests/util.cpp PRE-CREATION 
  src/kdeclarative/CMakeLists.txt d73bff0 
  src/kdeclarative/kdeclarative.cpp b3906e2 
  src/kdeclarative/qmlobject.h f26b67d 
  src/kdeclarative/qmlobject.cpp c483665 
  src/kdeclarative/qmlobjectsharedengine.h PRE-CREATION 
  src/kdeclarative/qmlobjectsharedengine.cpp PRE-CREATION 
  src/quickaddons/CMakeLists.txt 777d07c 
  src/quickaddons/quickviewsharedengine.h PRE-CREATION 
  src/quickaddons/quickviewsharedengine.cpp PRE-CREATION 

Diff: https://git.reviewboard.kde.org/r/123735/diff/


Testing
---


Thanks,

Marco Martin

___
Kde-frameworks-devel mailing list
Kde-frameworks-devel@kde.org
https://mail.kde.org/mailman/listinfo/kde-frameworks-devel


Re: Review Request 123867: Fix build on OSX clang and replace another abs with std::abs

2015-05-21 Thread Bhushan Shah


> On May 21, 2015, 1:31 p.m., Milian Wolff wrote:
> > src/klocalizedstring.cpp, line 23
> > 
> >
> > shouldn't this be
> > 
> > #include 
> 
> Bhushan Shah wrote:
> ah yeah.

meh; didn't fix it..


- Bhushan


---
This is an automatically generated e-mail. To reply, visit:
https://git.reviewboard.kde.org/r/123867/#review80680
---


On May 21, 2015, 1:49 p.m., Bhushan Shah wrote:
> 
> ---
> This is an automatically generated e-mail. To reply, visit:
> https://git.reviewboard.kde.org/r/123867/
> ---
> 
> (Updated May 21, 2015, 1:49 p.m.)
> 
> 
> Review request for KDE Frameworks, Marko Käning, Milian Wolff, and Scarlett 
> Clark.
> 
> 
> Repository: ki18n
> 
> 
> Description
> ---
> 
> https://build.kde.org/job/ki18n%20master%20kf5-qt5/PLATFORM=OSX,compiler=clang/1/console
> 
> Follow up to,
> 
> commit 8d392e523e4556f9e434f3e02890fcacfcb492e4
> Author: Milian Wolff 
> Date:   Mon May 18 10:52:29 2015 +0200
> 
> Fix compiler warning about potential truncation.
> 
> klocalizedstring.cpp:1126:46: warning: absolute value function 'abs'
> given an argument of type 'long' but has parameter of type 'int'
> which may cause truncation of value
> 
> kls.d->number = static_cast(abs(a));
>  ^
> klocalizedstring.cpp:1126:46: note: use function 'std::abs' instead
> 
> 
> Diffs
> -
> 
>   src/klocalizedstring.cpp 910f44d 
> 
> Diff: https://git.reviewboard.kde.org/r/123867/diff/
> 
> 
> Testing
> ---
> 
> 
> Thanks,
> 
> Bhushan Shah
> 
>

___
Kde-frameworks-devel mailing list
Kde-frameworks-devel@kde.org
https://mail.kde.org/mailman/listinfo/kde-frameworks-devel


Re: Review Request 123867: Fix build on OSX clang and replace another abs with std::abs

2015-05-21 Thread Bhushan Shah

---
This is an automatically generated e-mail. To reply, visit:
https://git.reviewboard.kde.org/r/123867/
---

(Updated May 21, 2015, 8:19 a.m.)


Status
--

This change has been marked as submitted.


Review request for KDE Frameworks, Marko Käning, Milian Wolff, and Scarlett 
Clark.


Changes
---

Submitted with commit b0ad9db8235e7ed644c239245c897a643515d278 by Bhushan Shah 
to branch master.


Repository: ki18n


Description
---

https://build.kde.org/job/ki18n%20master%20kf5-qt5/PLATFORM=OSX,compiler=clang/1/console

Follow up to,

commit 8d392e523e4556f9e434f3e02890fcacfcb492e4
Author: Milian Wolff 
Date:   Mon May 18 10:52:29 2015 +0200

Fix compiler warning about potential truncation.

klocalizedstring.cpp:1126:46: warning: absolute value function 'abs'
given an argument of type 'long' but has parameter of type 'int'
which may cause truncation of value

kls.d->number = static_cast(abs(a));
 ^
klocalizedstring.cpp:1126:46: note: use function 'std::abs' instead


Diffs
-

  src/klocalizedstring.cpp 910f44d 

Diff: https://git.reviewboard.kde.org/r/123867/diff/


Testing
---


Thanks,

Bhushan Shah

___
Kde-frameworks-devel mailing list
Kde-frameworks-devel@kde.org
https://mail.kde.org/mailman/listinfo/kde-frameworks-devel


Re: Review Request 123867: Fix build on OSX clang and replace another abs with std::abs

2015-05-21 Thread Bhushan Shah


> On May 21, 2015, 1:31 p.m., Milian Wolff wrote:
> > src/klocalizedstring.cpp, line 23
> > 
> >
> > shouldn't this be
> > 
> > #include 

ah yeah.


- Bhushan


---
This is an automatically generated e-mail. To reply, visit:
https://git.reviewboard.kde.org/r/123867/#review80680
---


On May 21, 2015, 11:20 a.m., Bhushan Shah wrote:
> 
> ---
> This is an automatically generated e-mail. To reply, visit:
> https://git.reviewboard.kde.org/r/123867/
> ---
> 
> (Updated May 21, 2015, 11:20 a.m.)
> 
> 
> Review request for KDE Frameworks, Marko Käning, Milian Wolff, and Scarlett 
> Clark.
> 
> 
> Repository: ki18n
> 
> 
> Description
> ---
> 
> https://build.kde.org/job/ki18n%20master%20kf5-qt5/PLATFORM=OSX,compiler=clang/1/console
> 
> Follow up to,
> 
> commit 8d392e523e4556f9e434f3e02890fcacfcb492e4
> Author: Milian Wolff 
> Date:   Mon May 18 10:52:29 2015 +0200
> 
> Fix compiler warning about potential truncation.
> 
> klocalizedstring.cpp:1126:46: warning: absolute value function 'abs'
> given an argument of type 'long' but has parameter of type 'int'
> which may cause truncation of value
> 
> kls.d->number = static_cast(abs(a));
>  ^
> klocalizedstring.cpp:1126:46: note: use function 'std::abs' instead
> 
> 
> Diffs
> -
> 
>   src/klocalizedstring.cpp 910f44d 
> 
> Diff: https://git.reviewboard.kde.org/r/123867/diff/
> 
> 
> Testing
> ---
> 
> 
> Thanks,
> 
> Bhushan Shah
> 
>

___
Kde-frameworks-devel mailing list
Kde-frameworks-devel@kde.org
https://mail.kde.org/mailman/listinfo/kde-frameworks-devel


Re: Review Request 123867: Fix build on OSX clang and replace another abs with std::abs

2015-05-21 Thread Milian Wolff

---
This is an automatically generated e-mail. To reply, visit:
https://git.reviewboard.kde.org/r/123867/#review80680
---

Ship it!


Ship It!


src/klocalizedstring.cpp (line 23)


shouldn't this be

#include 


- Milian Wolff


On May 21, 2015, 5:50 a.m., Bhushan Shah wrote:
> 
> ---
> This is an automatically generated e-mail. To reply, visit:
> https://git.reviewboard.kde.org/r/123867/
> ---
> 
> (Updated May 21, 2015, 5:50 a.m.)
> 
> 
> Review request for KDE Frameworks, Marko Käning, Milian Wolff, and Scarlett 
> Clark.
> 
> 
> Repository: ki18n
> 
> 
> Description
> ---
> 
> https://build.kde.org/job/ki18n%20master%20kf5-qt5/PLATFORM=OSX,compiler=clang/1/console
> 
> Follow up to,
> 
> commit 8d392e523e4556f9e434f3e02890fcacfcb492e4
> Author: Milian Wolff 
> Date:   Mon May 18 10:52:29 2015 +0200
> 
> Fix compiler warning about potential truncation.
> 
> klocalizedstring.cpp:1126:46: warning: absolute value function 'abs'
> given an argument of type 'long' but has parameter of type 'int'
> which may cause truncation of value
> 
> kls.d->number = static_cast(abs(a));
>  ^
> klocalizedstring.cpp:1126:46: note: use function 'std::abs' instead
> 
> 
> Diffs
> -
> 
>   src/klocalizedstring.cpp 910f44d 
> 
> Diff: https://git.reviewboard.kde.org/r/123867/diff/
> 
> 
> Testing
> ---
> 
> 
> Thanks,
> 
> Bhushan Shah
> 
>

___
Kde-frameworks-devel mailing list
Kde-frameworks-devel@kde.org
https://mail.kde.org/mailman/listinfo/kde-frameworks-devel