Change in module naming conventions

2002-08-27 Thread Per Einar Ellefsen

Hi everyone,

This has already been posted on the dev list, but with no replies (however 
previous feedback has been positive to this regard), so I'll pass it 
through here for some feedback before going on with it.

To find out how the new namespaces would look, I have gone through the 
process of categorizing all mod_perl modules found on CPAN (by searching 
for the Apache:: prefix).

What I came to was this:
http://users.skynet.be/pereinar/mod-perl/modules.txt

NOTE: I am *not* suggesting we rename all existing Apache:: modules, that 
issue has been raised many times before, and is clearly impractical. This 
list is only to get an idea of what categories could possibly be needed. 
Think of it as a way of wrapping my mind around what is already here.

 From this, and some comments from other people, I have come to a set of 
Module naming guidelines, which I just placed online for your perusal: see 
here:
http://users.skynet.be/pereinar/mod-perl/products/apache-modules.html#Module_Naming_Conventions

Some questions I got which I'm not too sure of:
- I created the Apache::Util:: namespace. However, one person thought the 
Persistent:: namespace to be too specific, and would prefer to rename 
Apache::Util:: to something like ::Misc, ::Lib, ::Extensions or ::Addons, 
and add the Persistent:: modules there. What do you think?
- I originally had Apache::Auth::Authen, ::Authz and ::Access, but Robin 
Berjon told me he preferred to have the 4 as top-level namespaces. What do 
people think?


-- 
Per Einar Ellefsen
[EMAIL PROTECTED]





Re: Change in module naming conventions

2002-08-27 Thread David Wheeler

On Tuesday, August 27, 2002, at 09:29  AM, Per Einar Ellefsen wrote:

 - I created the Apache::Util:: namespace. However, one person thought 
 the Persistent:: namespace to be too specific, and would prefer to 
 rename Apache::Util:: to something like ::Misc, ::Lib, ::Extensions or 
 ::Addons, and add the Persistent:: modules there. What do you think?

I like Apache::Util, and don't have a problem with 
Apache::Util::Persistent. Makes sense to me.

 - I originally had Apache::Auth::Authen, ::Authz and ::Access, but 
 Robin Berjon told me he preferred to have the 4 as top-level 
 namespaces. What do people think?

I agree with Robin.

David

-- 
David Wheeler AIM: dwTheory
[EMAIL PROTECTED] ICQ: 15726394
http://david.wheeler.net/  Yahoo!: dew7e
Jabber: [EMAIL PROTECTED]




Re: Change in module naming conventions

2002-08-27 Thread Per Einar Ellefsen

At 18:38 27.08.2002, David Wheeler wrote:
On Tuesday, August 27, 2002, at 09:29  AM, Per Einar Ellefsen wrote:

- I created the Apache::Util:: namespace. However, one person thought the 
Persistent:: namespace to be too specific, and would prefer to rename 
Apache::Util:: to something like ::Misc, ::Lib, ::Extensions or ::Addons, 
and add the Persistent:: modules there. What do you think?

I like Apache::Util, and don't have a problem with 
Apache::Util::Persistent. Makes sense to me.

It's actually Apache::Persistent, because the persistence modules in it 
have big differences from the Apache::Util modules.


-- 
Per Einar Ellefsen
[EMAIL PROTECTED]





Re: Change in module naming conventions

2002-08-27 Thread David Wheeler

On Tuesday, August 27, 2002, at 09:46  AM, Per Einar Ellefsen wrote:

 It's actually Apache::Persistent, because the persistence modules in 
 it have big differences from the Apache::Util modules.

Oh. So what's the complaint about Apache::Util:: ?

David

-- 
David Wheeler AIM: dwTheory
[EMAIL PROTECTED] ICQ: 15726394
http://david.wheeler.net/  Yahoo!: dew7e
Jabber: [EMAIL PROTECTED]




Re: Change in module naming conventions

2002-08-27 Thread Nick Tonkin



- nick

   
Nick Tonkin   {|8^)


On Tue, 27 Aug 2002, Per Einar Ellefsen wrote:

 - I originally had Apache::Auth::Authen, ::Authz and ::Access, but Robin 
 Berjon told me he preferred to have the 4 as top-level namespaces. What do 
 people think?

I'm in favor of your approach. I have it like that in my
stuff. Auth::Auth, Auth::Authz, and Auth:: Access.

- nick


Nick Tonkin   {|8^)










Re: Change in module naming conventions

2002-08-27 Thread Per Einar Ellefsen

At 18:59 27.08.2002, David Wheeler wrote:
On Tuesday, August 27, 2002, at 09:46  AM, Per Einar Ellefsen wrote:

It's actually Apache::Persistent, because the persistence modules in it 
have big differences from the Apache::Util modules.

Oh. So what's the complaint about Apache::Util:: ?

Not having the Persistent:: modules in it. And if it would have them in it, 
Apache::Util wouldn't necessarily be a correct name. But I think we'll keep 
Apache::Persistent and Apache::Util as is.


-- 
Per Einar Ellefsen
[EMAIL PROTECTED]





Re: Change in module naming conventions

2002-08-27 Thread James G Smith

Per Einar Ellefsen [EMAIL PROTECTED] wrote:
What I came to was this:
http://users.skynet.be/pereinar/mod-perl/modules.txt

Looks good, overall.

I like the Apache::Framework:: namespace :)

Some questions I got which I'm not too sure of:
- I originally had Apache::Auth::Authen, ::Authz and ::Access, but Robin 
Berjon told me he preferred to have the 4 as top-level namespaces. What do 
people think?

What's the difference between Apache::Auth and Apache::Authen ?  They
both seem to have authentication handlers.
-- 
James Smith [EMAIL PROTECTED], 979-862-3725
Texas AM CIS Operating Systems Group, Unix



Re: Change in module naming conventions

2002-08-27 Thread Per Einar Ellefsen

At 20:14 27.08.2002, James G Smith wrote:
Per Einar Ellefsen [EMAIL PROTECTED] wrote:
 What I came to was this:
 http://users.skynet.be/pereinar/mod-perl/modules.txt

Looks good, overall.

I like the Apache::Framework:: namespace :)

same; just shows how many there are.

 Some questions I got which I'm not too sure of:
 - I originally had Apache::Auth::Authen, ::Authz and ::Access, but Robin
 Berjon told me he preferred to have the 4 as top-level namespaces. What do
 people think?

What's the difference between Apache::Auth and Apache::Authen ?  They
both seem to have authentication handlers.

There are modules that do Authen+Authz,  and some that incorporate general 
functions related to authentication and authorization. These go into 
::Auth. The Authentication handlers go into Authen, as well as other 
modules *only* related to _authentication_.


-- 
Per Einar Ellefsen
[EMAIL PROTECTED]





Re: Change in module naming conventions

2002-08-27 Thread Stas Bekman

Nick Tonkin wrote:
 
 - nick
 
    
 Nick Tonkin   {|8^)
 
 
 On Tue, 27 Aug 2002, Per Einar Ellefsen wrote:
 
 
- I originally had Apache::Auth::Authen, ::Authz and ::Access, but Robin 
Berjon told me he preferred to have the 4 as top-level namespaces. What do 
people think?
 
 
 I'm in favor of your approach. I have it like that in my
 stuff. Auth::Auth, Auth::Authz, and Auth:: Access.

But Authentication, Authorization and Access aren't all Auth. May be 
using Apache::AAA:: as in httpd-2.0/modules/aaa/ ?



__
Stas BekmanJAm_pH -- Just Another mod_perl Hacker
http://stason.org/ mod_perl Guide --- http://perl.apache.org
mailto:[EMAIL PROTECTED] http://use.perl.org http://apacheweek.com
http://modperlbook.org http://apache.org   http://ticketmaster.com




Re: Change in module naming conventions

2002-08-27 Thread Iain Truskett

* Stas Bekman ([EMAIL PROTECTED]) [28 Aug 2002 12:54]:
 Nick Tonkin wrote:

[...]
  I'm in favor of your approach. I have it like that in my stuff.
  Auth::Auth, Auth::Authz, and Auth:: Access.

 But Authentication, Authorization and Access aren't all Auth. May be
 using Apache::AAA:: as in httpd-2.0/modules/aaa/ ?

I'd have to favour them being in a second-level namespace rather than a
top-level one. If they provide Apache related handlers, the Apache
handler modules should be in Apache:: (or ModPerl::, Apache2::
whatever; I'm going to have to look up the new naming convention there).

Generic authentication stuff should probably belong in the namespace of
the appropriate protocol. (e.g. Net::LDAP::Authenticate, used by
Apache::AAA::NetLDAP).

But Apache specific stuff should be in an Apache related namespace.

(of course, now you'll all say that the 'toplevel' thing mentioned
previously was relative to Apache::. Hrm.)

cheers,
-- 
Iain.



Re: Change in module naming conventions

2002-08-27 Thread John Siracusa

On Tuesday, August 27, 2002, at 10:54  PM, Stas Bekman wrote:
 But Authentication, Authorization and Access aren't all Auth. May be 
 using Apache::AAA:: as in httpd-2.0/modules/aaa/ ?

Please, no more too-clever TLAs.  Have we learned nothing from LWP? :)

-John