[openwisp] Floor plan

2023-10-25 Thread J H
Hi

Is it possible to see all APs at once in floor plans ?

(feature request?)

-- 
You received this message because you are subscribed to the Google Groups 
"OpenWISP" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to openwisp+unsubscr...@googlegroups.com.
To view this discussion on the web, visit 
https://groups.google.com/d/msgid/openwisp/b5b3c8b3-357c-4349-88f1-c47d720bb036n%40googlegroups.com.


[openwisp] Re: Reproduce OpenWRT Luci config through OpenWISP templates

2023-08-30 Thread J H
Hi

had a similar problem because i wanted 22.x w/ DSA and other options.

that's why i made a new template/object :

raw json file:

{
"wireless": [
{
"config_name": "wifi-iface",
"config_value": "internet",
"wpa_disable_eapol_key_retries": "0",
"time_advertisement": "2",
"time_zone": "CET-1CEST,M3.5.0,M10.5.0/3",
"bss_transition": "1",
"ieee80211k": "1",
"ft_over_ds": "1"
},
...

or
{
"wireless": [
{
"config_name": "wifi-device",
"config_value": "radio1",
"channels": "1-2 5-6 9-10 13"
},

and now i apply these. just check `uci show` output and write your own 
options.
On Monday, 7 August 2023 at 11:49:32 UTC+2 tech...@gmail.com wrote:

> Hello,
>
> We are currently testing OpenWISP with an AP or PC (OpenWRT OpenWrt 
> 22.03.5) with a single ethernet port and a wifi card
>
> This AP must (at least) broadcast 1 WIFI SSID egg :
>
> SSID 1 : TEST_GUEST 
>
> This SSID is binded to a specific VLAN, egg : 
>
> SSID : TEST_GUEST - VLAN 10 
>
> Let say that main network interface for AP is eth0.
>
> We can achieve this through Luci by creating in this order :  
>
> - VLAN 802.1q device :
> - base device : eth0
> - VLAN ID : 10
> - Device Name : eth0.10
> - Bridge device : 
> - device name : brdev10
> - Bridge port : Software VLAN eth0.10
> - New interface : 
> - name : if_brdev10
> - protocol : unmanaged
> - device : Bridge : brdev10
> - New wireless interface :
> - mode Access point:
> - ESSID : TEST_GUEST
> - Network : if_brdev10
>
> But we do not figure out how to achieve this through OpenWISP templates. 
> Any help would be greatly appreciated.
>
> Regards.
>

-- 
You received this message because you are subscribed to the Google Groups 
"OpenWISP" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to openwisp+unsubscr...@googlegroups.com.
To view this discussion on the web, visit 
https://groups.google.com/d/msgid/openwisp/3db01a5e-0587-49ba-b4b0-349812cbe81dn%40googlegroups.com.


Re: [openwisp] Re: Working cfg in OWRT interface/bridgedevice/network, but error in OpenWisp deployment

2022-12-20 Thread J H
{
"radios": [
{
"protocol": "802.11ac",
"name": "radio0",
"channel": 0,
"channel_width": 20,
"country": "AT",
"disabled": false,
"driver": "mac80211",
"hwmode": "11a",
"channels": "96-136",
"cell_density": 1,
"rrm_neighbor_report": true,
"ieee80211k": true,
"rrm_beacon_report": true,
"time_advertisement": 2,
"time_zone": "CET-1CEST,M3.5.0,M10.5.0/3",
"wnm_sleep_mode": false,
"bss_transition": true,
"country_ie": true,
"beacon_int": 100
},
{
"protocol": "802.11n",
"name": "radio1",
"channel": 0,
"channel_width": 20,
"country": "AT",
"disabled": false,
"driver": "mac80211",
"hwmode": "11g",
"channels": "13 5 1 9",
"cell_density": 2,
"rrm_neighbor_report": true,
"ieee80211k": true,
"rrm_beacon_report": true,
"time_advertisement": 2,
"time_zone": "CET-1CEST,M3.5.0,M10.5.0/3",
"wnm_sleep_mode": false,
"bss_transition": true,
"country_ie": true,
"beacon_int": 200
}
],
"interfaces": [
{
"type": "bridge",
"bridge_members": [
"eth0.22"
],
"name": "br_iot",
"disabled": false,
"network": "lan_iot",
"autostart": true
},
{
"wireless": {
"network": [
"lan_iot"
],
"mode": "access_point",
"radio": "radio0",
"ack_distance": 0,
"rts_threshold": 0,
"frag_threshold": 0,
"ssid": "iot",
"hidden": false,
"wds": false,
"encryption": {
"protocol": "wpa2_personal",
"key": "",
"disabled": false,
"cipher": "ccmp",
"ieee80211w": "0",
"wpa_disable_eapol_key_retries": 0,
"wpa_group_rekey": 3600
},
"wmm": false,
"isolate": true,
"ieee80211r": true,
"reassociation_deadline": 2,
"ft_psk_generate_local": true,
"ft_over_ds": true,
"rsn_preauth": true,
"macfilter": "disable",
"maclist": [],
"mobility_domain": "",
"pmk_r1_push": true,
"dtim_period": 3
},
"type": "wireless",
"name": "iot5",
"mtu": 1500,
"disabled": false,
"network": "lan_iot",
"mac": "",
"autostart": true
},
{
"wireless": {
"network": [
"lan_iot"
],
"mode": "access_point",
"radio": "radio1",
"ack_distance": 0,
"rts_threshold": 0,
"frag_threshold": 0,
"ssid": "iot",
"hidden": false,
"wds": false,
"encryption": {
"protocol": "wpa2_personal",
"key": "",
    "disabled": false,
 

[openwisp] Re: Working cfg in OWRT interface/bridgedevice/network, but error in OpenWisp deployment

2022-12-20 Thread J H
Ignore the   "list ports '*eth0.22*'  " typo.   VLAN id is not relevant 
here - bridge and device work on eth, just not when i want to add wifi to 
it.

On Tuesday, 20 December 2022 at 09:40:24 UTC+1 J H wrote:

> hi
>
> On OWRT 21.x / 22.x I already have a working cfg, but i wanted to deploy 
> it via latest OpenWisp
>
> radio0 (5Ghz) and radio1 (2Ghz) with same SSid and bound to same network 
> and bridge vlan 10 on eth0:
>
> config device 'device5'
> option bridge_empty '1'
> option name '*br-iot*'
> list ports '*eth0.10*'
> option type '*bridge*'
>
> config wifi-iface 'wifinet9'
> option device '*radio0*'
> option mode 'ap'
> option network '*lan_iot*'
> option disabled '0'
> option ssid 'iot'
>
> config wifi-iface 'wifinet10'
> option device '*radio1*'
> option mode 'ap'
> option network '*lan_iot*'
> option disabled '0'
> option ssid 'iot'
>
> config interface '*lan_iot*'
> option proto 'none'
> option device '*br-iot*'
>
>
> When i try to this this via OpenWisp i get this config which does not work:
>
> config device 'device_lan_iot'
> option name '*br_iot*'
> list ports '*eth0.22*'
> option type 'bridge'
>
> config interface 'lan_iot'
> option auto '1'
> option bridge_empty '1'
> option device '*br_iot*'
> option enabled '1'
> option proto 'none'
>
> config device 'device_lan_iot'
> option mtu '1500'
> option name '*iot5*'
>
> config interface 'lan_iot'
> option auto '1'
> option device '*iot5*'
> option enabled '1'
> option proto 'none'
>
> config device 'device_lan_iot'
> option mtu '1500'
> option name '*iot2*'
>
> config interface 'lan_iot'
> option auto '1'
> option device '*iot2*'
> option enabled '1'
> option proto 'none'
>
> package wireless
>
> config wifi-device 'radio0'
> option disabled '0'
>
> config wifi-device 'radio1'
> option disabled '0'
>
> config wifi-iface 'wifi_iot5'
> option device 'radio0'
> option disabled '0'
> *option ifname 'iot5'*
> option mode 'ap'
> option network '*lan_iot*'
> option ssid 'iot'
>
> config wifi-iface 'wifi_iot2'
> option device 'radio1'
> option disabled '0'
> 
> *option ifname 'iot2'*option mode 'ap'
> option network '*lan_iot*'
> option ssid 'iot'
>
>
> Why are ifname used and devices built that are not used ? If i add iot2 or 
> iot5 interfaces as bridge members then deployment also fails. 
> Is it possible to built a cfg w/o ifnames and those interfaces ? Because 
> that config works - just use network in wifi-ifaces.
>
> thank you
>
>
>

-- 
You received this message because you are subscribed to the Google Groups 
"OpenWISP" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to openwisp+unsubscr...@googlegroups.com.
To view this discussion on the web, visit 
https://groups.google.com/d/msgid/openwisp/f9c4d66c-2ab4-40f6-9e4a-c1353fde7da7n%40googlegroups.com.


[openwisp] Working cfg in OWRT interface/bridgedevice/network, but error in OpenWisp deployment

2022-12-20 Thread J H
hi

On OWRT 21.x / 22.x I already have a working cfg, but i wanted to deploy it 
via latest OpenWisp

radio0 (5Ghz) and radio1 (2Ghz) with same SSid and bound to same network 
and bridge vlan 10 on eth0:

config device 'device5'
option bridge_empty '1'
option name '*br-iot*'
list ports '*eth0.10*'
option type '*bridge*'

config wifi-iface 'wifinet9'
option device '*radio0*'
option mode 'ap'
option network '*lan_iot*'
option disabled '0'
option ssid 'iot'

config wifi-iface 'wifinet10'
option device '*radio1*'
option mode 'ap'
option network '*lan_iot*'
option disabled '0'
option ssid 'iot'

config interface '*lan_iot*'
option proto 'none'
option device '*br-iot*'


When i try to this this via OpenWisp i get this config which does not work:

config device 'device_lan_iot'
option name '*br_iot*'
list ports '*eth0.22*'
option type 'bridge'

config interface 'lan_iot'
option auto '1'
option bridge_empty '1'
option device '*br_iot*'
option enabled '1'
option proto 'none'

config device 'device_lan_iot'
option mtu '1500'
option name '*iot5*'

config interface 'lan_iot'
option auto '1'
option device '*iot5*'
option enabled '1'
option proto 'none'

config device 'device_lan_iot'
option mtu '1500'
option name '*iot2*'

config interface 'lan_iot'
option auto '1'
option device '*iot2*'
option enabled '1'
option proto 'none'

package wireless

config wifi-device 'radio0'
option disabled '0'

config wifi-device 'radio1'
option disabled '0'

config wifi-iface 'wifi_iot5'
option device 'radio0'
option disabled '0'
*option ifname 'iot5'*
option mode 'ap'
option network '*lan_iot*'
option ssid 'iot'

config wifi-iface 'wifi_iot2'
option device 'radio1'
option disabled '0'

*option ifname 'iot2'*option mode 'ap'
option network '*lan_iot*'
option ssid 'iot'


Why are ifname used and devices built that are not used ? If i add iot2 or 
iot5 interfaces as bridge members then deployment also fails. 
Is it possible to built a cfg w/o ifnames and those interfaces ? Because 
that config works - just use network in wifi-ifaces.

thank you


-- 
You received this message because you are subscribed to the Google Groups 
"OpenWISP" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to openwisp+unsubscr...@googlegroups.com.
To view this discussion on the web, visit 
https://groups.google.com/d/msgid/openwisp/d4413e2d-5ca8-4811-9856-16b5c10354bdn%40googlegroups.com.


[openwisp] network deployment issue w/ openwisp

2022-12-20 Thread J H
hi

On OWRT 21.x / 22.x I already have a working cfg, but i wanted to deploy it 
via latest OpenWisp

radio0 (5Ghz) and radio1 (2Ghz) with same SSid and bound to same network 
and bridge vlan 10 on eth0:

config device 'device5'
option bridge_empty '1'
option name '*br-iot*'
list ports '*eth0.10*'
option type '*bridge*'

config wifi-iface 'wifinet9'
option device '*radio0*'
option mode 'ap'
option network '*lan_iot*'
option disabled '0'
option ssid 'nice_iot'

config wifi-iface 'wifinet10'
option device '*radio1*'
option mode 'ap'
option network '*lan_iot*'
option disabled '0'
option ssid 'nice_iot'

config interface '*lan_iot*'
option proto 'none'
option device '*br-iot*'


When i try to this this via OpenWisp i get this config which does not work:

config device 'device_lan_iot'
option name '*br_iot*'
list ports '*eth0.22*'
option type 'bridge'

config interface 'lan_iot'
option auto '1'
option bridge_empty '1'
option device '*br_iot*'
option enabled '1'
option proto 'none'

config device 'device_lan_iot'
option mtu '1500'
option name '*iot5*'

config interface 'lan_iot'
option auto '1'
option device '*iot5*'
option enabled '1'
option proto 'none'

config device 'device_lan_iot'
option mtu '1500'
option name '*iot2*'

config interface 'lan_iot'
option auto '1'
option device '*iot2*'
option enabled '1'
option proto 'none'

package wireless

config wifi-device 'radio0'
option disabled '0'

config wifi-device 'radio1'
option disabled '0'

config wifi-iface 'wifi_iot5'
option device 'radio0'
option disabled '0'
*option ifname 'iot5'*
option mode 'ap'
option network '*lan_iot*'
option ssid 'iot'

config wifi-iface 'wifi_iot2'
option device 'radio1'
option disabled '0'

*option ifname 'iot2'*option mode 'ap'
option network '*lan_iot*'
option ssid 'iot'


Why are ifname used and devices built that are not used ? If i add iot2 or 
iot5 interfaces as bridge members then deployment also fails. 
Is it possible to built a cfg w/o ifnames and those interfaces ? Because 
that config works - just use network in wifi-ifaces.

thank you



-- 
You received this message because you are subscribed to the Google Groups 
"OpenWISP" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to openwisp+unsubscr...@googlegroups.com.
To view this discussion on the web, visit 
https://groups.google.com/d/msgid/openwisp/e119c8f3-4fb1-43e1-9c7c-d8479f4b5717n%40googlegroups.com.