Re: Small patch modifying variable name to reflect the logic involved

2023-09-15 Thread Daniel Gustafsson
> On 14 Sep 2023, at 11:30, Daniel Gustafsson  wrote:
> 
>> On 14 Sep 2023, at 08:28, Krishnakumar R  wrote:
> 
>> Please find a small patch to improve code readability by modifying
>> variable name to reflect the logic involved - finding diff between end
>> and start time of WAL sync.
> 
> - INSTR_TIME_ACCUM_DIFF(PendingWalStats.wal_sync_time, duration, start);
> + INSTR_TIME_SET_CURRENT(end);
> + INSTR_TIME_ACCUM_DIFF(PendingWalStats.wal_sync_time, end, start);
> 
> Agreed, the duration is the result of the INSTR_TIME_ACCUM_DIFF calculation,
> not what's stored in the instr_time variable.

And done, with a small fixup to handle another occurrence in the same file.

--
Daniel Gustafsson





Re: Small patch modifying variable name to reflect the logic involved

2023-09-14 Thread Daniel Gustafsson
> On 14 Sep 2023, at 08:28, Krishnakumar R  wrote:

> Please find a small patch to improve code readability by modifying
> variable name to reflect the logic involved - finding diff between end
> and start time of WAL sync.

-   INSTR_TIME_ACCUM_DIFF(PendingWalStats.wal_sync_time, duration, start);
+   INSTR_TIME_SET_CURRENT(end);
+   INSTR_TIME_ACCUM_DIFF(PendingWalStats.wal_sync_time, end, start);

Agreed, the duration is the result of the INSTR_TIME_ACCUM_DIFF calculation,
not what's stored in the instr_time variable.

--
Daniel Gustafsson





Small patch modifying variable name to reflect the logic involved

2023-09-13 Thread Krishnakumar R
Hi All,

Please find a small patch to improve code readability by modifying
variable name to reflect the logic involved - finding diff between end
and start time of WAL sync.

--
Thanks and Regards,
Krishnakumar (KK)
[Microsoft]


v1-0001-Improve-code-readability-by-modifying-variable-na.patch
Description: Binary data