[Proto-Scripty] Re: Firefox & document.getElementById

2009-02-15 Thread RobG



On Feb 12, 1:03 am, "T.J. Crowder"  wrote:
> Hi,
>
> Details here:http://prototypejs.org/learn/extensions

The following statement in that  article is wrong:

"...native objects such as HTMLElement..."

HTMLElement is a *host* object, not a native object.


--
Rob
--~--~-~--~~~---~--~~
You received this message because you are subscribed to the Google Groups 
"Prototype & script.aculo.us" group.
To post to this group, send email to prototype-scriptaculous@googlegroups.com
To unsubscribe from this group, send email to 
prototype-scriptaculous+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/prototype-scriptaculous?hl=en
-~--~~~~--~~--~--~---



[Proto-Scripty] Re: Firefox & document.getElementById

2009-02-15 Thread T.J. Crowder

Hi,

Fair point, care to file a doc ticket on it in lighthouse?

-- T.J. :-)

On Feb 15, 10:51 am, RobG  wrote:
> On Feb 12, 1:03 am, "T.J. Crowder"  wrote:
>
> > Hi,
>
> > Details here:http://prototypejs.org/learn/extensions
>
> The following statement in that  article is wrong:
>
> "...native objects such as HTMLElement..."
>
> HTMLElement is a *host* object, not a native object.
>
> --
> Rob
--~--~-~--~~~---~--~~
You received this message because you are subscribed to the Google Groups 
"Prototype & script.aculo.us" group.
To post to this group, send email to prototype-scriptaculous@googlegroups.com
To unsubscribe from this group, send email to 
prototype-scriptaculous+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/prototype-scriptaculous?hl=en
-~--~~~~--~~--~--~---



[Proto-Scripty] Re: Move - OnMouseMove- Only once

2009-02-15 Thread timbob

The problem is that you are triggering a mousemove event _every_ time
you move the mouse within the , and every single time you create
a Move effect.
So when you leave the  there is a mouseout event and also the
mousemove event from your last mouse movement.

The flickering you see is the interference of the two created move
effects. Since script.aculo.us renders all ongoing effects "in
parallel", unless you specify otherwise.

As a workaround you could use an extra Event.Queue for your menu, and
limit the effects in the queue to only one at a time.
This is a bit dirty, but it works sort of. Of course you can mess
things up if you move your mouse very fast (depending on the effects
duration) in and out of the .

It maybe better to save the state of the "menue" somewhere and check
that before creating a new effect.


  



  document.observe("dom:loaded", function(ev) {
$('aeusseresmenue').observe('mouseover', function(ev) {
  new Effect.Move(this, {x:0, y:50, duration:0.2, mode:
"absolute", queue : {scope : 'myscope', limit : 1}});
});
$('aeusseresmenue').observe('mouseout', function(ev) {
  new Effect.Move(this,{x:-200, y:50, duration:0.2, mode:
"absolute", queue : {scope : 'myscope', limit : 1}});
});
  });

  
  

  
Hallo Welt
  

  


On 13 Feb., 17:20, Mario  wrote:
> Hi there,
>
> I'd like to move a  container which is mostly hidden left of the
> screen (width is 230px, left is -200px so you can only see the right
> border) into the screen and back by using the event handlers
> onmouseover and onmouseout.
>
> It works already but not perfect: By leaving the  box the
> container shortly flickers in the middle again for some mili seconds.
> Can anybody help me?
>
> 
>
>  onmousemove='new Effect.Move(this,{x:0, y:50, duration:0.2, mode:
> "absolute"});' onmouseout='new Effect.Move(this,{x:-200, y:50,
> duration:0.2, mode: "absolute"});'>
> 
> Hallo Welt
> 
> 
>
> 
>
> Thanks, Mario.
>
> PS: I already tried to use onmouseover instead of onmousemove, but
> then i had the problem of recalling the move in all the time.

--~--~-~--~~~---~--~~
You received this message because you are subscribed to the Google Groups 
"Prototype & script.aculo.us" group.
To post to this group, send email to prototype-scriptaculous@googlegroups.com
To unsubscribe from this group, send email to 
prototype-scriptaculous+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/prototype-scriptaculous?hl=en
-~--~~~~--~~--~--~---



[Proto-Scripty] Naming scheme: viewport.getScrollOffsets() vs. Element.cumlativeScrollOffset()

2009-02-15 Thread timbob

Hi,

i just stumbled over viewport.getScrollOffset_s_.
Is there a specific reason why this method uses the plural "Offsets",
since all of Element's methods use the singular "Offset" while
returning the same tuple of values.

For consistency i would prefer getScrollOffset, so i want to know if i
am missing a point there.

Regards,
timbob

--~--~-~--~~~---~--~~
You received this message because you are subscribed to the Google Groups 
"Prototype & script.aculo.us" group.
To post to this group, send email to prototype-scriptaculous@googlegroups.com
To unsubscribe from this group, send email to 
prototype-scriptaculous+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/prototype-scriptaculous?hl=en
-~--~~~~--~~--~--~---



[Proto-Scripty] Re: AJAX

2009-02-15 Thread Paul

Thanks for all your help with this, I really don't know what was
happening but changing the javascript files for new copies has fixed
it for some reason - thanks for the advice though - its certainly
prompted me to go and but exception handling in.
Paul

On Feb 12, 3:24 pm, disccomp  wrote:
> I usually respond with a JSON object that at least provides some debug
> info like:
>
> {msg:'panel_X removed from col1'}
> {msg:'panel_X inserted in col2, position Y'}
>
> or
>
> {msg:'panel_X moved to position Y'}
>
> On the client I pass the debug string to a logging function that I use
> to output all my debugging stuff to any javascript console available:
>
> con=function(action,output){try{if(typeof(window.console)!='undefined')
> { window.console[action](output); return true; }else{ return false; }}
> catch(e){}}
>
> (Example)
> onSuccess:function(data){
>   if(typeof(data.responseJSON)!='undefined' && data.responseJSON!=null)
> {
>     o = data.responseJSON;
>
>     if( typeof(o.msg)=='string' ){
>       con('info','Server: ' + o.msg); //Output the debug message
>       con('dir',o);                   //Dump the rest of the servers
> response
>     }
>   }
>
> }
--~--~-~--~~~---~--~~
You received this message because you are subscribed to the Google Groups 
"Prototype & script.aculo.us" group.
To post to this group, send email to prototype-scriptaculous@googlegroups.com
To unsubscribe from this group, send email to 
prototype-scriptaculous+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/prototype-scriptaculous?hl=en
-~--~~~~--~~--~--~---