[quagga-dev 16098] Re: round-8: tentative proposed head for master

2016-09-14 Thread Martin Winter

On 14 Sep 2016, at 0:44, Paul Jakma wrote:


On Tue, 13 Sep 2016, Martin Winter wrote:


Paul,

I’ve started it, but already found some BGP issues…

So somehow my CI testbed had a bug and when the basic setup of the 
BGP IPv6 tests failed (and caused all tests to skip),

then this was ignored (skipped instead of failed tests). Sorry :-(

This broke with the CI Pull Request #38 (and was fine up to and 
including #37)

https://github.com/opensourcerouting/quagga/pull/38

Should have been flagged as failed and not as good…



The issue (on IPv6 BGP):
“No supported  combination found in the received BGP4 
Open Message”



This works for plain IPv4 BGP, but fails for IPv6 sessions.


Weird. I don't see what in the 2 leak fixes of #38 could cause a 
problem. I doubt your test even hits the paths either one change (you 
don't go in and delete the peer in bgpd via the CLI interface do you? 
and you're not testing AFI_ETHER either and anyway that path only is 
hit when shutting down bgpd)?


Can you get the tcpdump?


Sure :-) PCAP is attached.

You’ll see my tester opening the BGP session first
and giving in the capabilities IPv6 Unicast. The OPEN in response from
Quagga is missing the IPv6/Unicast AFI/SAFI

Here is the relevant config from the Quagga Side:

Current configuration:
!
![...]
!
interface eth2
 ip address 192.168.1.101/24
 ipv6 address fc00:192:168:1::101/64
!
![...]
!
router bgp 500
 bgp router-id 192.168.1.101
 network 192.168.1.0/24
 neighbor fc00:192:168:1::1 remote-as 501
 neighbor fc00:192:168:1::1 ebgp-multihop 255
 neighbor fc00:192:168:1::1 timers 60 180
!
 address-family ipv6
 network fc00:192:168:1::/64
 neighbor fc00:192:168:1::1 activate
 exit-address-family
 exit
!
ip forwarding
ipv6 forwarding
!
line vty
!
end

Let me know if you need anything else. I’m working to fix my CI to 
correctly detect issues like these.


- Martin

BGP_Session.pcap
Description: Binary data
___
Quagga-dev mailing list
Quagga-dev@lists.quagga.net
https://lists.quagga.net/mailman/listinfo/quagga-dev

[quagga-dev 16097] Re: round-8: tentative proposed head for master

2016-09-14 Thread Paul Jakma

On Tue, 13 Sep 2016, Martin Winter wrote:


Paul,

I’ve started it, but already found some BGP issues…

So somehow my CI testbed had a bug and when the basic setup of the BGP IPv6 
tests failed (and caused all tests to skip),

then this was ignored (skipped instead of failed tests). Sorry :-(

This broke with the CI Pull Request #38 (and was fine up to and including 
#37)

https://github.com/opensourcerouting/quagga/pull/38

Should have been flagged as failed and not as good…



The issue (on IPv6 BGP):
“No supported  combination found in the received BGP4 Open 
Message”



This works for plain IPv4 BGP, but fails for IPv6 sessions.


Weird. I don't see what in the 2 leak fixes of #38 could cause a 
problem. I doubt your test even hits the paths either one change (you 
don't go in and delete the peer in bgpd via the CLI interface do you? 
and you're not testing AFI_ETHER either and anyway that path only is hit 
when shutting down bgpd)?


Can you get the tcpdump?

Additionally, for AS4 BGP sessions (IPv4 or IPv6), there is a collision issue 
which then closes the session:



(I thought you fixed this - did the fix only apply to 2-byte AS?)


No, generally. Collision window should be lower, and a possible bug in 
handling was fixed.


However, that doesn't mean a collision is impossible - it's just 
dependent on timing and can happen every now and then. The test needs to 
be prepared for a retry. Either the test itself should run again, or the 
wrapper around the test should try again if the fail was due to 
connection collision. ??



From the bgpd log for the collision:
2016/09/13 18:41:04 BGP: [Event] Make dummy peer structure until read Open 
packet
2016/09/13 18:41:04 BGP: 192.168.1.1 [FSM] TCP_connection_open 
(Active->OpenSent)

2016/09/13 18:41:04 BGP: 192.168.1.1 passive open
2016/09/13 18:41:04 BGP: 192.168.1.1 sending OPEN, version 4, my as 500, 
holdtime 180, id 192.168.1.101
2016/09/13 18:41:04 BGP: 192.168.1.1 send message type 1, length (incl. 
header) 51

2016/09/13 18:41:04 BGP: 192.168.1.1 went from Active to OpenSent
2016/09/13 18:41:04 BGP: 192.168.1.1 rcv message type 1, length (excl. 
header) 18
2016/09/13 18:41:04 BGP: 192.168.1.1 rcv OPEN, version 4, remote-as (in open) 
23456, holdtime 90, id 192.168.1.1, inbound connection
2016/09/13 18:41:04 BGP: 192.168.1.1 [AS4] rcv OPEN w/ OPTION parameter len: 
8, peeking for as4

2016/09/13 18:41:04 BGP: [AS4] found AS4 capability, about to parse
2016/09/13 18:41:04 BGP: 192.168.1.1 [AS4] about to set cap PEER_CAP_AS4_RCV, 
got as4 65538
2016/09/13 18:41:04 BGP: %NOTIFICATION: sent to neighbor 192.168.1.1 6/7 
(Cease/Connection collision resolution) 0 bytes
2016/09/13 18:41:04 BGP: 192.168.1.1 send message type 3, length (incl. 
header) 21

2016/09/13 18:41:04 BGP: Notification sent to neighbor 192.168.1.1: type 6/7


Let me know if you need help to reproduce the issues


Scratching my head on the first one..

regards,
--
Paul Jakma | p...@jakma.org | @pjakma | Key ID: 0xD86BF79464A2FF6A
Fortune:
Humor in the Court:
Q: (Showing man picture.) That's you?
A: Yes, sir.
Q: And you were present when the picture was taken, right?___
Quagga-dev mailing list
Quagga-dev@lists.quagga.net
https://lists.quagga.net/mailman/listinfo/quagga-dev