Re: Review Request 53351: Added 'ContainerClass' to help decide how best to launch a container.

2016-11-11 Thread Kevin Klues

---
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/53351/
---

(Updated Nov. 11, 2016, 11:17 p.m.)


Review request for mesos and Jie Yu.


Changes
---

Updated to reflect new "Depends On" dependency.


Bugs: MESOS-6464
https://issues.apache.org/jira/browse/MESOS-6464


Repository: mesos


Description
---

A 'ContainerClass' must now be passed to all *nested*
containerizer->launch() calls in order to specify the class of
container being launched. For now, we simply have the default nested
container class (called 'NESTED') in a subsequent commit we will
introduce the 'DEBUG' class to help classify debug-based nested
containers that should be launched slightly differently than default
nested containers.

The 'ContainerClass' specified is passed through to each isolator in
'ContainerConfig' so they have a chance to custiomize their isolation
policies based on the class as well.


Diffs (updated)
-

  include/mesos/slave/containerizer.proto 
f4c4ad771b5dead4ea3ee7cd1b4383c4dc2359b4 
  src/slave/containerizer/composing.hpp 
68c0523bb96e1078bd95c6094bce04c38c2fc9dd 
  src/slave/containerizer/composing.cpp 
0c5489f8dffaf75bce26a042000eaf7376f05ff4 
  src/slave/containerizer/containerizer.hpp 
7554446ac51a9063bd52b8b99845c73650740849 
  src/slave/containerizer/mesos/containerizer.hpp 
c4fea8b56c39d5a363f6ea80bd109fd2d3db52d9 
  src/slave/containerizer/mesos/containerizer.cpp 
44225ebf63d8dd93be9b60fff496c74dc6c3a5ad 
  src/tests/api_tests.cpp 57981f12d429614a537733ac4cec9c0e72ff6d6f 
  src/tests/containerizer.hpp 080b8fa695d4c0dd2ed2bf028f1fc617dad23943 
  src/tests/containerizer.cpp c3bcb85d245a0e95b377059802cd89617eb5e25c 

Diff: https://reviews.apache.org/r/53351/diff/


Testing
---

make -j check


Thanks,

Kevin Klues



Re: Review Request 53351: Added 'ContainerClass' to help decide how best to launch a container.

2016-11-10 Thread Kevin Klues

---
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/53351/
---

(Updated Nov. 10, 2016, 8:11 p.m.)


Review request for mesos and Jie Yu.


Changes
---

Updated to remove erroneous `using` directive.


Bugs: MESOS-6464
https://issues.apache.org/jira/browse/MESOS-6464


Repository: mesos


Description
---

A 'ContainerClass' must now be passed to all *nested*
containerizer->launch() calls in order to specify the class of
container being launched. For now, we simply have the default nested
container class (called 'NESTED') in a subsequent commit we will
introduce the 'DEBUG' class to help classify debug-based nested
containers that should be launched slightly differently than default
nested containers.

The 'ContainerClass' specified is passed through to each isolator in
'ContainerConfig' so they have a chance to custiomize their isolation
policies based on the class as well.


Diffs (updated)
-

  include/mesos/slave/containerizer.proto 
f4c4ad771b5dead4ea3ee7cd1b4383c4dc2359b4 
  src/slave/containerizer/composing.hpp 
68c0523bb96e1078bd95c6094bce04c38c2fc9dd 
  src/slave/containerizer/composing.cpp 
0c5489f8dffaf75bce26a042000eaf7376f05ff4 
  src/slave/containerizer/containerizer.hpp 
7554446ac51a9063bd52b8b99845c73650740849 
  src/slave/containerizer/mesos/containerizer.hpp 
c4fea8b56c39d5a363f6ea80bd109fd2d3db52d9 
  src/slave/containerizer/mesos/containerizer.cpp 
44225ebf63d8dd93be9b60fff496c74dc6c3a5ad 
  src/tests/api_tests.cpp 57981f12d429614a537733ac4cec9c0e72ff6d6f 
  src/tests/containerizer.hpp 080b8fa695d4c0dd2ed2bf028f1fc617dad23943 
  src/tests/containerizer.cpp c3bcb85d245a0e95b377059802cd89617eb5e25c 

Diff: https://reviews.apache.org/r/53351/diff/


Testing
---

make -j check


Thanks,

Kevin Klues



Re: Review Request 53351: Added 'ContainerClass' to help decide how best to launch a container.

2016-11-09 Thread Jie Yu

---
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/53351/#review155549
---


Ship it!




Ship It!

- Jie Yu


On Nov. 4, 2016, 9:32 p.m., Kevin Klues wrote:
> 
> ---
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/53351/
> ---
> 
> (Updated Nov. 4, 2016, 9:32 p.m.)
> 
> 
> Review request for mesos and Jie Yu.
> 
> 
> Bugs: MESOS-6464
> https://issues.apache.org/jira/browse/MESOS-6464
> 
> 
> Repository: mesos
> 
> 
> Description
> ---
> 
> A 'ContainerClass' must now be passed to all *nested*
> containerizer->launch() calls in order to specify the class of
> container being launched. For now, we simply have the default nested
> container class (called 'NESTED') in a subsequent commit we will
> introduce the 'DEBUG' class to help classify debug-based nested
> containers that should be launched slightly differently than default
> nested containers.
> 
> The 'ContainerClass' specified is passed through to each isolator in
> 'ContainerConfig' so they have a chance to custiomize their isolation
> policies based on the class as well.
> 
> 
> Diffs
> -
> 
>   include/mesos/slave/containerizer.proto 
> f4c4ad771b5dead4ea3ee7cd1b4383c4dc2359b4 
>   src/slave/containerizer/composing.hpp 
> 68c0523bb96e1078bd95c6094bce04c38c2fc9dd 
>   src/slave/containerizer/composing.cpp 
> 0c5489f8dffaf75bce26a042000eaf7376f05ff4 
>   src/slave/containerizer/containerizer.hpp 
> 7554446ac51a9063bd52b8b99845c73650740849 
>   src/slave/containerizer/mesos/containerizer.hpp 
> c4fea8b56c39d5a363f6ea80bd109fd2d3db52d9 
>   src/slave/containerizer/mesos/containerizer.cpp 
> 67cc595278f124cdf518d2f4fcfb257439f067e2 
>   src/slave/http.cpp a32aca437cffd52bc2bcde859eedddca2038e3f1 
>   src/tests/api_tests.cpp 57981f12d429614a537733ac4cec9c0e72ff6d6f 
>   src/tests/containerizer.hpp 080b8fa695d4c0dd2ed2bf028f1fc617dad23943 
>   src/tests/containerizer.cpp c3bcb85d245a0e95b377059802cd89617eb5e25c 
> 
> Diff: https://reviews.apache.org/r/53351/diff/
> 
> 
> Testing
> ---
> 
> make -j check
> 
> 
> Thanks,
> 
> Kevin Klues
> 
>



Re: Review Request 53351: Added 'ContainerClass' to help decide how best to launch a container.

2016-11-04 Thread Kevin Klues

---
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/53351/
---

(Updated Nov. 4, 2016, 9:32 p.m.)


Review request for mesos and Jie Yu.


Changes
---

Updated to address Jie's comments.


Bugs: MESOS-6464
https://issues.apache.org/jira/browse/MESOS-6464


Repository: mesos


Description
---

A 'ContainerClass' must now be passed to all *nested*
containerizer->launch() calls in order to specify the class of
container being launched. For now, we simply have the default nested
container class (called 'NESTED') in a subsequent commit we will
introduce the 'DEBUG' class to help classify debug-based nested
containers that should be launched slightly differently than default
nested containers.

The 'ContainerClass' specified is passed through to each isolator in
'ContainerConfig' so they have a chance to custiomize their isolation
policies based on the class as well.


Diffs (updated)
-

  include/mesos/slave/containerizer.proto 
f4c4ad771b5dead4ea3ee7cd1b4383c4dc2359b4 
  src/slave/containerizer/composing.hpp 
68c0523bb96e1078bd95c6094bce04c38c2fc9dd 
  src/slave/containerizer/composing.cpp 
0c5489f8dffaf75bce26a042000eaf7376f05ff4 
  src/slave/containerizer/containerizer.hpp 
7554446ac51a9063bd52b8b99845c73650740849 
  src/slave/containerizer/mesos/containerizer.hpp 
c4fea8b56c39d5a363f6ea80bd109fd2d3db52d9 
  src/slave/containerizer/mesos/containerizer.cpp 
67cc595278f124cdf518d2f4fcfb257439f067e2 
  src/slave/http.cpp a32aca437cffd52bc2bcde859eedddca2038e3f1 
  src/tests/api_tests.cpp 57981f12d429614a537733ac4cec9c0e72ff6d6f 
  src/tests/containerizer.hpp 080b8fa695d4c0dd2ed2bf028f1fc617dad23943 
  src/tests/containerizer.cpp c3bcb85d245a0e95b377059802cd89617eb5e25c 

Diff: https://reviews.apache.org/r/53351/diff/


Testing
---

make -j check


Thanks,

Kevin Klues



Re: Review Request 53351: Added 'ContainerClass' to help decide how best to launch a container.

2016-11-02 Thread Jie Yu

---
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/53351/#review154594
---




include/mesos/slave/containerizer.proto (line 32)


Nested is implied by the containerId. I would call it 'DEFAULT' in the 
sense that if someone does not specify a class explicitly, it'll be treated as 
DEFAULT.



src/slave/containerizer/composing.hpp (line 71)


Let's make this optional and default to None().
```
const Option& containerClass = None()
```


- Jie Yu


On Nov. 1, 2016, 10:28 p.m., Kevin Klues wrote:
> 
> ---
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/53351/
> ---
> 
> (Updated Nov. 1, 2016, 10:28 p.m.)
> 
> 
> Review request for mesos and Jie Yu.
> 
> 
> Bugs: MESOS-6464
> https://issues.apache.org/jira/browse/MESOS-6464
> 
> 
> Repository: mesos
> 
> 
> Description
> ---
> 
> A 'ContainerClass' must now be passed to all *nested*
> containerizer->launch() calls in order to specify the class of
> container being launched. For now, we simply have the default nested
> container class (called 'NESTED') in a subsequent commit we will
> introduce the 'DEBUG' class to help classify debug-based nested
> containers that should be launched slightly differently than default
> nested containers.
> 
> The 'ContainerClass' specified is passed through to each isolator in
> 'ContainerConfig' so they have a chance to custiomize their isolation
> policies based on the class as well.
> 
> 
> Diffs
> -
> 
>   include/mesos/slave/containerizer.proto 
> f4c4ad771b5dead4ea3ee7cd1b4383c4dc2359b4 
>   src/slave/containerizer/composing.hpp 
> 68c0523bb96e1078bd95c6094bce04c38c2fc9dd 
>   src/slave/containerizer/composing.cpp 
> 0c5489f8dffaf75bce26a042000eaf7376f05ff4 
>   src/slave/containerizer/containerizer.hpp 
> 7554446ac51a9063bd52b8b99845c73650740849 
>   src/slave/containerizer/mesos/containerizer.hpp 
> c4fea8b56c39d5a363f6ea80bd109fd2d3db52d9 
>   src/slave/containerizer/mesos/containerizer.cpp 
> 67cc595278f124cdf518d2f4fcfb257439f067e2 
>   src/slave/http.cpp a32aca437cffd52bc2bcde859eedddca2038e3f1 
>   src/tests/api_tests.cpp f87130d7554f98265ff6da39ea1d366839193e85 
>   src/tests/containerizer.hpp d418ecebee155f894187e24549f42497372d8a5f 
>   src/tests/containerizer.cpp c2208660352e5cf62cec5c7b92ec67fea62aea49 
>   src/tests/containerizer/nested_mesos_containerizer_tests.cpp 
> e6c690c411f57138207044f31b4816bd4090c1b7 
>   src/tests/containerizer/volume_image_isolator_tests.cpp 
> f14a0bd1c44c069c2784638132a08072a2343309 
>   src/tests/containerizer/volume_sandbox_path_isolator_tests.cpp 
> f873e288f72dbecc33b9c1c817688332c0eb3d31 
> 
> Diff: https://reviews.apache.org/r/53351/diff/
> 
> 
> Testing
> ---
> 
> make -j check
> 
> 
> Thanks,
> 
> Kevin Klues
> 
>



Review Request 53351: Added 'ContainerClass' to help decide how best to launch a container.

2016-11-01 Thread Kevin Klues

---
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/53351/
---

Review request for mesos and Jie Yu.


Bugs: MESOS-6464
https://issues.apache.org/jira/browse/MESOS-6464


Repository: mesos


Description
---

A 'ContainerClass' must now be passed to all *nested*
containerizer->launch() calls in order to specify the class of
container being launched. For now, we simply have the default nested
container class (called 'NESTED') in a subsequent commit we will
introduce the 'DEBUG' class to help classify debug-based nested
containers that should be launched slightly differently than default
nested containers.

The 'ContainerClass' specified is passed through to each isolator in
'ContainerConfig' so they have a chance to custiomize their isolation
policies based on the class as well.


Diffs
-

  include/mesos/slave/containerizer.proto 
f4c4ad771b5dead4ea3ee7cd1b4383c4dc2359b4 
  src/slave/containerizer/composing.hpp 
68c0523bb96e1078bd95c6094bce04c38c2fc9dd 
  src/slave/containerizer/composing.cpp 
0c5489f8dffaf75bce26a042000eaf7376f05ff4 
  src/slave/containerizer/containerizer.hpp 
7554446ac51a9063bd52b8b99845c73650740849 
  src/slave/containerizer/mesos/containerizer.hpp 
c4fea8b56c39d5a363f6ea80bd109fd2d3db52d9 
  src/slave/containerizer/mesos/containerizer.cpp 
67cc595278f124cdf518d2f4fcfb257439f067e2 
  src/slave/http.cpp a32aca437cffd52bc2bcde859eedddca2038e3f1 
  src/tests/api_tests.cpp f87130d7554f98265ff6da39ea1d366839193e85 
  src/tests/containerizer.hpp d418ecebee155f894187e24549f42497372d8a5f 
  src/tests/containerizer.cpp c2208660352e5cf62cec5c7b92ec67fea62aea49 
  src/tests/containerizer/nested_mesos_containerizer_tests.cpp 
e6c690c411f57138207044f31b4816bd4090c1b7 
  src/tests/containerizer/volume_image_isolator_tests.cpp 
f14a0bd1c44c069c2784638132a08072a2343309 
  src/tests/containerizer/volume_sandbox_path_isolator_tests.cpp 
f873e288f72dbecc33b9c1c817688332c0eb3d31 

Diff: https://reviews.apache.org/r/53351/diff/


Testing
---

make -j check


Thanks,

Kevin Klues