Re: [U-Boot] [PATCH 0/6] tegra2: Add more clock/pinmux functionality

2011-09-21 Thread Simon Glass
Hi Tom,

On Wed, Sep 21, 2011 at 1:43 PM, Tom Warren  wrote:
>> -Original Message-
>> From: Simon Glass [mailto:s...@chromium.org]
>> Sent: Thursday, September 08, 2011 3:12 PM
>> To: U-Boot Mailing List
>> Cc: Albert ARIBAUD; Tom Warren; Simon Glass
>> Subject: [PATCH 0/6] tegra2: Add more clock/pinmux functionality
>>
>> This adds to the basic clock functionality already available. The concept
>> of a peripheral ID is introduced, and all peripheral clock access is done
>> using this ID.
>>
>> Functions are provided to start, query and adjust peripheral clocks,
>> including automatic selection of the best available clock based on the
>> requested rate (this replaces hard-coded divisors).
>>
>> On the pinmux side we can now select functions for pin groups using the
>> new pinmux_set_func() function.
>>
>> Expanded functions are provided to adjust and query PLL clocks.
>>
>> With a full compliment of clock and pinmux functions, it should no longer
>> be necessary for board/driver code to directly access clock registers. This
>> change removes all such accesses.
>>
>> This functionality will be used for I2C, SPI, LCD, USB, keyboard, NAND and
>> other drivers for Tegra2.
>>
>> At then end is a patch to enable MMC on Seaboard, to make it all worthwhile.
>>
>> Note: These patches include a definition of assert() which I will happily
>> remove if the one sent upstream is accepted.
>>
>>
>> Simon Glass (6):
>>   tegra2: Rename CLOCK_PLL_ID to CLOCK_ID
>>   tegra2: Clean up board code a little
>>   tegra2: Add more clock functions
>>   tegra2: Rename PIN_ to PINGRP_
>>   tegra2: Add more pinmux functions
>>   tegra2: Enable MMC for Seaboard
>>
>>  arch/arm/cpu/armv7/tegra2/ap20.c           |    5 +-
>>  arch/arm/cpu/armv7/tegra2/clock.c          |  840
>> +++-
>>  arch/arm/cpu/armv7/tegra2/pinmux.c         |  540 ++-
>>  arch/arm/include/asm/arch-tegra2/clk_rst.h |   84 +--
>>  arch/arm/include/asm/arch-tegra2/clock.h   |  149 -
>>  arch/arm/include/asm/arch-tegra2/pinmux.h  |  444 ++-
>>  board/nvidia/common/board.c                |  243 +++--
>>  board/nvidia/common/board.h                |    4 +-
>>  board/nvidia/harmony/harmony.c             |   26 +
>>  board/nvidia/seaboard/seaboard.c           |   35 ++-
>>  drivers/mmc/tegra2_mmc.c                   |   94 +--
>>  drivers/mmc/tegra2_mmc.h                   |    1 +
>>  12 files changed, 1972 insertions(+), 493 deletions(-)
>>
>> --
>> 1.7.3.1
>
> This works fine on my Seaboard (T20-A03). My Harmony is put away, so I didn't 
> test on it.
>
> Tested-by: Tom Warren 

Thanks for testing it. I will remove the assert() now that it is in
U-Boot's common.h, and resend.

Regards,
Simon

>
> Thanks,
>
> Tom
>
> ---
> This email message is for the sole use of the intended recipient(s) and may 
> contain
> confidential information.  Any unauthorized review, use, disclosure or 
> distribution
> is prohibited.  If you are not the intended recipient, please contact the 
> sender by
> reply email and destroy all copies of the original message.
> ---
>
___
U-Boot mailing list
U-Boot@lists.denx.de
http://lists.denx.de/mailman/listinfo/u-boot


Re: [U-Boot] [PATCH 0/6] tegra2: Add more clock/pinmux functionality

2011-09-21 Thread Tom Warren
> -Original Message-
> From: Simon Glass [mailto:s...@chromium.org]
> Sent: Thursday, September 08, 2011 3:12 PM
> To: U-Boot Mailing List
> Cc: Albert ARIBAUD; Tom Warren; Simon Glass
> Subject: [PATCH 0/6] tegra2: Add more clock/pinmux functionality
> 
> This adds to the basic clock functionality already available. The concept
> of a peripheral ID is introduced, and all peripheral clock access is done
> using this ID.
> 
> Functions are provided to start, query and adjust peripheral clocks,
> including automatic selection of the best available clock based on the
> requested rate (this replaces hard-coded divisors).
> 
> On the pinmux side we can now select functions for pin groups using the
> new pinmux_set_func() function.
> 
> Expanded functions are provided to adjust and query PLL clocks.
> 
> With a full compliment of clock and pinmux functions, it should no longer
> be necessary for board/driver code to directly access clock registers. This
> change removes all such accesses.
> 
> This functionality will be used for I2C, SPI, LCD, USB, keyboard, NAND and
> other drivers for Tegra2.
> 
> At then end is a patch to enable MMC on Seaboard, to make it all worthwhile.
> 
> Note: These patches include a definition of assert() which I will happily
> remove if the one sent upstream is accepted.
> 
> 
> Simon Glass (6):
>   tegra2: Rename CLOCK_PLL_ID to CLOCK_ID
>   tegra2: Clean up board code a little
>   tegra2: Add more clock functions
>   tegra2: Rename PIN_ to PINGRP_
>   tegra2: Add more pinmux functions
>   tegra2: Enable MMC for Seaboard
> 
>  arch/arm/cpu/armv7/tegra2/ap20.c   |5 +-
>  arch/arm/cpu/armv7/tegra2/clock.c  |  840
> +++-
>  arch/arm/cpu/armv7/tegra2/pinmux.c |  540 ++-
>  arch/arm/include/asm/arch-tegra2/clk_rst.h |   84 +--
>  arch/arm/include/asm/arch-tegra2/clock.h   |  149 -
>  arch/arm/include/asm/arch-tegra2/pinmux.h  |  444 ++-
>  board/nvidia/common/board.c|  243 +++--
>  board/nvidia/common/board.h|4 +-
>  board/nvidia/harmony/harmony.c |   26 +
>  board/nvidia/seaboard/seaboard.c   |   35 ++-
>  drivers/mmc/tegra2_mmc.c   |   94 +--
>  drivers/mmc/tegra2_mmc.h   |1 +
>  12 files changed, 1972 insertions(+), 493 deletions(-)
> 
> --
> 1.7.3.1

This works fine on my Seaboard (T20-A03). My Harmony is put away, so I didn't 
test on it.

Tested-by: Tom Warren 

Thanks,

Tom

---
This email message is for the sole use of the intended recipient(s) and may 
contain
confidential information.  Any unauthorized review, use, disclosure or 
distribution
is prohibited.  If you are not the intended recipient, please contact the 
sender by
reply email and destroy all copies of the original message.
---
___
U-Boot mailing list
U-Boot@lists.denx.de
http://lists.denx.de/mailman/listinfo/u-boot


Re: [U-Boot] [PATCH 0/6] tegra2: Add more clock/pinmux functionality

2011-09-11 Thread Simon Glass
Hi,

On Thu, Sep 8, 2011 at 3:11 PM, Simon Glass  wrote:
> This adds to the basic clock functionality already available. The concept
> of a peripheral ID is introduced, and all peripheral clock access is done
> using this ID.
>
[snip]
> Note: These patches include a definition of assert() which I will happily
> remove if the one sent upstream is accepted.

Now that assert() is in master, this needs to be removed. I will send
a new patch set later in the week to tidy this up - just want to allow
a few more days for any comments to come through.

Regards,
Simon

>
>
> Simon Glass (6):
>  tegra2: Rename CLOCK_PLL_ID to CLOCK_ID
>  tegra2: Clean up board code a little
>  tegra2: Add more clock functions
>  tegra2: Rename PIN_ to PINGRP_
>  tegra2: Add more pinmux functions
>  tegra2: Enable MMC for Seaboard
>
>  arch/arm/cpu/armv7/tegra2/ap20.c           |    5 +-
>  arch/arm/cpu/armv7/tegra2/clock.c          |  840 
> +++-
>  arch/arm/cpu/armv7/tegra2/pinmux.c         |  540 ++-
>  arch/arm/include/asm/arch-tegra2/clk_rst.h |   84 +--
>  arch/arm/include/asm/arch-tegra2/clock.h   |  149 -
>  arch/arm/include/asm/arch-tegra2/pinmux.h  |  444 ++-
>  board/nvidia/common/board.c                |  243 +++--
>  board/nvidia/common/board.h                |    4 +-
>  board/nvidia/harmony/harmony.c             |   26 +
>  board/nvidia/seaboard/seaboard.c           |   35 ++-
>  drivers/mmc/tegra2_mmc.c                   |   94 +--
>  drivers/mmc/tegra2_mmc.h                   |    1 +
>  12 files changed, 1972 insertions(+), 493 deletions(-)
>
> --
> 1.7.3.1
>
>
___
U-Boot mailing list
U-Boot@lists.denx.de
http://lists.denx.de/mailman/listinfo/u-boot


[U-Boot] [PATCH 0/6] tegra2: Add more clock/pinmux functionality

2011-09-08 Thread Simon Glass
This adds to the basic clock functionality already available. The concept
of a peripheral ID is introduced, and all peripheral clock access is done
using this ID.

Functions are provided to start, query and adjust peripheral clocks,
including automatic selection of the best available clock based on the
requested rate (this replaces hard-coded divisors).

On the pinmux side we can now select functions for pin groups using the
new pinmux_set_func() function.

Expanded functions are provided to adjust and query PLL clocks.

With a full compliment of clock and pinmux functions, it should no longer
be necessary for board/driver code to directly access clock registers. This
change removes all such accesses.

This functionality will be used for I2C, SPI, LCD, USB, keyboard, NAND and
other drivers for Tegra2.

At then end is a patch to enable MMC on Seaboard, to make it all worthwhile.

Note: These patches include a definition of assert() which I will happily
remove if the one sent upstream is accepted.


Simon Glass (6):
  tegra2: Rename CLOCK_PLL_ID to CLOCK_ID
  tegra2: Clean up board code a little
  tegra2: Add more clock functions
  tegra2: Rename PIN_ to PINGRP_
  tegra2: Add more pinmux functions
  tegra2: Enable MMC for Seaboard

 arch/arm/cpu/armv7/tegra2/ap20.c   |5 +-
 arch/arm/cpu/armv7/tegra2/clock.c  |  840 +++-
 arch/arm/cpu/armv7/tegra2/pinmux.c |  540 ++-
 arch/arm/include/asm/arch-tegra2/clk_rst.h |   84 +--
 arch/arm/include/asm/arch-tegra2/clock.h   |  149 -
 arch/arm/include/asm/arch-tegra2/pinmux.h  |  444 ++-
 board/nvidia/common/board.c|  243 +++--
 board/nvidia/common/board.h|4 +-
 board/nvidia/harmony/harmony.c |   26 +
 board/nvidia/seaboard/seaboard.c   |   35 ++-
 drivers/mmc/tegra2_mmc.c   |   94 +--
 drivers/mmc/tegra2_mmc.h   |1 +
 12 files changed, 1972 insertions(+), 493 deletions(-)

-- 
1.7.3.1

___
U-Boot mailing list
U-Boot@lists.denx.de
http://lists.denx.de/mailman/listinfo/u-boot