Re: Translation of the AppDB

2010-10-20 Thread Yaron Shahrabani
On Wed, Oct 20, 2010 at 6:48 AM, James McKenzie
jjmckenzi...@earthlink.netwrote:

  On 10/19/10 10:20 AM, Yaron Shahrabani wrote:

  On Tue, Oct 19, 2010 at 5:16 PM, Rosanne DiMesio 
 dime...@earthlink.netwrote:

 On Tue, 19 Oct 2010 12:12:33 +0200
 Yaron Shahrabani sh.ya...@gmail.com wrote:

   I see but I had another idea in mind...
  I was thinking about having the possibility to rate and report but
 without
  any way to comment, I mean that you cannot comment in foreign languages
 but
  you can vote and report (any operation that requires clicking is OK,
 typing
  is not).
 
  It's not possible to report without typing, and ratings without the typed
 information as to why the user gave the app that rating would be at best
 useless (Why is this silver? What doesn't work?), and at worst misleading.
 False platinums in particular are already a big problem: users give an app
 a platinum rating, but list tweaks they applied (so it really should be
 gold) or things that didn't work (so it really should be silver). Admins and
 maintainers need that typed information to assess whether a rating is
 correct.

 I fully understand, so reporting is way complicated without typing...
 Well its just a thought but maybe we should consider simplifying the whole
 process, maybe this way more data will be collected.


   Yaron:

 As a maintainer of several applications, I want to know about
 improvements/regressions of all functions in those applications.  Thus, I
 ask those who use the products I maintain to provide details 'What Works'
 and 'What Does Not Work' and these must be, for the present time, in
 English.  Sorry, but English is the Universal language.  The boxes, for
 now, should stay.

So you mean you have got to get some input and there's no other way of
getting input from the users without typing...
Do you feel like you get enough feedback or that automating parts of the
reporting system would make it more widely used.
I'm maintaining lots of translations in the open source world, I never feel
like I get enough feedback and I truly think that if the input was at the
user's fingertips it would help a lot, just my way of looking at it...


 There are many 'drop down' menus that it would be nice to input Hebrew and
 have English populate them.  Would this be a good idea?

The drop down boxes would be great, the simplest way of interaction is what
needed, no ways of typing Hebrew...

(I was thinking of a small Javascript code that will check for foreign
scripts and if the script is different than the Latin script, a Red message
will appear on top of the box and after clicking the button a message will
pop up saying that this message contains non-universal characters and ask
the user if he is sure about sending this report).

Kind regards,
Yaron Shahrabani.


 James McKenzie








Re: [1/7] msxml3/tests: internal schema doc storage tests (resend)

2010-10-20 Thread Alexandre Julliard
Adam Martinson amartin...@codeweavers.com writes:

 +#define _create(cls) cls, #cls
 +
 +#define _obj(cls, ...) _create(cls ## __VA_ARGS__)

You can't do that, varargs macros are not portable.

-- 
Alexandre Julliard
julli...@winehq.org




Re: Translation of the AppDB

2010-10-20 Thread James Mckenzie
Yaron Shahrabani sh.ya...@gmail.com wrote:

On Wed, Oct 20, 2010 at 6:48 AM, James McKenzie
jjmckenzi...@earthlink.netwrote:

[snip]
So you mean you have got to get some input and there's no other way of
getting input from the users without typing...
Do you feel like you get enough feedback or that automating parts of the
reporting system would make it more widely used.
I'm maintaining lots of translations in the open source world, I never feel
like I get enough feedback and I truly think that if the input was at the
user's fingertips it would help a lot, just my way of looking at it...

Correct.  There is quite a wide variation of what can and cannot work that 
having a bunch of selections would be tedious at best, confusing at worst.

 There are many 'drop down' menus that it would be nice to input Hebrew and
 have English populate them.  Would this be a good idea?

The drop down boxes would be great, the simplest way of interaction is what
needed, no ways of typing Hebrew...

Again, the existing drop downs could be translated into Hebrew and then used to 
select the English equivilent.  However, the text boxes will have to remain due 
to wide variations in 'What works' and 'What does not work'.  Too many 
selections can be confusing and makes the web site appear to be slow (I work 
with a web application that has 35,000+ selections, it takes about two minutes 
for the menu to load on a high speed connection and not all Wine users have 
that luxury.)

(I was thinking of a small Javascript code that will check for foreign
scripts and if the script is different than the Latin script, a Red message
will appear on top of the box and after clicking the button a message will
pop up saying that this message contains non-universal characters and ask
the user if he is sure about sending this report).

I would just block it.  Again, English, for now, is the world's universal 
language.  If someone does not know English, there are sites like Babblefish 
that cover just about all languages, including (but not limited to) Hebrew, 
Farsi, Persian, Arabic, Simplified and Traditional Chinese.  Users can avail 
themselves of them and copy/paste into the boxes.  I can understand quite a bit 
of 'translated' English.

James McKenzie






Re: oleaut32/tests: Better reflect the naming scheme

2010-10-20 Thread Alexandre Julliard
André Hentschel webmas...@dawncrow.de writes:

 @@ -10,7 +10,7 @@ C_SRCS = \
   typelib.c \
   usrmarshal.c \
   varformat.c \
 - vartest.c \
 + variant.c \
   vartype.c

Renaming tests should be avoided, it makes it hard to follow the history
on test.winehq.org.

-- 
Alexandre Julliard
julli...@winehq.org




Re: [3/4]strmbase: implement OLE registration in AMovieDllRegisterServer2

2010-10-20 Thread Alexandre Julliard
Aric Stewart a...@codeweavers.com writes:

  HRESULT WINAPI AMovieDllRegisterServer2(BOOL bRegister)
  {
  HRESULT hr;
  int i;
  IFilterMapper2 *pIFM2 = NULL;
 +HMODULE psapi;
 +fnGetModuleFileNameExW pFunc;
 +WCHAR szFileName[MAX_PATH];
 +
 +psapi = LoadLibraryA(psapi.dll);
 +if (psapi)
 +{
 +pFunc = (fnGetModuleFileNameExW)GetProcAddress(psapi, 
 GetModuleFileNameExW);
 +if (pFunc)
 +{
 +if (!pFunc(GetCurrentProcess(), g_hInst, szFileName, MAX_PATH))
 +{
 +ERR(Failed to get module file name for registration\n);
 +return E_FAIL;
 +}
 +}
 +else
 +{
 +ERR(Failed to get get function GetModuleFileNameExW\n);
 +return E_FAIL;
 +}
 +}
 +else
 +{
 +ERR(Failed to load psapi.dll\n);
 +return E_FAIL;
 +}
 +FreeLibrary(psapi);

There's no reason to use psapi for this.

-- 
Alexandre Julliard
julli...@winehq.org




Re: About: d3dx9: Store transform matrix per-sprite.

2010-10-20 Thread Joris Huizer

--- On Tue, 10/19/10, Austin English austinengl...@gmail.com wrote:

 While these emails are very helpful, can you please do a
 reply to the
 original thread? It makes it easier for those of us using
 clients with
 threaded mode to follow.
 
 Thanks!
 
 -- 
 -Austin
 

I can understand that's easier, less messy - I didn't do so up until now as it 
is quite a number of emails per day (especially if tracking both wine-devel and 
wine-patch) -- and my contributions/'contributions' are rare;

Is there a way to do this other than registering to get the emails daily sent 
to me? I usually browse through the updates via the web (the mail archive and 
the patch watcher at http://source.winehq.org/patches/), and as far as I know 
there is no way of replying on either ?

I think I will register to receive emails from the wine-devel and wine-patch 
mailing lists unless there's an other way to reply to thread.

Best regards,
Joris


  




Re: [1/2] msvcrt: Implement _mbsnbcat_s.

2010-10-20 Thread Piotr Caban

Hi,

On 10/20/10 08:49, Andrew Nguyen wrote:
+ * a lead byte and move the pointer back by one for later overwrite. */
+if (get_locale()-locinfo-mb_cur_max  1  
MSVCRT_isleadbyte(*(ptr - 1)))

+size++, ptr--;
You may access dst-1.

+ok(errno == EINVAL, Expected errno to be EINVAL, got %d\n, ret);
Printing ret here may be misleading.

Cheers,
Piotr




Re: Translation of the AppDB

2010-10-20 Thread Yaron Shahrabani
On Wed, Oct 20, 2010 at 3:57 PM, James Mckenzie
jjmckenzi...@earthlink.netwrote:

 Yaron Shahrabani sh.ya...@gmail.com wrote:
 
 On Wed, Oct 20, 2010 at 6:48 AM, James McKenzie
 jjmckenzi...@earthlink.netwrote:
 
 [snip]
 So you mean you have got to get some input and there's no other way of
 getting input from the users without typing...
 Do you feel like you get enough feedback or that automating parts of the
 reporting system would make it more widely used.
 I'm maintaining lots of translations in the open source world, I never
 feel
 like I get enough feedback and I truly think that if the input was at the
 user's fingertips it would help a lot, just my way of looking at it...
 
 Correct.  There is quite a wide variation of what can and cannot work that
 having a bunch of selections would be tedious at best, confusing at worst.
 
  There are many 'drop down' menus that it would be nice to input Hebrew
 and
  have English populate them.  Would this be a good idea?
 
 The drop down boxes would be great, the simplest way of interaction is
 what
 needed, no ways of typing Hebrew...
 
 Again, the existing drop downs could be translated into Hebrew and then
 used to select the English equivilent.  However, the text boxes will have to
 remain due to wide variations in 'What works' and 'What does not work'.  Too
 many selections can be confusing and makes the web site appear to be slow (I
 work with a web application that has 35,000+ selections, it takes about two
 minutes for the menu to load on a high speed connection and not all Wine
 users have that luxury.)

 (I was thinking of a small Javascript code that will check for foreign
 scripts and if the script is different than the Latin script, a Red
 message
 will appear on top of the box and after clicking the button a message will
 pop up saying that this message contains non-universal characters and ask
 the user if he is sure about sending this report).
 
 I would just block it.  Again, English, for now, is the world's universal
 language.  If someone does not know English, there are sites like Babblefish
 that cover just about all languages, including (but not limited to) Hebrew,
 Farsi, Persian, Arabic, Simplified and Traditional Chinese.  Users can avail
 themselves of them and copy/paste into the boxes.  I can understand quite a
 bit of 'translated' English.

So what you are saying is that even if we want to translate the boxes there
are many boxes to translate...
I'm cool with that, its just an idea :).

I want to see what will the Hebrew website bring along, so far I can't
measure any changes in interest but this kind of things takes time so I
won't jump into conclusions...

Kind regards,


 James McKenzie






Re: About: d3dx9: Store transform matrix per-sprite.

2010-10-20 Thread Austin English
On Wed, Oct 20, 2010 at 2:31 PM, Joris Huizer joris_hui...@yahoo.com wrote:

 --- On Tue, 10/19/10, Austin English austinengl...@gmail.com wrote:

 While these emails are very helpful, can you please do a
 reply to the
 original thread? It makes it easier for those of us using
 clients with
 threaded mode to follow.

 Thanks!

 --
 -Austin


 I can understand that's easier, less messy - I didn't do so up until now as 
 it is quite a number of emails per day (especially if tracking both 
 wine-devel and wine-patch) -- and my contributions/'contributions' are rare;

 Is there a way to do this other than registering to get the emails daily sent 
 to me? I usually browse through the updates via the web (the mail archive and 
 the patch watcher at http://source.winehq.org/patches/), and as far as I know 
 there is no way of replying on either ?

 I think I will register to receive emails from the wine-devel and wine-patch 
 mailing lists unless there's an other way to reply to thread.

Registering is the only way I know of. You can setup a filter in your
mail client to ignore them / put them in their own folder so they
don't flood your inbox.

-- 
-Austin




Re: current state of full screen on MacOS?

2010-10-20 Thread James McKenzie

On 7/10/09 6:26 AM, joerg-cyril.hoe...@t-systems.com wrote:

Hi,

I'd like to know whether a MacOSX user can expect full screen modes to work, as
I've heard only rumors and too little facts.  My experience is this:


Joerg:

I have news to announce on this very old thread, but with XQuartz 2.5.3, 
Quake II runs in a on-screen resizing window and the installer ran in 
full-screen mode.


James McKenzie




Re: ws2_32: Add support and tests for WSARecvMsg and IP_PKTINFO.

2010-10-20 Thread Erich Hoover
On Mon, Oct 18, 2010 at 8:58 PM, Mike Kaplinskiy
mike.kaplins...@gmail.com wrote:
 On Sun, Oct 17, 2010 at 5:51 PM, Erich Hoover ehoo...@mines.edu wrote:
 ...
 That's why in the original version I had those parameters split out;
 however, I realized that since the length parameter gets modified by
 WSARecvMsg that it is impossible for the WSAMSG structure (or any of
 its parameters) to disappear before WSARecvMsg completes.  I have
 re-written the tests (see patch 4 at the end) to show that this
 structure gets modified even when an overlapped request is used and
 results in modification of the structure at a later time, the results
 from the test bot can be found here:
    https://testbot.winehq.org/JobDetails.pl?Key=6250

 Fair enough. Would you mind adding a test to see if the flags are
 changed as well (and see if the flags returned by
 WSAGetOverlappedResult are of that sort as well)? If it doesn't you
 can drop lpFlags and just copy it from flags. Otherwise you may want
 to rename it to be less windows-y (like local_flags and flags).


I'm not entirely following you here, but if I understand you correctly
then the lpFlags is appropriate.  The flags in the WSAMSG structure
get modified while the WSAGetOverlappedResult flags do not (which
works as is since the overlapped version of the flags is not a
pointer).  I've changed the patch around a little so that the pointer
version is only used when appropriate (and added tests for this
functionality):
[3/4] 
http://www.compholio.com/wine-kane/patches/2010-10-20/0003-ws2_32-Add-support-for-WSARecvMsg-and-IP_PKTINFO.patch
[4/4] 
http://www.compholio.com/wine-kane/patches/2010-10-20/0004-ws2_32-tests-Add-regression-tests-for-WSARecvMsg-and.patch

Erich Hoover
ehoo...@mines.edu