[Question] trinidad-skins.xml in a jar

2006-11-08 Thread Jeanne Waldman
I have two questions about jar'ing up the skins. Let's say someone has jar'd up their skin and the trinidad-skins.xml file. I have a jar with this directory structure: META-INF trinidad-skins.xml skin customSkin.css images dateButtonPurple.gif In trinidad-skins.xml, I

[Question] Copying code from MyFaces

2006-11-08 Thread Scott O'Bryan
Hey Guys, All arguments about the need for a common code package aside (yes, I will continue to champion this), Trinidad has the need to create container abstractions for some of our initialization services. We're basically going to use the external context to pass into these services

Re: Re: make ValueMap public

2006-11-08 Thread Arjuna Wijeyekoon
ok, since we can't use the commons-collections, let's make ValueMap public. I was going to call it ReverseHashMap, but since BidiMap seems to be more popular (especially since commons-collections has a BidiMap) can I call this BidiHashMap ? On 10/27/06, Matthias Wessendorf [EMAIL PROTECTED]

Re: Re: make ValueMap public

2006-11-08 Thread Arjuna Wijeyekoon
Also, can I call this method getInvertedMap? MapV,K BidiHashMapK,V.getInvertedMap() ? On 11/8/06, Arjuna Wijeyekoon [EMAIL PROTECTED] wrote: ok, since we can't use the commons-collections, let's make ValueMap public. I was going to call it ReverseHashMap, but since BidiMap seems to be more

Re: Re: make ValueMap public

2006-11-08 Thread Arjuna Wijeyekoon
http://issues.apache.org/jira/browse/ADFFACES-282 --arjuna On 11/8/06, Arjuna Wijeyekoon [EMAIL PROTECTED] wrote: Also, can I call this method getInvertedMap? MapV,K BidiHashMapK,V.getInvertedMap() ? On 11/8/06, Arjuna Wijeyekoon [EMAIL PROTECTED] wrote: ok, since we can't use the

Re: api cleanup for UIXCollection

2006-11-08 Thread Arjuna Wijeyekoon
Matthias, I forgot to deprecate the UIXCollection.clearCurrencyStringCache() method. I also forgot to add javadoc to the UIXCollection.getClientRowKeyManager() method. I have uploaded an additional patch to address these issues. Can you please commit it? thanks! Arjuna

Base64OutputStream needs a cleanup

2006-11-08 Thread Arjuna Wijeyekoon
The public class: org.apache.myfaces.trinidad.util.Base64OutputStream is annoying me. 1. it has a finish() method instead of a close() method. 2. it doesn't have a close() method at all. It should have one that delegates to the underlying Writer 3. it doesn't have a flush() method that

When notSerializableException is thrown it is hard to find the problem

2006-11-08 Thread Arjuna Wijeyekoon
Sometimes, when people use complete client-side state saving, or they passivate the HttpSession, they get a NotSerializableException thrown while Serializing the component state tree. Usually the cause is user error - the user did not use a ValueBinding to bind to some unSerializable object. It

deprecating methods

2006-11-08 Thread Arjuna Wijeyekoon
Usually method deprecation is done like: /** * @deprecated use the foobar method instead */ public void foo() In addition , do we have to do: /** * @deprecated use the foobar method instead */ @Deprecated public void foo() ??

Re: deprecating methods

2006-11-08 Thread Simon Lessard
I would say yes as annotations are the way to go now. Regards, ~Simon On 11/8/06, Arjuna Wijeyekoon [EMAIL PROTECTED] wrote: Usually method deprecation is done like: /** * @deprecated use the foobar method instead */ public void foo() In addition , do we have to do: /** * @deprecated use

Re: Base64OutputStream needs a cleanup

2006-11-08 Thread Adam Winer
I agree, it'd be good to fix all those. -- Adam On 11/8/06, Arjuna Wijeyekoon [EMAIL PROTECTED] wrote: The public class: org.apache.myfaces.trinidad.util.Base64OutputStream is annoying me. 1. it has a finish() method instead of a close() method. 2. it doesn't have a close() method at all.

Re: Re: Re: make ValueMap public

2006-11-08 Thread Adam Winer
Shouldn't it be BidiMap? Not BidiHashMap? -- Adam On 11/8/06, Arjuna Wijeyekoon [EMAIL PROTECTED] wrote: http://issues.apache.org/jira/browse/ADFFACES-282 --arjuna On 11/8/06, Arjuna Wijeyekoon [EMAIL PROTECTED] wrote: Also, can I call this method getInvertedMap? MapV,K

Re: Re: deprecating methods

2006-11-08 Thread Simon Lessard
Adding it is more purism than anything else I agree. However, it is a Java 5 standard, it makes Eclipse happier and allow to do some runtime check to see if a method is deprecated or not. The latter is not of much use for Trinidad, but adding @Deprecated takes about 3 seconds and there's no

Re: Base64OutputStream needs a cleanup

2006-11-08 Thread Simon Lessard
Yeah that would be a good idea. On 11/9/06, Adam Winer [EMAIL PROTECTED] wrote: I agree, it'd be good to fix all those. -- Adam On 11/8/06, Arjuna Wijeyekoon [EMAIL PROTECTED] wrote: The public class: org.apache.myfaces.trinidad.util.Base64OutputStream is annoying me. 1. it has a